Upgrading ZFS - Dependency Problem

    • OMV 4.x
    • Upgrading ZFS - Dependency Problem

      Hi All,

      This is somewhat more of a debian question, but there may/should be an OMV solution, so I'm putting it here...

      I'm using OMV 4 with ZFS plugin. But now I need to update my ZFS version to access some of the newer features. I got the source and made new packages (0.8.0-150), installed them with dpkg and things work fine, but now my apt dependencies are hosed and won't let me install anything else, because openmediavault-zfs depends on the old versions.

      How do I get an openmediavault-zfs package that does not depend on the old zfs packages (spl-dkms and friends)? I couldn't find the source repo for it, not sure where that is, so I can't rebuild from source. Or is there a debian way to permanently ignore the dependencies?

      Any help welcome!

      Dirk