Nextcloud changes one way; Windows changes won't stick

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Nextcloud changes one way; Windows changes won't stick

      I have Samba enabled, and at first, I followed these instructions to change the permissions in the smb.conf file so that I could access Nextcloud from Windows. That didn't work. So I poked around more and went to Shared Folders > PHS > ACL and under "Extra Options," changed Owner and Group to www-data. That seemed to solve the issue and now I can both access my files on Windows and the web app for NextCloud. The issue now is that if I make a change on Nextcloud, it shows up in Windows. But if I make a change in Windows, Nextcloud web app won't show it (ignores it). It's like it's syncing one-way. I am totally lost on how to set up permissions. But I'm sure it's a permissions issue.
    • I deleted NextCloud and reinstalled everything, and I got the same issue. Didn't have permission to open the folder on Windows once I logged into NextCloud. I went to Samba settings in OMV, and under Shares, I chose the data folder where I have all my NextCloud stuff, and clicked on Edit. I toggled on Inherit Permissions. Once I did that, I could access the folder from Windows. What's weird, is if I toggle it off again, I can still access. But I still have the same issue where if I create a folder in Windows, the NextCloud web app won't show it.

      But then I confirmed that the folder is *indeed* there, by using Shellinabox to cd to the files section of my NextCloud data. I typed ls, and sure enough, my newly created folder is there. So it must be that NextCloud is not adding the folder to its database and so not showing up in the NextCloud web app? I guess?
    • You can achieve this by rescanning the NC filesystem.

      Source Code

      1. docker exec -it nextcloud bash
      2. sudo -u abc php /config/www/nextcloud/occ files:scan --all
      3. exit
      also:

      Morlan wrote:

      I faced a similar problem since I also wanted to have access to my nextcloud files via smb.
      The best solution I came up (which is working flawlessly so far) is to integrate my main datafolder not directly into Nextcloud, but connect it as an external storage. This way the permissions are not an issue and Nextcloud is always in sync with changes made via smb.

      docs.nextcloud.com/server/16/a…ge_configuration_gui.html


      Morlan wrote:

      You have to create a shared folder and share it via smb. In Nextcloud you to App -> deactivated Apps and there activate the External storage support-App.
      Then go to settings. Under administrative settings you can allow users to mount external storage. Then with your regular user account you go to settings -> External storage.
      Choose a displayed folder name and SMB / CIFS. Authentification Username and Password. Host is the IP-Adress of your OMV-Machine. Share is the name of the shared folder. Subfolder and Domain can be left blank. Lastly enter a Username and PW of an OMV-User who has R/W Privileges to the shared folder.
      Thats how it worked in my case. If you want to share files from this folders with others you also want to check sharing allowd behind the ...-menu.

    • This is *exactly* the information I'm looking for!!! Thank you!!! I want to have symlinks, remote access, etc. But as far as I understand, the desktop client is for syncing, which I don't want. My laptop has 1 TB, but I have a massive amount of documents, pictures, videos, etc from over the years, and buying expensive laptop drives every time I run out of room is going to get pricy. So I figured it would be best to have a central server with all my files at home, but access to this server on each of my laptops. I also homeschool my kids, where someone is using a laptop, and I might need access to my files in a simple way. So my Odroid HC2 setup will make things easier.

      Thanks so much for your help! I was able to successfully add am external drive to NextCloud. My OCD is a bit bothered that I have to do it that way, but it will do. :)