letsencrypt for docker

    • letsencrypt for docker

      Hi,

      I have been told that let's encrypt plugin is no longer under maintenance and I should use letsencrypt in docker instead.
      There are 2 versions in docker, jrcs/letsencrypt-nginx-proxy-companion and linuxserver/letsencrypt.

      I believe that the former one has nginx reserve proxy included which I have no idea what is it, shall I just install the latter one if I just want simply secured connection for my omv?

      thanks
    • Morlan wrote:

      Use the latter. I think the community has the most experience with it and can help troubleshoot. It also has an included nginx reverse proxy.

      aldrick wrote:

      Hi,
      You should use this one: linuxserver/letsencrypt.

      For you omv having the SSL, you'll have to create a file omv.subdomain.conf as in this following thread.

      cj2tech wrote:

      whenever you use a docker container look at what is supported by the community of whatever application you are running. most of the time it will be self-named (ie. emby/embyserver) or linuxserver.
      thank you guys! i will give it a shot!
    • Hi,


      I used this video: youtube.com/watch?v=pRt7UlQSB2…I2SLMIbc4PM&index=56&t=0s as a guide to try to install LetsEncrypt with NoIp on Docker but no luck.

      Note: Sensitive data has been changed.

      I'm currently using Let's Encrypt plugin in OMV as well.
      I notice in the video, TechnoDad port forwarded port 80>90, 443>450.
      I don't want to change my current config like that.

      Is there an alternative solution ?

      HTML Source Code

      1. http-01 challenge for site1.mydomain.com
      2. http-01 challenge for site2.mydomain.com
      3. http-01 challenge for site3.mydomain.com
      4. Waiting for verification...
      5. Challenge failed for domain site1.mydomain.com
      6. Challenge failed for domain site2.mydomain.com
      7. Challenge failed for domain site3.mydomain.com
      8. http-01 challenge for site1.mydomain.com
      9. http-01 challenge for site2.mydomain.com
      10. http-01 challenge for site3.mydomain.com
      11. Cleaning up challenges
      12. Some challenges have failed.
      13. IMPORTANT NOTES:
      14. - The following errors were reported by the site3:
      15. Domain: site1.mydomain.com
      16. Type: unauthorized
      17. Detail: Invalid response from
      18. http://site1.mydomain.com/.well-known/acme-challenge/T0xc0td4-Ro0HSB9tDKvBnDwChbma9pxy8pwvDomd8U
      19. [69.1.2.3]: "<html>\r\n<head><title>404 Not
      20. Found</title></head>\r\n<body bgcolor=\"white\">\r\n<center><h1>404
      21. Not Found</h1></center>\r\n<hr><center>"
      22. Domain: site2.mydomain.com
      23. Type: unauthorized
      24. Detail: Invalid response from
      25. http://site2.mydomain.com/.well-known/acme-challenge/av2dnhMiYl3kP1GmEFTPtRUGLM83KEe59gJ6nsR-pOs
      26. [69.1.2.3]: "<html>\r\n<head><title>404 Not
      27. Found</title></head>\r\n<body bgcolor=\"white\">\r\n<center><h1>404
      28. Not Found</h1></center>\r\n<hr><center>"
      29. Domain: site3.mydomain.com
      30. Type: unauthorized
      31. Detail: Invalid response from
      32. http://site3.mydomain.com/.well-known/acme-challenge/fYYlvP_xOSYj2rdH23LB2HdR5u_ipdBb-_Ll34YB7D0
      33. [69.1.2.3]: "<html>\r\n<head><title>404 Not
      34. Found</title></head>\r\n<body bgcolor=\"white\">\r\n<center><h1>404
      35. Not Found</h1></center>\r\n<hr><center>"
      36. To fix these errors, please make sure that your domain name was
      37. entered correctly and the DNS A/AAAA record(s) for that domain
      38. contain(s) the right IP address.
      39. ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container
      40. ^C
      Display All
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10

      The post was edited 1 time, last by tinh_x7 ().

    • tinh_x7 wrote:

      Hi,


      I used this video: youtube.com/watch?v=pRt7UlQSB2…I2SLMIbc4PM&index=56&t=0s as a guide to try to install LetsEncrypt with NoIp on Docker but no luck.

      Note: Sensitive data has been changed.

      I'm currently using Let's Encrypt plugin in OMV as well.
      I notice in the video, TechnoDad port forwarded port 80>90, 443>450.
      I don't want to change my current config like that.

      Is there an alternative solution ?
      port forwaded is to preserve actual port 80 & 443 of OMV webGUI, but if you do not want to do it, you need to change default port 80 & 443 in OMV WebGUI and configure letsencrypt to use port 80 & 443
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ; ctop
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • I've ported 80>90, and 443>450, but still no luck.


      Source Code

      1. E-mail address entered: test111@outlook.com
      2. http validation is selected
      3. Certificate exists; parameters unchanged; starting nginx
      4. [cont-init.d] 50-config: exited 0.
      5. [cont-init.d] 99-custom-files: executing...
      6. [custom-init] no custom files found exiting...
      7. [cont-init.d] 99-custom-files: exited 0.
      8. [cont-init.d] done.
      9. [services.d] starting services
      10. [services.d] done.
      11. ifelse: fatal: unable to exec --cap-add=NET_ADMIN: No such file or directory
      12. [cmd] --cap-add=NET_ADMIN exited 127
      13. [cont-finish.d] executing container finish scripts...
      14. [cont-finish.d] done.
      15. [s6-finish] waiting for services.
      16. [s6-finish] sending all processes the TERM signal.
      17. [s6-finish] sending all processes the KILL signal and exiting.
      Display All
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10

      The post was edited 2 times, last by tinh_x7 ().