NextCloud Slow, SMB/CIFS Blazing Fast - Help

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • NextCloud Slow, SMB/CIFS Blazing Fast - Help

      I have NextCloud successfully installed on OMV, including remote access. If I transfer a 2 GB folder using my Windows filesystem (Samba), I can get speeds up to 90 mb/s, so it transfers very quickly. However, if I use the web interface to upload something, or the NextCloud desktop app to download something (download so it can sync), it's ridiculously slow. Example: the desktop app says I have anywhere from 6-8 hours left to download 2 GB.

      Is there some kind of configuration that I don't know about to make things run faster? I used the Techno Dad tutorials to get this set up.

      Just for clarification on my setup, I have a separate shared folder with SMB/CIFS access so I can access it in Windows, and then I added it to NextCloud as an external drive. The 2 GB folder I'm trying to sync between my computer and NextCloud is in the regular files section of NextCloud and not in my external drive that is a shared folder with SMB/CIFS.
    • I have the same issue as you.
      SMB fast as but sync suuuper slow. The nextcloud app syncing terribly slow, and get gateway timeout most times. I know from previous nextcloud servers I set up you can edit the php.ini file, I did this with nc on omv but the settings have no effect, I increased my max upload to 2gb but once I restarted the containers the settings/values withing nextlcoud under monitoring is unchanged.

      Anyone here with suggestions it would be greatly appreciated..
    • I edited this
      nano /etc/php/7.0/fpm/php.ini


      memory limit 256M
      post max size 80M
      upload max filesize 2000M

      Once I started syncing it seems better, not sure if I'm just over tired from setting everything up today because I like you also had some issues with setting up the SSL with letsencrypt, but it seems faster and better though. But the display under maintenance is unchanged which still shows

      PHP

      Version: 7.3.6
      Memory Limit: 512 MB
      Max Execution Time: 3600
      Upload max size: 2 MB

      The post was edited 2 times, last by cryptopher ().

    • New

      @threehappypenguins
      Did you try the above? did it help? I'm still experiencing slow sync speeds using the Netxcloud desktop app, get gateway time-out errors.

      I might just revert back to using my Pi as entry point to my data through nextcloud and have my drives connected via OMV. Instead of running nextcloud in a container within OMV, I will run nexcloudpi and link my data using SMB to OMV.