Raspberry Pi 4 HELP PLS!!!

    • OMV 4.x
    • Resolved
    • Raspberry Pi 4 HELP PLS!!!

      Hi, I've been using the 'beta' version of OMV 4 on the Raspberry Pi 4. Whether it is 'beta' or not i saw it was published on source forge. I decided to download it to use on my Pi 4 and i've done this MULTIPLE TIMES. However, every single time if i leave the perfectly working server alone for roughly 2 WEEKS it breaks just after. All i run on it is a Plex, VPN and File Server. It used to work fine on my raspberry pi 3 but then the new raspberry came out and i wanted that one. But for some reason, every time i keep going to the web interface it just doesn't load and when i head to the plex web interface it doesn't load either. The file serve works for about 2 SECONDS then the connection drops. The only thing that works is the VPN server but even then it still stops working at starts again. When i look over at the Pi both lights just keep flashing (RED AND GREEN) don't know what that's for. But i have to constantly re-flash my device because it fails on me most of the time. I WANT THIS TO WORK WITH OMV but nothing is working.

      Just looking for some advice because it is getting a bit frustrating at the minute, having to constantly take out the micro sd card and flash a new copy of the Pi 4 OMV image and re configure all my services and settings etc.

      ANY HELP WOULD BE APPRECIATED!

      PS. Could you also recommend any other similar software like OMV that i could use incase this next fresh install i am doing doesn't work.

      Thanks.
    • Hey I am a new to this site as well. I have been using OMV for 3 years with a Pi 3. I could not tell you off the top of my head what OMV file I am using but could log in and see but for this post it is unimportant.

      When you are asking for help in sites like this "You need to specifically say which file name you are using and are looking for help with" even if is a Beta file name state the file name and version if one exists you are using and asking questions about.
    • My RPi4 is running the Raspbian Buster Lite image with OMV 5.x installed using the guide - forum.openmediavault.org/index…OMV5-on-Debian-10-Buster/. I don't remember having to do anything special.
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • LinuxG6702 wrote:

      Have you experienced any problems when running OMV 5?
      Not really but I am not your typical OMV user and I am porting plugins to run on OMV 5.x.

      LinuxG6702 wrote:

      If i was to install OMV 5 using the guide you posted. Do i just copy and paste the shell script. How would i do it
      Read through the guide. It tells you want you need to know but I'm pretty sure it is just cut&paste.
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • LinuxG6702 wrote:

      So would it be worth trying to install OMV 5 and seeing if it runs ok with PLEX, VPN and FILE SERVER?
      Sure.

      LinuxG6702 wrote:

      About the Guide for OMV 5 i take it i just copy line by line in to the Terminal? Do i do both the Source Code and the Shell Script or just the Shell Script
      The first source code box gets cut & paste as one block. While you could cut & paste the entire shell script listing, I would cut & paste one line at a time except for lines 7-12 which should be cut&paste together.
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • @ryecoaaron

      I've installed omv 5 on a fresh copy of Debian Buster and accessed the web gui of OMV. Everything was working fine until i was about to change my host name and web password. when i went to press save and then apply configuration after changing some settings my screen would just be stuck on loading for 2 minutes. Then it would say 192.168.x.x. took too long to respond. Then when i go to ssh to it it says the device refused to connect when i have allowed root login on the web gui for ssh and when i go on the web gui again and refresh it just says it took too long to respond.

      I then took out that micro sd card and put in my OTHER fresh copy of OMV FOR RPI 4 and it was working fin as well. But now it does the same thing. When i go to make a change it is just stuck on loading. Then says internal server error when i refresh the page. And when i go to make the same change again it just says bad error or just error or and error has occured

      I NEED HELP PLEASE!


      If all is just failing to work could you recommended any other software that is similar to OMV that i could run on the RPI

      Thanks
    • LinuxG6702 wrote:

      Everything was working fine until i was about to change my host name and web password.
      Are you using the hostname or IP address to access the web interface?

      LinuxG6702 wrote:

      Then when i go to ssh to it it says the device refused to connect when i have allowed root login on the web gui for ssh
      ssh either isn't enabled or root login is disabled.

      I would try doing things without changing the hostname or network settings for now. I will look into why the hostname change is failing if it happens on my rpi but I'm guessing it is your network where the new hostname doesn't get registered in DNS.


      LinuxG6702 wrote:

      f all is just failing to work could you recommended any other software that is similar to OMV that i could run on the RPI
      Strange question to ask me. Why would I recommend something other than OMV? Using sbc/arm boards as a server requires some command line sometimes.
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • @ryecoaaron

      i am using the ip address

      ssh is enabled with root access. I know the hostname has been registered because i can see it under my network on a different computer. I've used OMV on my RPI 3 and NEVER HAD ANY ISSUES.

      For some reason i am having all of these problems for the first time on the RPI 4. Probably because a stable version hasn't been released for the RPI 4 yet. IDK.[/b]

      I've manged to finally change the hostname, web password, mounted my external disk, create a user all in 45 mins. (Should've taken 2 mins)

      but that was because i had to frequently refresh the page, click ok when a message box appeared saying error occurred.

      Do you get ANY ERRORS when using the web gui on ur OMV 5 . Cuz even when i had installed OMV 5 on a fresh install of Debian Buster i still run into errors.

      I am so CLUELESS about what to do. I really want to use OMV because i like it. I can do what i want from the command line but its just harder to debug or to restart and why do all of that when there is software out there to do it. I've really enjoyed using OMV but ever since i upgraded to the PI 4 my experience has just been like *poo* .


      In the image,

      Whenever i even just click anything on the side bar i get messages like these. Never got them before on my PI 3


      ANY HELP IS APPRECIATED!


      Thanks
      Images
      • Screenshot 2019-08-19 at 16.24.22.png

        83.73 kB, 1,357×667, viewed 71 times
    • LinuxG6702 wrote:

      Probably because a stable version hasn't been released for the RPI 4 yet.
      Yep.

      LinuxG6702 wrote:

      I've manged to finally change the hostname, web password, mounted my external disk, create a user all in 45 mins. (Should've taken 2 mins)
      I just did that on my RPi4 in between other things and it only took a few minutes. Never had to refresh the page.

      LinuxG6702 wrote:

      Do you get ANY ERRORS when using the web gui on ur OMV 5 . Cuz even when i had installed OMV 5 on a fresh install of Debian Buster i still run into errors.
      Nope.

      LinuxG6702 wrote:

      I am so CLUELESS about what to do. I really want to use OMV because i like it. I can do what i want from the command line but its just harder to debug or to restart and why do all of that when there is software out there to do it. I've really enjoyed using OMV but ever since i upgraded to the PI 4 my experience has just been like *poo* .
      Not sure what to tell you other than don't use an RPi4 yet. I am working on a new image but I don't have a lot of time and my suggestion of using raspbian buster lite and OMV 5.x has been solid for me. If your RPi3 is good, keep using it until I have something stable. There aren't a lot of option for the RPi4 for anything yet.
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • LinuxG6702 wrote:

      so for your RPI 4 did u just install buster lite, then use the guide on installing omv 5 and just setup everything from there
      More or less. I don't need the guide to install OMV. I've done it thousands of times.

      LinuxG6702 wrote:

      I wasn't using buster lite, i was using buster with desktop. but i will try with buster lite(probably won't make a difference )
      That makes a lot of sense and yes, using the desktop can cause you problems ESPECIALLY with networking. That would have saved us some time. We always have highly recommended to not use a desktop environment on any OMV system. I did mention in the original suggestion to use Lite.
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Users Online 2

      2 Guests