BTRFS and UDEV

    • OMV 4.x
    • BTRFS and UDEV

      Hello, I don't speak English. I write via translator.
      I see it is a new OMV5 but as I found it has not solved the problems with BTRFS at all.
      As you can see in the attached picture, I see almost no information about the repository. Although it works and has shared folders.
      The first question is: Can I fix it to show the list correctly?
      And the second question: Can I use UDEV or something else to set up hard disk names (sdaa, sdab, sdba, sdbb) for easier organization.
      And please for specific advice, not a link to the archwiki.
      I've been looking for a long time, and I've never found anything serious.
      I am an old MS Windows user and I chose OMV because Windows Home Server is out of date.

      Thank you all for your advice :)
      Images
      • btrfs.jpg

        143.44 kB, 1,142×801, viewed 200 times
    • I know, however, how I read elsewhere. He will be released soon.
      This screen is from a running OMV4. I just tried in VirtualBox that OMV5 behaves the same way.

      The list shows that the units are not connected, but they actually are. If they weren't, you wouldn't be able to create a shared folder.

      If I create a btrfs file system in the web interface, everything is fine. But as soon as I add a mirror through CLI, the information changes as shown. And if I want to disconnect disks so it is not via the web. It writes a mistake.

      I guess the problem is that the first disk is SDC and the second is SDB.
      So if I could name the disks (sda, sdb, sdac, ..) in UDEV, maybe the problem would be solved.

      However, I was hoping that OMV5 would come with full support for btrfs via the if web. :(





      Vím, nicméně jak jsem se dočetl jinde. Brzy bude propuštěn.
      Tento screen je z bežícího OMV4. Jen jsem si ozkoušel ve VirtualBoxu že OMV5 se chová úplně stejně.

      Seznam ukazuje že jednotky nejsou připojené, ale oni ve skutečnosti jsou. Pokud by nebyli, nešla by vytvořit sdílená složka.

      Pokud vytvořím ve web interface btrfs file system, vše je v pořádku. Ale jakmile přes CLI přidám zrcadlo tak se informace změní tak jak je vidět na obrázku. A pokud bych chtěl disky odpojit tak to ani přes web nejde. Napíše to chybu.

      Tuším že problém je v tom že první disk je SDC a druhý je potom SDB.
      Kdybych tedy mohl disky fixně pojmenovat (sda, sdb, sdac,..) v UDEV, možná by se problém vyřešil.


      Nicméně teda doufal jsem že OMV5 přijde s úplnou podporou btrfs přes web if. :-(
    • If you create a file system in OMV you should always do it by the WebUI. Otherwise it is not registered in the backend database.
      See this link: Docs » Administration » Storage » Filesystems

      There are only few exceptions which are also explained in the new OMV documentation.


      RDan wrote:

      If I create a btrfs file system in the web interface, everything is fine. But as soon as I add a mirror through CLI, the information changes as shown.
      Nevertheless, according to the documentation above what you do is an explicitely allowed exception.


      So indeed it really looks like a problem in OMV.
      OMV 3.0.99 (Gray style)
      ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

      The post was edited 3 times, last by cabrio_leo ().

    • Well I thought at least someone would help with that UDEV.

      I've been trying it for a long time and nothing.

      And it would help me a lot.


      This is an attempt I made, but it doesn't work.

      KERNEL=="sd?", SUBSYSTEM=="block", DEVPATH=="*host19/port-19:5*", NAME="sdbc", RUN+="/usr/bin/logger My disk ATTR{partition}=$ATTR{partition}, DEVPATH=$devpath, ID_PATH=$ENV{ID_PATH}, ID_SERIAL=$ENV{ID_SERIAL}", GOTO="END_20_PERSISTENT_DISK"

      KERNEL=="sd?*", ATTR{partition}=="1", SUBSYSTEM=="block", DEVPATH=="*host19/port-19:5*", NAME="sdbc%n" RUN+="/usr/bin/logger My partition parent=%p number=%n, ATTR{partition}=$ATTR{partition}"
      LABEL="END_20_PERSISTENT_DISK"