OpenVPN Setup

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OpenVPN Setup

      Hi All,
      Need assistance for setting up Openvpn-As via Docker.
      I have OMV_4_Rock64 intalled on eMMC of Rock64 SBC.

      I followed every bit of this video from TechnoDad How to OpenVPN-as on Openmediavault) to install openvpn-as via Docker
      Installation went OK with no errors, however am stuck at the point :/ when trying to use openvpn-as via the web for the first time (myip:943/admin)

      Any help to resolve this will be highly appreciated, as am quite a noob.

      thanks

      The post was edited 2 times, last by MohitSapru ().

    • Hi, I just had the same problem and solved it the following way:

      My host interface is not etho.
      Execute ip a on your server and look for the entry that contains the local IP adress of your server.
      For me it looks like this:

      Source Code

      1. 2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
      2. link/ether xy ff:ff:ff:ff:ff:ff
      3. inet my.ip.adress.here/24 brd 192.168.0.255 scope global enp3s0
      4. valid_lft forever preferred_lft forever
      Afterwards I was able to access the openvpn configuration page at https://my-ip:943/admin

      Strangely though, the openvpn-as logs accessed via docker logs -tf openvpn-as point me to a wrong IP address to access the admin and client gui.
      The address is in the 172.18.0.x range. ip a shows a network device with a name starting with br- and than a hexadecimal number.
      Does anyone know what that is?