OMV5 setup notifications don't work

    • OMV 5.x (beta)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV5 setup notifications don't work

      Hi have freshly installed OMV5.0.5 today and have a small problem,

      i can't save the notification settings - i don't get a error msg on screen but the apply changes bar will show up again every time i hit accept.

      have tried many different email servers/email combinations with the same result.

      my syslog shows the following msg:

      Source Code

      1. Sep 9 21:48:00 openmediavault omv-engined[7103]: PHP Fatal error: Uncaught Error: Call to a member function preDeploy() on null in /usr/share/openmediavault/engined/rpc/config.inc:161
      2. Sep 9 21:48:00 openmediavault omv-engined[7103]: Stack trace:
      3. Sep 9 21:48:00 openmediavault omv-engined[7103]: #0 [internal function]: Engined\Rpc\Config->applyChanges(Array, Array)
      4. Sep 9 21:48:00 openmediavault omv-engined[7103]: #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      5. Sep 9 21:48:00 openmediavault omv-engined[7103]: #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      6. Sep 9 21:48:00 openmediavault omv-engined[7103]: #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusrj...', '/tmp/bgoutputCP...')
      7. Sep 9 21:48:00 openmediavault omv-engined[7103]: #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      8. Sep 9 21:48:00 openmediavault omv-engined[7103]: #5 /usr/share/openmediavault/engined/rpc/config.inc(186): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      9. Sep 9 21:48:00 openmediavault omv-engined[7103]: #6 [internal function]: Engined\Rpc\Config->applyChangesBg(Array, Array)
      10. Sep 9 21:48:00 openmediavault omv-engined[7103]: #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      11. Sep 9 21:48:00 openmediavault omv-engined[7103]: #8 /usr/share/php/openmediavault in /usr/share/openmediavault/engined/rpc/config.inc on line 161
      12. Sep 9 21:48:44 openmediavault postfix/postdrop[12311]: warning: unable to look up public/pickup: No such file or directory
      Display All
      anyone has a clue how i can fix this?!? every thing else is working like a charm - including docker&portainer (man was hard to get into it but now its ok :) )
    • I am having a similar problem on OMV5, both on an Nanopi M4 and a Odroid H2. In my case the save is accepted. I just don't receive a test email. I have a main and a backup email listed and nothing comes to either email. I have done this numerous times on OMV4 installs without any issues.

      This is my syslog:

      Source Code

      1. Sep 9 16:06:39 m4omv5 rsyslogd: [origin software="rsyslogd" swVersion="8.1901.0" x-pid="1452" x-info="https://www.rsyslog.com"] rsyslogd was HUPed
      2. Sep 9 16:06:45 m4omv5 postfix/pickup[24313]: 5576E27C510: uid=0 from=<root>
      3. Sep 9 16:06:45 m4omv5 postfix/cleanup[26214]: 5576E27C510: message-id=<20190909210645.5576E27C510@m4omv5.local>
      4. Sep 9 16:06:45 m4omv5 postfix/qmgr[24315]: 5576E27C510: from=<my.smtp.server>, size=418, nrcpt=4 (queue active)
      5. Sep 9 16:06:45 m4omv5 postfix/smtp[25757]: SMTPS wrappermode (TCP port 465) requires setting "smtp_tls_wrappermode = yes", and "smtp_tls_security_level = encrypt" (or stronger)
      6. Sep 9 16:06:45 m4omv5 postfix/pipe[26216]: 5576E27C510: to=<openmediavault-notification@localhost.localdomain>, relay=omvnotificationfilter, delay=0.14, delays=0.07/0.02/0/0.05, dsn=2.0.0, status=sent (delivered via omvnotificationfilter service)
      Retired. I love to garden and mess with computers. The more I mess with both the less I know about either.
      OMV 4.1.23-1 on a pair of Odroid hc2's w/ 4TB WD Blue. Running Nextcloud, Plex, & Heimdall - and a Raspberry Pi 3 running Pi-hole.
      Testing OMV 5.0.5 5.0.6 beta on an Odroid H2, HP dx2400, and Nanopi M4.
    • Post your settings. I just duplicated my omv4 settings and everything works well. I am using gmail which seems to work better than most.
      omv 4.1.23 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Not much to see. I have obfuscated my user name and emails. Like you I copied my omv4 settings. Just before posting this, I switched to gmail smtp and no different.
      Retired. I love to garden and mess with computers. The more I mess with both the less I know about either.
      OMV 4.1.23-1 on a pair of Odroid hc2's w/ 4TB WD Blue. Running Nextcloud, Plex, & Heimdall - and a Raspberry Pi 3 running Pi-hole.
      Testing OMV 5.0.5 5.0.6 beta on an Odroid H2, HP dx2400, and Nanopi M4.
    • I'm not using ssl/tls and using port 25. I'm also using charter's (my ISP) smtp server.
      omv 4.1.23 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Well, I'll be blessed. On a whim I changed the port setting to 587 and it worked like a charm. AT&T plainly specifies port 465 and I have four OMV4 machines currently running notifications that way. Thanks for poking me a bit to help get me there.
      Retired. I love to garden and mess with computers. The more I mess with both the less I know about either.
      OMV 4.1.23-1 on a pair of Odroid hc2's w/ 4TB WD Blue. Running Nextcloud, Plex, & Heimdall - and a Raspberry Pi 3 running Pi-hole.
      Testing OMV 5.0.5 5.0.6 beta on an Odroid H2, HP dx2400, and Nanopi M4.
    • Now if I just knew what the messages meant.
      Display Spoiler
      /etc/cron.daily/openmediavault-cron-apt:
      touch: cannot touch '/var/log/cron-apt/log': No such file or directory
      /usr/sbin/cron-apt: 155: /usr/sbin/cron-apt: cannot create /var/log/cron-apt/log: Directory nonexistent
      /usr/sbin/cron-apt: 155: /usr/sbin/cron-apt: cannot create /var/log/cron-apt/log: Directory nonexistent
      /usr/sbin/cron-apt: 155: /usr/sbin/cron-apt: cannot create /var/log/cron-apt/log: Directory nonexistent
      Retired. I love to garden and mess with computers. The more I mess with both the less I know about either.
      OMV 4.1.23-1 on a pair of Odroid hc2's w/ 4TB WD Blue. Running Nextcloud, Plex, & Heimdall - and a Raspberry Pi 3 running Pi-hole.
      Testing OMV 5.0.5 5.0.6 beta on an Odroid H2, HP dx2400, and Nanopi M4.
    • changing the port dosn't solve anything here, i will always get the php error - but only if i'm saving the notification setup...

      other changes will be saved without problem...

      always the same error in syslog:

      Source Code

      1. Sep 10 07:55:18 openmediavault omv-engined[26763]: PHP Fatal error: Uncaught Error: Call to a member function preDeploy() on null in /usr/share/openmediavault/engined/rpc/config.inc:161
      2. Sep 10 07:55:18 openmediavault omv-engined[26763]: Stack trace:
      3. Sep 10 07:55:18 openmediavault omv-engined[26763]: #0 [internal function]: Engined\Rpc\Config->applyChanges(Array, Array)
      4. Sep 10 07:55:18 openmediavault omv-engined[26763]: #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      5. Sep 10 07:55:18 openmediavault omv-engined[26763]: #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      6. Sep 10 07:55:18 openmediavault omv-engined[26763]: #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusXH...', '/tmp/bgoutputZg...')
      7. Sep 10 07:55:18 openmediavault omv-engined[26763]: #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      8. Sep 10 07:55:18 openmediavault omv-engined[26763]: #5 /usr/share/openmediavault/engined/rpc/config.inc(186): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      9. Sep 10 07:55:18 openmediavault omv-engined[26763]: #6 [internal function]: Engined\Rpc\Config->applyChangesBg(Array, Array)
      10. Sep 10 07:55:18 openmediavault omv-engined[26763]: #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      11. Sep 10 07:55:18 openmediavault omv-engined[26763]: #8 /usr/share/php/openmediavault in /usr/share/openmediavault/engined/rpc/config.inc on line 161
      Display All
    • SadButTrue wrote:

      changing the port dosn't solve anything here, i will always get the php error - but only if i'm saving the notification setup...

      other changes will be saved without problem...

      always the same error in syslog:

      Source Code

      1. Sep 10 07:55:18 openmediavault omv-engined[26763]: PHP Fatal error: Uncaught Error: Call to a member function preDeploy() on null in /usr/share/openmediavault/engined/rpc/config.inc:161
      2. Sep 10 07:55:18 openmediavault omv-engined[26763]: Stack trace:
      3. Sep 10 07:55:18 openmediavault omv-engined[26763]: #0 [internal function]: Engined\Rpc\Config->applyChanges(Array, Array)
      4. Sep 10 07:55:18 openmediavault omv-engined[26763]: #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      5. Sep 10 07:55:18 openmediavault omv-engined[26763]: #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      6. Sep 10 07:55:18 openmediavault omv-engined[26763]: #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusXH...', '/tmp/bgoutputZg...')
      7. Sep 10 07:55:18 openmediavault omv-engined[26763]: #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      8. Sep 10 07:55:18 openmediavault omv-engined[26763]: #5 /usr/share/openmediavault/engined/rpc/config.inc(186): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      9. Sep 10 07:55:18 openmediavault omv-engined[26763]: #6 [internal function]: Engined\Rpc\Config->applyChangesBg(Array, Array)
      10. Sep 10 07:55:18 openmediavault omv-engined[26763]: #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      11. Sep 10 07:55:18 openmediavault omv-engined[26763]: #8 /usr/share/php/openmediavault in /usr/share/openmediavault/engined/rpc/config.inc on line 161
      Display All

      You need to collect the PHP error message from syslog. Without this info we can not identify which plugin or internal module raises the error.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Can you post the output of /var/lib/openmediavault/dirtymodules.json please.

      You can also start omv-engined in debug mode:

      Add OMV_DEBUG_PHP="yes" to /etc/default/openmediavault
      $ monit stop omv-engined
      $ omv-engined -d -f
      Then press the apply button in the UI.

      After that there should be a line on stderr
      Deploying configuration for module 'foo'

      before the daemon crashes.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Source Code

      1. root@openmediavault:~# cat /var/lib/openmediavault/dirtymodules.json
      2. [
      3. "cronapt",
      4. "postfix",
      5. "mdadm",
      6. "monit",
      7. "nut",
      8. "smartmontools"

      Source Code

      1. Child process forked (pid=5705)
      2. Executing RPC (service=Exec, method=isRunning, params={"filename":"\/tmp\/bgstatusIVh82Y"}, context={"username":"admin","role":1}) ...
      3. RPC response (service=Exec, method=isRunning): {"response":{"filename":"\/tmp\/bgstatusIVh82Y","running":true},"error":null}
      4. SIGCHLD received ...
      5. Child (pid=5705) terminated with exit code 0
      6. DEBUG [Tue, 10 Sep 19 11:13:32 +0200 File=config.inc Line=158 Method=Engined\Rpc\Config::applyChanges()]: Deploying configuration for module 'collectd'
      7. PHP Fatal error: Uncaught Error: Call to a member function preDeploy() on null in /usr/share/openmediavault/engined/rpc/config.inc:161
      8. Stack trace:
      9. #0 [internal function]: Engined\Rpc\Config->applyChanges(Array, Array)
      10. #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      11. #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      12. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusIV...', '/tmp/bgoutput0n...')
      13. #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      14. #5 /usr/share/openmediavault/engined/rpc/config.inc(186): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      15. #6 [internal function]: Engined\Rpc\Config->applyChangesBg(Array, Array)
      16. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      17. #8 /usr/share/php/openmediavault in /usr/share/openmediavault/engined/rpc/config.inc on line 161
      18. omv-engined[32701]: PHP Fatal error: Uncaught Error: Call to a member function preDeploy() on null in /usr/share/openmediavault/engined/rpc/config.inc:161
      19. RPC response (service=System, method=getInformation): {"response":{"ts":1568106787,"time":"Di 10 Sep 2019 11:13:07 CEST","hostname":"openmediavault.SadButHome.local","version":"5.0.6-1 (Usul)","cpuModelName":"AMD Turion(tm) II Neo N54L Dual-Core Processor","cpuUsage":63.5,"memTotal":"4005801984","memUsed":"1325256704","kernel":"Linux 5.2.0-0.bpo.2-amd64","uptime":"0 days 4 hours 58 minutes 0 seconds","loadAverage":"1.06, 0.37, 0.19","configDirty":true,"rebootRequired":false,"pkgUpdatesAvailable":false},"error":null}
      20. RPC response (service=System, method=getInformation): {"response":{"ts":1568106727,"time":"Di 10 Sep 2019 11:12:07 CEST","hostname":"openmediavault.SadButHome.local","version":"5.0.6-1 (Usul)","cpuModelName":"AMD Turion(tm) II Neo N54L Dual-Core Processor","cpuUsage":56.92307692307692,"memTotal":"4005801984","memUsed":"1294323712","kernel":"Linux 5.2.0-0.bpo.2-amd64","uptime":"0 days 4 hours 57 minutes 0 seconds","loadAverage":"0.18, 0.10, 0.09","configDirty":true,"rebootRequired":false,"pkgUpdatesAvailable":false},"error":null}
      21. SIGCHLD received ...
      22. Child (pid=32714) terminated with exit code 0
      23. omv-engined[32701]: Stack trace:
      24. omv-engined[32701]: #0 [internal function]: Engined\Rpc\Config->applyChanges(Array, Array)
      25. omv-engined[32701]: #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      26. omv-engined[32701]: #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      27. omv-engined[32701]: #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusIV...', '/tmp/bgoutput0n...')
      28. omv-engined[32701]: #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      29. omv-engined[32701]: #5 /usr/share/openmediavault/engined/rpc/config.inc(186): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      30. omv-engined[32701]: #6 [internal function]: Engined\Rpc\Config->applyChangesBg(Array, Array)
      31. omv-engined[32701]: #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      32. omv-engined[32701]: #8 /usr/share/php/openmediavault in /usr/share/openmediavault/engined/rpc/config.inc on line 161
      33. PHP Fatal error: Uncaught Error: Call to a member function preDeploy() on null in /usr/share/openmediavault/engined/rpc/config.inc:161
      34. Stack trace:
      35. #0 [internal function]: Engined\Rpc\Config->applyChanges(Array, Array)
      36. #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      37. #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      38. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(588): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusIV...', '/tmp/bgoutput0n...')
      39. #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      40. #5 /usr/share/openmediavault/engined/rpc/config.inc(186): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      41. #6 [internal function]: Engined\Rpc\Config->applyChangesBg(Array, Array)
      42. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      43. #8 /usr/share/php/openmediavault in /usr/share/openmediavault/engined/rpc/config.inc on line 161
      44. SIGCHLD received ...
      45. Child (pid=5316) terminated with exit code 0
      46. Child process forked (pid=5706)
      47. Executing RPC (service=Exec, method=isRunning, params={"filename":"\/tmp\/bgstatusIVh82Y"}, context={"username":"admin","role":1}) ...
      48. RPC response (service=Exec, method=isRunning): {"response":{"filename":"\/tmp\/bgstatusIVh82Y","running":false},"error":null}
      49. SIGCHLD received ...
      Display All


      hope you can find something

      thanks in advice
      Files
    • Thx for the debug infos. Sadly i can not reproduce this behaviour nor do not i see anything in the code when i review it. This would make me wonder because the code is part of OMV since many years now and i never saw such an behaviour nor get reports from users.
      Currently i have no idea how to proceed.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • P.S. can you please re-post the output of /var/lib/openmediavault/dirtymodules.json, you cut the output somewhere.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • After doing another review i've found that might cause the problem, theoretical, but as said i never experienced any problem here.
      github.com/openmediavault/open…8a0c90a8890858695c4277444
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • votdev wrote:

      P.S. can you please re-post the output of /var/lib/openmediavault/dirtymodules.json, you cut the output somewhere.
      have attached the file as it is.


      votdev wrote:

      After doing another review i've found that might cause the problem, theoretical, but as said i never experienced any problem here.
      github.com/openmediavault/open…8a0c90a8890858695c4277444
      have patched the file but it behaved like before - takes abt 1-2 minutes and then the apply bar comes back again immediately :(

      have had never an problem with this - using the same credentials since ages...

      //add.: have taken a look at postfix and it isn't even configured - the setupfiles are almost blank...
      Files
      • dirtymodules.json.txt

        (90 Byte, downloaded 2 times, last: )
      • syslog.txt

        (949.29 kB, downloaded 3 times, last: )
    • votdev wrote:

      Thx for the debug infos. Sadly i can not reproduce this behaviour nor do not i see anything in the code when i review it. This would make me wonder because the code is part of OMV since many years now and i never saw such an behaviour nor get reports from users.
      Currently i have no idea how to proceed.

      @votdev this silly bug has bugged me so long that i have invested a few hours and i have found the cause of the problem.

      as soon as i install the NUT plugin from plugins email doesnt work anymore and the apply loop begins!

      have reproduced this many times on two different HP Proliant servers.

      the NUT plugin doesnt need to be conf'd or active and the ups isn't even connected - an install of the plugin is enough to get the loop - so i hope you can find the problem bc i need the nut plugin ;)

      //add.: after removing the plugin email loop is gone again :) so seem that this plugins kills something :D

      The post was edited 1 time, last by SadButTrue ().

    • New

      I'm also hitting this email notification settings issue on omv5
      And yes, I've got NUT installed* - I will uninstall it and try my email settings again. Thanks for the pointer.
      Do we know if the email notifications get broken, once set without NUT installed, by then installing NUT again?

      * Also noticed that NUT is not producing any graph/stats on the system status pages. This was working for my UPS on omv2 (yes I've jumped a few versions :p ).

      Thanks Antony

      omv5 with SnapRaid / MergerFS working nicely.
    • New

      antfurn wrote:

      Do we know if the email notifications get broken, once set without NUT installed, by then installing NUT again?
      have tried it on my testing device if you remove the plugin every thing works as long as you do not reinstall it!

      if you reinstall the nut plugin its broken again...

      no clue why i havent received any feedback from @votdev have also created a bugreport in the git repo no response also :(

      github.com/openmediavault/openmediavault/issues/448

      The post was edited 1 time, last by SadButTrue ().