Rsnapshot backup with remote-mount

    • OMV 4.x
    • Rsnapshot backup with remote-mount

      Hi there
      I have been using OMV since a long time (the beginning of it :D :thumbsup: )
      I have a small server hp ml110 g5 and omv has been working great since it was with omv 0.5, then omv 1.x and after that with omv 2.0 for many years.
      The os drive broke a few days ago and i installed omv 3 because 4 and 5 were throwing some errors at me. Yesterday i got another old computer, fujitsu with pentium 4xxx and 4gb of ram and i put there my backup drives.
      I used remote-mount plugin to mount the backup drives into main omv and then tried to backup the main drive with rsnapshot (have been using rsnapshot all the time and it has worked great too, when the drives were in the same computer). Tried remote-mount with samba but rsnapshot gave me permission denied and failed, same thing with nfs. Was able to remote-mount the backup drive in both ways but when rsnapshot started the backup was failing due to permissions.
      Is there a way to fix this permission problem ?( ? I set up same user on both computers with same password but no luck with that,tried to give permission to the user on the backup omv from the ACL and privileges but no luck with that either
      Any help would be much appreciated, thanks.
    • Well nobody cares to write and maybe my question was dumb, i searched a little bit and it seems that rsnapshot is made for local backup only, so im thinking of doing the reverse, ill use remote-mount to mount the shared source on the backup computer and then use rsnapshot there to backup that source. Hope it works this way.
      Thanks
    • neoal83 wrote:

      Well nobody cares to write and maybe my question was dumb
      After 3 hours you think this?

      neoal83 wrote:

      Tried remote-mount with samba but rsnapshot gave me permission denied and failed
      You need to open up permissions or change the user that remote mount is connecting with. Personally, I would use rsync without remotemount - forum.openmediavault.org/index…3-Rsync-two-OMV-machines/
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      neoal83 wrote:

      Well nobody cares to write and maybe my question was dumb
      After 3 hours you think this?

      neoal83 wrote:

      Tried remote-mount with samba but rsnapshot gave me permission denied and failed
      You need to open up permissions or change the user that remote mount is connecting with. Personally, I would use rsync without remotemount - forum.openmediavault.org/index…3-Rsync-two-OMV-machines/
      Sorry - been wake till i dont remember, with this problem, and maybe is that, but thank you for replying.

      I changed permissions but it didnt work, so now i tested the other way around, i remote-mounted on the backup computer the source folder and after that i made a rsnapshot on the local backup drive and it worked without giving any failed or permission error.
      Thank you
    • neoal83 wrote:

      sorry for reposting stuff, but the forum gives me an error after posting smth and it says contact administrators.
      Read problem #4 here - forum.openmediavault.org/index…tions-to-common-problems/
      omv 5.0.10 usul | 64 bit | 5.0 proxmox kernel | omvextrasorg 5.1.1
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • neoal83 wrote:

      @ryecoaaron sorry for reposting stuff, but the forum gives me an error after posting smth and it says contact administrators
      Next time you get one of those errors just refresh your page and you will see that your message has posted after all. I made the same mistake numerous times the first six months I was on the forum.
      Retired. I love to garden and mess with computers. The more I mess with both the less I know about either.
      OMV 4.1.23-1 on a pair of Odroid hc2's w/ 4TB WD Blue. Running Nextcloud, Plex, & Heimdall - and a Raspberry Pi 3 running Pi-hole.
      Testing OMV 5.0.5 5.0.6 5.0.10-1 beta on an Odroid H2, HP dx2400, and Nanopi M4.