No gui (error 500) after update

    • OMV 4.x
    • Update
    • dpkg -l | grep openm
      ii openmediavault 4.1.23-1 all openmediavault - The open network attached storage solution
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-mysql 4.1.1 all MySQL plugin for OpenMediaVault.
      ii openmediavault-nginx 4.0.3 all Nginx plugin for OpenMediaVault.
      ii openmediavault-omvextrasorg 4.1.16 all OMV-Extras.org Package Repositories for OpenMediaVault
      ii openmediavault-plexmediaserver 3.8.2 all OpenMediaVault Plex Media Server plugin
      ii openmediavault-transmissionbt 4.0 all OpenMediaVault Transmission (BitTorrent client) plugin.

      sudo dpkg --configure -a
      $ omv-mkconf nginx

      sudo apt-get install --reinstall openmediavault

      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
      Need to get 0 B/1917 kB of archives.
      After this operation, 0 B of additional disk space will be used.
      perl: warning: Setting locale failed.
      perl: warning: Please check that your locale settings:
      LANGUAGE = (unset),
      LC_ALL = (unset),
      LC_CTYPE = "UTF-8",
      LC_TERMINAL_VERSION = "3.3.3",
      LC_TERMINAL = "iTerm2",
      LANG = "C.UTF-8"
      are supported and installed on your system.
      perl: warning: Falling back to a fallback locale ("C.UTF-8").
      locale: Cannot set LC_CTYPE to default locale: No such file or directory
      locale: Cannot set LC_ALL to default locale: No such file or directory
      Preconfiguring packages ...
      (Reading database ... 57124 files and directories currently installed.)
      Preparing to unpack .../openmediavault_4.1.23-1_all.deb ...
      Unpacking openmediavault (4.1.23-1) over (4.1.23-1) ...
      Setting up openmediavault (4.1.23-1) ...
      locale: Cannot set LC_CTYPE to default locale: No such file or directory
      locale: Cannot set LC_ALL to default locale: No such file or directory
      Updating configuration database ...
      Updating configuration ...
      Processing triggers for rsyslog (8.24.0-1) ...
      Processing triggers for openmediavault (4.1.23-1) ...
      locale: Cannot set LC_CTYPE to default locale: No such file or directory
      locale: Cannot set LC_ALL to default locale: No such file or directory
      Restarting engine daemon ...
      Cannot create socket to [localhost]:2812 -- Connection refused
      Updating locale files ...
      Updating file permissions ...

      Purging internal cache ...

      systemctl reload monit
      1. Request URL: nas.local:90/
      2. Request Method: GET
      3. Status Code: 500 Internal Server Error
      4. Remote Address: 192.168.88.21:90
      5. Referrer Policy: no-referrer-when-downgrade
      reboot and apt-get install --reinstall openmediavault

      Status Code: 500 Internal Server Error :(

      The post was edited 1 time, last by IhorPr ().