A possible fix for macOS users with poor SMB speeds

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • A possible fix for macOS users with poor SMB speeds

      TL;DR, setting "strict sync = no" in OpenMediaVault SMB settings may help to 'uncap' write speeds at the expense of a little more risk of in-flight data if there's a power outage or network interruption. I went from 70MB/s to 750MB/s write speeds via 10G ethernet on macOS.

      I don't know if this exclusively affects those using ZFS or not as I've only been using ZFS in my file server, but it'd be interesting to know if those using regular RAID or similar file systems can chime in too.

      -----------------

      I just thought I'd post this here for the benefits of others and people Googling to fix this problem experiencing poor SMB speeds on macOS from their file servers. It took me a long time to finally solve this long-standing problem.

      Usually when most people post about poor SMB speeds on macOS, people usually tell them to disable SMB packet signing, however this is no longer needed as the default in new releases of macOS is for it to be disabled. However, you can still apply this if you want to be doubly sure.

      I've experienced poor SMB speeds with macOS for a while now (completely fine in Windows) and despite common tuning methods given here, my sub-par SMB write speeds in the 70MB/s range persisted, despite being able to achieve 800MB/s speeds in Windows with 12-disks in a ZFS pool of mirrors.

      It wasn't until recently that I realised that macOS seemed to be treating all write operations over SMB as 'sync writes', which seems to be due to recent Samba releases changing the default setting of 'strict sync' from 'no' to 'yes'. While I know macOS doesn't use Samba and they use their own implementation, it still appears to honour the 'strict sync=yes' setting whereas Windows doesn't, hence the speed discrepancy.

      After setting "strict sync = no" in SMB settings it fixed the speed problem entirely and I went from 70MB/s writes to 750MB/s write speeds over 10G ethernet. The only caveat is that data transfers are at a bit more risk if there's a network interruption or power outage, so if that's a concern for you, then you might want to consider adding a SLOG device like a 32G Optane module to speed up sync writes and leave 'strict sync=yes' as the default.

      Anyway, just wanted to post this for others to refer to, because this issue bothered me for a really long time! If someone else can confirm this helps them, maybe it could be added to the 'Common SMB problems' sticky thread.

      The post was edited 1 time, last by skittlebrau: Added link. ().