What am I missing trying to configure static IP adress?

    • OMV 5.x (beta)
    • Resolved
    • What am I missing trying to configure static IP adress?

      Hi all,

      I'm following The Getting Started guide, since I am very new to OMW and servers in general.

      After I try to set a static IP adress, stuff starts going wrong.

      What am I missing?

      I've set
      IPv4
      Method - Static
      Adress - 192.168.0.201
      netmask - 255.255.255.0
      gateway - 192.168.0.1

      IPv6
      Method - disabled

      Advanced settings
      DNS servers - 1.1.1.1
      Search domains - ??? (no idea what needs to be filled in here)
      MTU - 1500
      Wake on Lan - off

      Here's an example of an error I get trying to update a package
      Display Spoiler
      Reading package lists...
      Building dependency tree...
      Reading state information...

      >>> *************** Error ***************
      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-broken --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install base-files 2>&1' with exit code '100': Reading package lists...

      Building dependency tree...

      Reading state information...

      The following packages will be upgraded:
      base-files
      1 upgraded, 0 newly installed, 0 to remove and 84 not upgraded.
      Need to get 69.7 kB of archives.
      After this operation, 0 B of additional disk space will be used.
      Err:1 deb.debian.org/debian buster/main amd64 base-files amd64 10.3+deb10u1
      Temporary failure resolving 'deb.debian.org'
      E: Failed to fetch deb.debian.org/debian/pool/mai…es_10.3+deb10u1_amd64.deb Temporary failure resolving 'deb.debian.org'
      E: Internal Error, ordering was unable to handle the media swap
      <<< *************************************

      >>> *************** Error ***************
      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-broken --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install base-files 2>&1' with exit code '100': Reading package lists...


      (repeats from here)
    • You specified wrong settings. Perhaps your gateway should be something else. Perhaps the ip should be something else.

      Login to your router and check the settings used for DHCP in it.

      It is a good idea to not only set a fixed ip in OMV but also specify a static lease of that IP, for that device, in the router. Then you can also assign a name to the server.

      Start with asigning a fixed lease to OMV in the routef, then change in OMV.
      OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4
    • Hi Adoby,

      Pretty sure IP adress, gateway, netmask are the correct settings.

      The DNS server should also be okay? For the MTU value I used the same value as I saw in the system monitor when DHCP was still on.

      Maybe I can try a different IP address, maybe I've picked one which is already in use or not allowed?

      Unfortunately my router is only accesable through my ISP's website and has very limited options. There is no way to set a static lease for certain IP's...
    • I'm just installing OMV for the very first time. It's pretty much still a clean in install

      I'm following the "Getting started guide", I'm at the point where I'm setting the static IP, but then I noticed something went wrong because I couldn't run any updates with static IP, whilst if I revert to DHCP I can run the updates.
      (this guide forum.openmediavault.org/index…rted-with-Openmediavault/)

      (I'm using OMV 5 because the installer for OMV 4 wouldnt recognize some of the hardware in my pc)

      The post was edited 1 time, last by ontorugs ().

    • Some tests pingíng:
      Display Spoiler

      root@Eddy:~# pimg 1.1.1.1
      -bash: pimg: command not found
      root@Eddy:~# ping 1.1.1.1
      connect: Network is unreachable
      root@Eddy:~# 8.8.8.8
      -bash: 8.8.8.8: command not found
      root@Eddy:~# ping 1.1.1.1
      connect: Network is unreachable
      root@Eddy:~# ping 8.8.8.8
      connect: Network is unreachable
      root@Eddy:~# ping google.com
      ping: google.com: Temporary failure in name resolution
      root@Eddy:~# ping 192.168.0.1
      PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
      64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=12.7 ms
      64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=3.89 ms
      64 bytes from 192.168.0.1: icmp_seq=3 ttl=64 time=3.64 ms
      64 bytes from 192.168.0.1: icmp_seq=4 ttl=64 time=3.73 ms
      64 bytes from 192.168.0.1: icmp_seq=5 ttl=64 time=3.84 ms
      64 bytes from 192.168.0.1: icmp_seq=6 ttl=64 time=3.77 ms
      64 bytes from 192.168.0.1: icmp_seq=7 ttl=64 time=3.61 ms
      64 bytes from 192.168.0.1: icmp_seq=8 ttl=64 time=9.30 ms
      64 bytes from 192.168.0.1: icmp_seq=9 ttl=64 time=3.69 ms
      64 bytes from 192.168.0.1: icmp_seq=10 ttl=64 time=3.72 ms
      64 bytes from 192.168.0.1: icmp_seq=11 ttl=64 time=14.5 ms
      64 bytes from 192.168.0.1: icmp_seq=12 ttl=64 time=3.76 ms
      64 bytes from 192.168.0.1: icmp_seq=13 ttl=64 time=3.69 ms
      64 bytes from 192.168.0.1: icmp_seq=14 ttl=64 time=3.73 ms
      64 bytes from 192.168.0.1: icmp_seq=15 ttl=64 time=4.50 ms
      64 bytes from 192.168.0.1: icmp_seq=16 ttl=64 time=3.98 ms
      64 bytes from 192.168.0.1: icmp_seq=17 ttl=64 time=3.95 ms
      64 bytes from 192.168.0.1: icmp_seq=18 ttl=64 time=3.72 ms
      64 bytes from 192.168.0.1: icmp_seq=19 ttl=64 time=6.75 ms
      64 bytes from 192.168.0.1: icmp_seq=20 ttl=64 time=3.76 ms
      64 bytes from 192.168.0.1: icmp_seq=21 ttl=64 time=4.86 ms
      64 bytes from 192.168.0.1: icmp_seq=22 ttl=64 time=3.84 ms
      64 bytes from 192.168.0.1: icmp_seq=23 ttl=64 time=4.52 ms
      64 bytes from 192.168.0.1: icmp_seq=24 ttl=64 time=3.88 ms
      64 bytes from 192.168.0.1: icmp_seq=25 ttl=64 time=3.70 ms
      64 bytes from 192.168.0.1: icmp_seq=26 ttl=64 time=10.3 ms
      64 bytes from 192.168.0.1: icmp_seq=27 ttl=64 time=3.77 ms
      64 bytes from 192.168.0.1: icmp_seq=28 ttl=64 time=4.76 ms
      64 bytes from 192.168.0.1: icmp_seq=29 ttl=64 time=4.76 ms
      64 bytes from 192.168.0.1: icmp_seq=30 ttl=64 time=3.83 ms
      --- 192.168.0.1 ping statistics ---
      30 packets transmitted, 30 received, 0% packet loss, time 79ms
      rtt min/avg/max/mdev = 3.606/5.081/14.479/2.771 ms


      I also tried restarting my router several times... No change
    • The Getting Started Guide was written for OMV3 and 4.
      OMV5 is still a Beta and, as such, may have a few wrinkles to iron out. (And there is a note in the Guide about what running a "BETA" means. :) )

      Since you're at the start and are already statically addressed - if you can get on the command line, try this.

      systemctl stop NetworkManager.service
      systemctl disable NetworkManager.service

      For the time being, try using your routers IP address as the DNS server.

      Please let us know how it went. This may have a bearing on other issues.
    • If everything is working fine when you use DHCP you can ask the router to assign always the same IP to your NAS.

      Another option is to not care about the IP adress, but use the hostname instead. If your OMV is called "nas" you reach the gui with

      http://nas.local
      Odroid HC2 - armbian - OMV4.x | Asrock Q1900DC-ITX - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • crashtest wrote:

      The Getting Started Guide was written for OMV3 and 4.
      OMV5 is still a Beta and, as such, may have a few wrinkles to iron out. (And there is a note in the Guide about what running a "BETA" means. :) )

      Since you're at the start and are already statically addressed - if you can get on the command line, try this.

      systemctl stop NetworkManager.service
      systemctl disable NetworkManager.service

      For the time being, try using your routers IP address as the DNS server.

      Please let us know how it went. This may have a bearing on other issues.
      This yielded some unexpected results (I threw in the ip address show just to prove I am in fact connected :))

      Display Spoiler
      root@Eddy:~# systemctl stop NetworkManager.service
      Failed to stop NetworkManager.service: Unit NetworkManager.service not loaded.
      root@Eddy:~# systemctl disable NetworkManager.service
      Failed to disable unit: Unit file NetworkManager.service does not exist.

      root@Eddy:~# ip address show
      1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
      link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      inet 127.0.0.1/8 scope host lo
      valid_lft forever preferred_lft forever
      inet6 ::1/128 scope host
      valid_lft forever preferred_lft forever
      2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
      link/ether 70:85:c2:78:e0:8e brd ff:ff:ff:ff:ff:ff
      inet 192.168.0.7/24 brd 192.168.0.255 scope global eno1
      valid_lft forever preferred_lft forever
      root@Eddy:~#

      macom wrote:

      If everything is working fine when you use DHCP you can ask the router to assign always the same IP to your NAS.

      Another option is to not care about the IP adress, but use the hostname instead. If your OMV is called "nas" you reach the gui with

      http://nas.local
      That is a neat little trick. Thanks. That could help indeed if I would be stuck with DHCP. However I'd like to have this weirdness sorted out.
    • ontorugs wrote:

      root@Eddy:~# systemctl stop NetworkManager.service
      Failed to stop NetworkManager.service: Unit NetworkManager.service not loaded.
      root@Eddy:~# systemctl disable NetworkManager.service
      Failed to disable unit: Unit file NetworkManager.service does not exist.
      So it's not running. Hum,, network-manager is running only on Armbian SBC's.

      I'll take it that you changed your DNS server IP address, to your routers IP address and that had no affect. You could try another public DNS server like 8.8.4.4 just to see what happens.
      From time to time, sources may not be available. It's pretty rare, but it happens. Generally, the next day, they're back on line.

      In any case, I don't know of a specific reason why using a static IP address and a pubilc DNS server would cause a name resolution failure. On the other hand you could try the DHCP setting, reboot, and see what happens.
      ________________________________________________________

      If this persists and if you're in a hurry, I'd suggest building OMV4.