Access denied from Windows XP desktop PCs

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Access denied from Windows XP desktop PCs

      Hello everyone. I have successfully installed OMV 4.1.22 on a HP550 Laptop in just a few minutes and am happy with the ease of use of this software NAS.
      Unfortunately, however, in my LAN there are some PCs with Windows XP because some essential applications run only on XP and from these PCs I cannot access the folders of the NAS unless they are set as public. In all the other folders it is possible to enter with Username and Password from other devices but from the PC XP even if you type in the correct Username and Password you cannot access the folders, even though you see them in the network resources.


      Should access be enabled via the Samba v1 protocol? How can I do it?


      Can someone help me ?


      Thanks in advance.
    • frengo wrote:

      Should access be enabled via the Samba v1 protocol?
      Yes

      frengo wrote:

      How can I do it?
      Check the current supported smb protocol version with the CLI command testparm. In the [global]-section there should be an entry server min protocol = . For Windows XP the necessary entry is server min protocol = NT1.

      To change the smb protocol version goto "Services -> SMB/CIFS -> Settings -> Advances Settings. In the "Extra Options"-field add the line min protocol = NT1 (without 'server'!)

      After the change check again with testparm if it was successfull.
      OMV 3.0.99 (Gray style)
      ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

      The post was edited 1 time, last by cabrio_leo ().

    • crashtest wrote:

      Hum,,, I guess that would mean there would be lots of pizza and spaghetti, to go with the beer, at Oktoberfest.
      This weekend a lot of people from Italy are coming to Munich to the Oktoberfest with their campers. Traditionally this happens always on the second weekend of the Oktoberfest - and we "natives" call it the "Italien weekend".
      oktoberfest.de/magazin/das-italiener-wochenende

      Today the weather is absolutely fine, 25°C, sunny with blue sky. A perfect weather for the "Festa d'ottobre".
      OMV 3.0.99 (Gray style)
      ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

      The post was edited 1 time, last by cabrio_leo ().

    • crashtest wrote:

      I need to be there for some pizza and beer!
      :D I do really like pizza too, but this is not the traditional bavarian food which you will get on the Oktoberfest. Traditional food is roasted chicken, steak and so on. And the food is usually really delicious!

      Please have a look at the english menu of the Hofbräu Festzelt (Hofbräu is a famous Munich beer brewery): Menu of Hofbräu Festzelt

      Some impressions: hb-festzelt.de/galerie.html

      An Guadn! = Enjoy your meal!
      OMV 3.0.99 (Gray style)
      ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

      The post was edited 3 times, last by cabrio_leo ().

    • cabrio_leo wrote:

      frengo wrote:

      Should access be enabled via the Samba v1 protocol?
      Yes

      frengo wrote:

      How can I do it?
      Check the current supported smb protocol version with the CLI command testparm. In the [global]-section there should be an entry server min protocol = . For Windows XP the necessary entry is server min protocol = NT1.
      To change the smb protocol version goto "Services -> SMB/CIFS -> Settings -> Advances Settings. In the "Extra Options"-field add the line min protocol = NT1 (without 'server'!)

      After the change check again with testparm if it was successfull.
      I think I need your recommended tutorial to correctly configure all the starting values in OMV. I checked that I had successfully modified the [global] and restarted everything but it still doesn't work. I beg you. Write me a link here for a tutorial that is valid for installing OMV so that I can make changes to a default configuration.
    • cabrio_leo wrote:

      To change the smb protocol version goto "Services -> SMB/CIFS -> Settings -> Advances Settings. In the "Extra Options"-field add the line min protocol = NT1 (without 'server'!)

      @frengo
      If you rebuild according to the Guide and you are setting up XP LAN clients, you'll still need to add the above to SMB/CIF extra options. If you have XP clients only, and nothing newer, I would consider using:

      min protocol = NT1
      max protocol = NT1

      The post was edited 1 time, last by crashtest ().

    • crashtest wrote:

      cabrio_leo wrote:

      To change the smb protocol version goto "Services -> SMB/CIFS -> Settings -> Advances Settings. In the "Extra Options"-field add the line min protocol = NT1 (without 'server'!)
      @frengo
      If you rebuild according to the Guide and you are setting up XP LAN clients, you'll still need to add the above to SMB/CIF extra options. If you have XP clients only, and nothing newer, I would consider using:

      min protocol = NT1
      max protocol = NT1

      Nothing.

      I' ve reinstalled entire OMV but

      I CANNOT have access from my XP PC.

      X( ;( ?(
    • Do you get access to other PCs with a newer Windows version?

      Did you get any error message? Maybe it´s not an SMB but a authorization problem. In your first post you wrote that you have access when the share is set to public. Therefore I assume that it is a permission problem.
      OMV 3.0.99 (Gray style)
      ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • cabrio_leo wrote:

      Do you get access to other PCs with a newer Windows version?

      Did you get any error message? Maybe it´s not an SMB but a authorization problem. In your first post you wrote that you have access when the share is set to public. Therefore I assume that it is a permission problem.
      1): Yes, All regular from Win7 and Android smartphone.

      2): The error message is a classic XP error window with the red cross and the text:

      "Unable to access \\MyNAS\NewFolder. The user may not have the necessary authorization to use the network resource. For access permissions, contact the server administrator. Access denied."

      3): Yes. If the share folder have a public access i quickly can access at all content, (but i cannot set so public all my folders ... )
    • crashtest wrote:

      frengo wrote:

      3): Yes. If the share folder have a public access i quickly can access at all content, (but i cannot set so public all my folders ... )
      This is another matter. If you're setting permissions to allow specific users, access to specific shares, some extra work will need to be done.
      Read over this post and see if it helps.
      I' ve reinstalled all OMV OS and following the instructions of your post and he result is:

      On a public share folder I' ve complete access and write/read/erase files inside

      On a private share folder I get the little windows asking me User and Passw but I cannot go inside. I' ve tried with my PC bios name (CORE-86E45CBFFC) and my PC password. User and pw of others user of the OMV user group and crossing user/pw in infinite combinations.

      Nothing to do

      Update: I' ve tried NOW by my smartphone using the name/pw of my PC and it work.

      The post was edited 1 time, last by frengo ().