no DNS after boot.

    • OMV 4.x
    • no DNS after boot.

      I'm trying to install OMV on a Raspberry Pi 3B+. I installed the image on a SD card (4 times using both dd and Etcher and it did verify) I power on the RPi and wait. I try to connect (Safari & Chrome) and the connection is refused. I try to log in via ssh, it finds the computer but logins fail. I hook up a console and can log in vi root.

      Now comes the interesting part. My DHCP server (Pi-Hole) records that the connection and reports the correct IP (mac locked). I can ping by IP address only, no DNS resolution. I can see that the DNS/gateway has been configured correctly in the logs but it seems like OMV ignores my DNS server unless specifically told to to use it.
      host debian.org <- not found
      host debian.org 192.168.0.242 <- debian.org found just fine.

      Needless to say the normal install boot fails because it cannot find any domains outside my local network.
      From OMV I can ssh/ping only IPs, no hostnames.

      Why does OMV not use the DNS server configured suring the DHCP transaction? and how do I fix it?

      TIA.
    • Your type of problems typically has two causes:

      1. The install is not finished. Could be because of a bad or slow SD card. Make sure to use at least a 16 GB A1 type card for a fast install.
      2. You network (especially the router/DHCP-server) is not correctly configured


      Please note: 192.168.0.252 is a IP inside your LAN. Not debian.org.
      OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

      The post was edited 1 time, last by Adoby ().

    • I thought of the SD card issue. I tried a 16GB and 32GB SC cards (spares from my Pi farm) and in one case I waited 3.5 hours (went out for the night) and still no joy.

      I have been using this configuration for over a year and currently have 10+ Pi's, 3 Mac's 4 phones and any number of IOT's devices connected and none have had any difficulty. Even this PI was originally purposed as a Raspbian machine and the DHCP was fine (this is why the MAC is tied to a specific IP)

      I looked at the log again and the DHCP transaction seems nominal. All the info is there and correct.

      TFTH.
    • No joy. :(

      It seems that OMV is sensitive to something with certain DHCP servers. In my case Pi-Hole. It won't use the DNS server that is issued during the DHCP transaction. I can see that the correct DNS server is accepted in the traction.

      I don't have the skills patients or time necessary to continue exploring this.

      I'll keep looking back on occasion to see if someone has figured it out.