UnionFS SnapRAID 0 size files

    • OMV 4.x
    • UnionFS SnapRAID 0 size files

      Hi,

      I have OMV running on an Intel system with M.2 NVME drive, 4x4TB data drives with UnionFS and SnapRAID. I have Emby running on a seperate Ubuntu system feeding several Kodi devices from media on OMV.

      Since changing from RAID 5 to the above setup a week ago a lot of the .nfo files now have zero file size - everything works as before as far I can make out.

      On running the SnapRAID helper script

      sourceforge.net/p/snapraid/dis…/1677233/thread/385e8cf5/

      I get a few messages about this. Is this anything to worry about?

      John
    • johnvick wrote:

      Since changing from RAID 5 to the above setup a week ago a lot of the .nfo files now have zero file size
      I have done the same but a number of months ago, Emby runs in Docker on my OMV server, each .nfo file is located in each movie folder. I also don't use that helper script nor the diff script on OMV I run cron jobs.
      Best guess here is that the .nfo is on your Ubuntu server, hence the .nfo on OMV displays as 0, I also scrape my movies with MCM before moving them to the server. If something is missing I then use the metadata manager in Emby to fix it, but my Emby config points to a different drive (separate one) from the MergerFS + Snapraid plugins.
      Raid is not a backup! Would you go skydiving without a parachute?
    • Thanks for the input - I've searched the Emby folder on the Ubuntu system but the only .nfo files I find relate to music, there are none relating to TV episodes. I've checked a bit more and no problems are apparent, watched status and episode info is still there so the info must be in the Emby database, where it probably was all the time, the only change is I now have empty .nfo files. Interested to know how this has come about and only with .nfo files.

      John
    • The problem with 0 byte .nfo files seems to happen often enough that at least one of the several SnapRAID helper scripts explicitly removes them in the Preprocessing phase.

      See:

      gist.github.com/mtompkins/91cf0b8be36064c237da3f39ff5cc49d
      --
      Google is your friend and Bob's your uncle!

      RAID - Its ability to disappoint is inversely proportional to the user's understanding of it.

      ASRock Rack C2550D4I - 16GB CC - Silverstone DS380
    • Thanks for the input with this, I haven't solved the problem but come up with a workaround, which it to tell Emby not to produce .nfo files and instead get Ember Media Manager (Windows) on the job to create them.

      Ember renames the empty .nfo files to .info but easy to delete these.

      Edit - just discovered tinyMediaManager - much faster at recreating the .nfo files.

      The post was edited 1 time, last by johnvick ().