Proper use/setup of Shared Folders, not CIFS/SMB but internal OS

    • OMV 4.x
    • Resolved
    • Proper use/setup of Shared Folders, not CIFS/SMB but internal OS

      I've recently setup an OMV system, and after many reloads have finally established my system with 4 data disks set up with mergefs and snapraid. My problem is that I still continue to have numerous issues with dockers and the internal use of shared folders. Mergefs duplicates parts of the primary disk structure across disks in order to use the "least filled" requirement I have selected. I'm guessing my dir tree structure is the same as most, a primary dir-1 that contains all of my other sub dirs.

      What I was previously doing is sharing each dir that was called out as a requirement for each docker; i.e. /dir1/dir3/dir2/downloads, I would simply share downloads. Needless to say there a lot of shared folders showing up. I then decided that if I simply share /dir1, then all sub directories would be shared by default.

      I have also been creating new folders as necessary using both my windows share, and SSH, then going into the OMV GUI and sharing them internally if needed.

      I still have a lot of problems. I've removed shares from within the OMV GUI, and I've SSH into the drive structure and removed suspect directories that way. My dockers like Radarr, Sonarr, Serviio, all continue to screw up because the shares keep changing. I set up so that everything is working, then I come back the next day and the dockers no longer see the shared information. If I SSH into and look at the structure, I can clearly see by timestamps that things are being saved/accessed from different drives (probably due to mergefs).

      Yesterday, after having problems with a docker Serviio, I discovered that my shared folders had all been changed in ownership back to root! Nothing worked.

      I probably have a number of things I have done wrong, and continue to do wrong, but I think the first thing is to get a better grasp of the shared folder concept and how I should be emplimenting it. I had hoped that there was a TDL video that seriously described it but I havent found it, only the basic stuff most of his vids have.

      I would really appreciate it if someone could either explain it for me, or point me to a good place to get the info. Thanks

      EDIT*** In a previous post, it was recommended that I declare my shared folders as volumes within the docker. I have done that using numerous methods. I have gone to /srv/ and selected the applicable folder within my mergefs, I have gone to /sharedfolders/ and selected the appropriate folder there, I have gone to /tv, /media, and probably a couple other places, but the one thing that remains consistent is that I can not consistently rely on those folders remaining accessable; one day the work, the next they don't.

      The post was edited 1 time, last by MightyMo: Related to previous post, deserves clarification ().

    • I'm trying to make some sense of what you have asked, I use MergerFS + Snapraid and all of the above cam be completed in the GUI.

      So you have created your pool for MergerFS, so under File Systems you will have a fuse mount point and it will look something like this;

      DeviceLabelFilesystem Type
      /srv/<device name>your pool namefuse.mergerfs



      there will also be the mount point.

      So to create a shared folder Access Rights Management -> Shared Folders -> Add (from the menu) and select the mergerfs pool name from the list, then select the appropriate permissions. This will also create the folder under /sharedfolders ignore this!

      Docker requires you to point an internal docker folder to an external folder on OMV, however this should be done using /srv/<pool name>/sharedfolder name, so;

      outside; absolute path as per the gui shared folders inside; /downloads

      This a snapshot of one of my volume binds using portianer for my Emby server in docker;


      the destination is inside the container, the source is the share on the server.

      There is one issue as far as MergerFS is concerned, you cannot have a dockers config on the MergerFS it will simply not work unless you change the Options when setting up MergerFS, some users have done this successfully.

      But what you are trying to do can be done in the GUI, perhaps have a look at new user guide this might help.
      Raid is not a backup! Would you go skydiving without a parachute?
    • Thanks Geaves, you helped me more than you know. I just needed a little better understanding. I've both cleaned up my file system (too many remnants of all my failed docker setups) and then reinstalled my dockers according to your guidance, and I think everything is OK. I suppose testing again in the morning will be the real test.

      I've tried to install portainer, but I cant get it to load properly. I think I have the "/var/run/docker.sock" set up incorrectly. Also, the instruction page says something about a certificate that needs to be generated and installed. My error when trying to manage a docker with a local connection is:

      failure can not connect to the docker daemon at unix///var/run/docker.sock
    • MightyMo wrote:

      I've tried to install portainer, but I cant get it to load properly.
      You don't need to install Portainer on OMV4 you can use the docker plugin, I have installed it on mine because in OMV5 Portainer is the only option to deploy containers, there is one caveat to this, unlike the plugin you cannot modify a container, if you make a mistake you have to delete the container an start again.

      There is a @TechnoDadLife video to install Portainer using the docker plugin, or from the command line;
      docker pull portainer/portainer
      docker volume create portainer_data
      docker run -d -p 9000:9000 -p 8000:8000 --name portainer --restart always -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer
      the above is from the portainer docs
      Raid is not a backup! Would you go skydiving without a parachute?
    • Question. When installing dockers where do you point the AppData and config folders? The sharefolders or srv folder. if I point plex config file to srv it won't run.I started setting up to sharefolders per the videos. changing downloads, documents, media, etc to srv. Just don't know the best place for operating files.

      Thanks, ML
    • Users Online 1

      1 Guest