web GUI not available after upgrade from OMV3 to OMV4; is it possible to reinstall OMV4 without losing all configurations?

    • web GUI not available after upgrade from OMV3 to OMV4; is it possible to reinstall OMV4 without losing all configurations?

      New

      Hello,

      voilà my problem:

      upgrading from Debian Jessie to Debian Stretch and then from OMV3 to OMV4 worked pretty well on my RasPi2.

      I am still able to connect to the installation via ssh an can access the storage via ssh, too. But the web-surface doesn't work anymore: after filling in the local IP address I get the Login-page, fill in name and password, then the screen gets a little darker, it says "Bitte warten...", the Address is shown in the status bar at the bottom of the page but finally there appears only the blue openmediavault logo in the upper left corner, the rest of the page remains light grey.

      When I then clear the browser cache, there appears the red and black warning frame about a broken connection, and I can restart the same thing all over.

      I think there might be a problem with the .json files in /var/cache/openmediavault, because after the upgrade, I had to restore them from a backup that I made before starting the upgrade.

      Is it possible to reinstall only these files without losing all of the configuration?


      Thank you for your help!
      There is NO CLOUD, just other people's computers.
    • New

      Thank you for your advice. Do I get you right: if I remove and reinstall the "openmediavault" package via apt on the commandline, the configuration of my system should remain untouched?
      If something goes wrong: which files from a backup would I use to restore the configuration?

      And YES! OMV on a RasPi2 is what I want!
      Perfect for hosting few files that from time to time have to be accessed via internet. No need for more speed and more money to spend.
      There is NO CLOUD, just other people's computers.