can't resolve anything, no internet, No DNS servers known

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • can't resolve anything, no internet, No DNS servers known

      this happened the third time today after I've been wiping my SSD and reinstalling OMV.
      I've been trying to set up OMV with smb, ftp, omv-extras5.14, docker and cockpit
      after some time it just stops responding to anything outside of my local network.
      meaning, I can't do apt-get update, nor install anything with apt-get. or even ping google.
      local network, web interface and ssh is all working.
      Last time I had this issue all I was using was stock OMV 5, latest update, and set up smb. no plugins.

      doing apt-get update gives me stuff like Temporary failure resolving 'deb.debian.org'
      and all /etc/resolv.conf shows is
      "# No DNS servers known."

      tried to add dns-nameservers 1.1.1.1 1.0.0.1 to /etc/network/interfaces. No luck.

      my Ubuntu Installation from my other SSD works just fine.

      any ideas?



      update:
      anyways, I fixed it.
      Whoever has the same issue as me, run omv-firstaid and do the network setup.
      make sure you select your actual network adapter and not docker.
      it looks like docker uses a virtual adapter that somehow got prioritized over my actual network adapter.

      The post was edited 2 times, last by nex86 ().