Wake on Lan not supported with 5.2 Kernel?

    • OMV 5.x (beta)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wake on Lan not supported with 5.2 Kernel?

      I needed to update the kernel for a WIFI card that's coming this week and I wanted to be prepared.

      Wake on Lan doesn't work anymore though, before I was able to wake up my NAS from my router but now it doesn't work.

      Using OMV 5 it says WOL is activated on the current ethernet interface.

      Any ideas what I have to set up to get it working again?
    • Okay, reinstalled OMV 5 and updated to the 5.3 proxmox kernel.
      When I select standby from the top right OMV menu in the web gui it shuts the computer down.
      Tried pm-suspend from the command line but I get "command not found". I'm hesitant to install something from the CLI since I don't want to break OMV again. Is it save to install?
    • To check if it is supported, you can use: pm-is-supported --suspend and then actually suspend with systemctl suspend
      omv 5.3.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • When I enter pm-is-supported --suspend, nothing happens. I assume I should get any kind of output?
      systemctl suspend though suspends the system successfully and Waking it from Lan works too.
      Still when I select "standby" from the dropdown menu in the upper right it shuts the system right off.
      What's wrong here?

      Thanks for chiming in :)
    • ja-ki wrote:

      When I enter pm-is-supported --suspend, nothing happens. I assume I should get any kind of output?
      Sorry for not mentioning more... echo $? after the command will show the answer. If 0, then your system supports suspend. If anything else, it doesn't support suspend.

      ja-ki wrote:

      Still when I select "standby" from the dropdown menu in the upper right it shuts the system right off.
      What's wrong here?
      It looks like the code will try a suspend-hybrid first (if supported) then hibernate (if supported) then suspend (if supported). Otherwise, it does a shutdown.
      omv 5.3.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      ja-ki wrote:

      When I enter pm-is-supported --suspend, nothing happens. I assume I should get any kind of output?
      Sorry for not mentioning more... echo $? after the command will show the answer. If 0, then your system supports suspend. If anything else, it doesn't support suspend.

      ja-ki wrote:

      Still when I select "standby" from the dropdown menu in the upper right it shuts the system right off.
      What's wrong here?
      It looks like the code will try a suspend-hybrid first (if supported) then hibernate (if supported) then suspend (if supported). Otherwise, it does a shutdown.
      thanks for clarifying, it's been a while with linux.
      So the output is "127".
    • The man pages don't have a good list of the exit codes. So, not sure what 127 means but I would interpret it as regular suspend is not supported.
      omv 5.3.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ja-ki wrote:

      so how do I get it working then?
      No idea. I don't put my servers to sleep.

      ja-ki wrote:

      Also pm-suspend works, but that's not what's getting triggered from the dropdown menu
      Need to figure out why systemctl suspend isn't working. @votdev
      omv 5.3.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      ja-ki wrote:

      so how do I get it working then?
      No idea. I don't put my servers to sleep.

      ja-ki wrote:

      Also pm-suspend works, but that's not what's getting triggered from the dropdown menu
      Need to figure out why systemctl suspend isn't working. @votdev

      systemctl suspend IS working! As well as pm-suspend. The computer shuts down, but keeps the LAN interface on, Wake on Lan works flawlessly this way. It's only the WEB GUI button "standby" that's not working
    • ja-ki wrote:

      It's only the WEB GUI button "standby" that's not working
      The system must be incorrectly reporting that hybrid-suspend or hibernate are supported since those options are tried before suspend.
      omv 5.3.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ja-ki wrote:

      What should I do then?
      Maybe try changing /etc/systemd/sleep.conf and disable the methods that don't work preventing OMV from using them? This describes the options - freedesktop.org/software/systemd/man/systemd-sleep.conf.html
      omv 5.3.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.4
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Thanks for the tip!
      I thought the documentation was way too hard to understand for me as a linux noob, BUT I've found an exampe of a sleep.conf that seems to work (NAS goes to sleep when I press the standby button from the WEB GUI)

      Source Code

      1. [Sleep]
      2. # suspend=hybrid-sleep
      3. SuspendMode=suspend
      4. SuspendState=disk
      5. # hibernate=hybrid-sleep
      6. HibernateMode=suspend
      7. HibernateState=disk
    • Users Online 1

      1 Guest