Potential first HDD failure in x4 storage disc HP micro server

    • OMV 4.x
    • Resolved
    • Potential first HDD failure in x4 storage disc HP micro server

      Hoping those with greater IT skills than I can advise if this is what it appears to be:

      I just had the following e-mailed message via OMV:

      This is an automatically generated mail message from mdadm running on openmediavault



      A Fail event had been detected on md device /dev/md/0.



      It could be related to component device /dev/sdd.



      Faithfully yours, etc.



      P.S. The /proc/mdstat file currently contains the following:



      Personalities : [raid6] [raid5] [raid4] [linear] [multipath] [raid0] [raid1] [raid10]

      md0 : active raid5 sdb[0] sdd[2](F) sdc[1] sde[3]

      8790405120 blocks super 1.2 level 5, 512k chunk, algorithm 2 [4/3] [UU_U]



      unused devices: <none>Hi all


      Looking under SMART and devices shows that sdd appears offline.

      At the moment I can still access files on the server, but I'm pretty sure the RAID setup I have can only cope with one failed drive so I need to sort this before another falls over.

      Anything worth trying before I assume it's dead?

      Is there a walkthrough guide for replacing the drive and other steps to integrate a new drive into the RAID?

      Many thanks for any and all advice :)

      Adrian
    • Start your search with this thread: How to Recover Degraded RAID5 after physical disk failure?

      I absolutely do not wish to offend other users here in the forum, but look for the posts of @geaves. He seems to be one of the most experienced users of mdadm.
      OMV 3.0.99 (Gray style)
      ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • Thanks - I marked this as resolved, as did some further digging and got some advice from an IT tech friend. ordered a pair of new 3TB WD drives at 9pm and they arrived the next morning (one to replace the dead drive, the other as a spare in case the process of rebuilding the RAID caused one of the other drives to die!)

      Since my HP microserver doesn't support hot swapping I shut it right down and physically checked the discs for the correct serial number - got the right one at 2nd guess. Interestingly (ish!) the drive that's failed is one of a pair of newer ones (albeit from 2014).

      Popped in new disc straight out of the packet and went into 'repair' and chose the new disc. About 10 hours later everything was back to 'clean'. Now wondering if I can figure a way to house the new 'spare' drive within the server. Already have x4 data drives, an SSD for OMV and a spare 2.5" drive with a backup of OMV within the case (but not connected). I've got negligible redundancy on the RAID at the moment. I might be able to remove the 2.5" drive as that's housed in the optical drive bay at the moment with the SSD sitting on top of it!
    • Users Online 1

      1 Guest