How to install HassIO?

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • How to install HassIO?

      I'm new to OMV and docker. But have managed to install some containers using Portainer. I have a fair knowledge of Hassio and have been running that on a RPi for some years. I want to migrate to my OMV NAS but don't understand how, even though I've been googling and trying to understand. There seems to be so many ways, and different ways depending on your system etc.

      I want to keep on using HassIO instead of Home assistant since I'm so used to addons. I tried pull this within Portainer hub.docker.com/r/hassioaddons/base-amd64 but it didn't work and got some 'can't reach API' error.

      Thanks in advance!
    • hassioaddons is not the hassio application. You need to find a hassio image first.
      --
      Google is your friend and Bob's your uncle!

      RAID - Its ability to disappoint is inversely proportional to the user's understanding of it.

      ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.
    • HI, I've just got it working on OMV 4.1, following the instructions on home-assistant.io/hassio/installation/ (last steps, general install on UBUNTU).

      Steps I've done are in the attached text file forum.openmediavault.org/index…677d6d33cd614d524fd61c7d0,

      Also attached a copy of the result working dockercontainers.

      Home assistant is accesed via: OMV_IP:8123


      Tested add-ons (MQTT, SSH, Config) are installed as usual and they work ...


      Regards
      OMV 4.x. OMV-Extras ZFS iSCSI Infiniband. Testing OMV 5.1. Testing OMV arm64

      The post was edited 2 times, last by vcp_ai ().

    • Hello
      Yes that is exactly what i was looking for : installinhg Hassio on my OMV NAS (because running InfluxDB and Grafana on the pi make no mich sense as i see my SD card being slowly grinded by the data logging

      My PC based NAS/ Server Running OMV would be great for that matter

      I will définitely start this quest of installing Home Assistant(Hassio flavour) in docker - wish me luck as i'm far from being linux aware
      I already fear / feel being eaten alive by the "command line monsters" (and their parameters demons),..that is if the "directory permission gouhls" do not feast on my miserables bones before

      ;(

      to Mr VCP_ai : the link to your "steps" look to be no more available (attachement 14215 returning error)

      starting with 1 (probably stupid) question : procedure from Hassio Site , ubuntu procedure :

      is this a "normal" install on the server or an an install "inside a docker" ?
      if this is inside a docker, does that not mix or interfere with docker management from the OMV web UI ?

      I already succeed in having running the Normal Home assistant in a dock but installing the Hassio layer is my current line of defeat

      any advices ? am'i wrong somewere ?

      The post was edited 1 time, last by yvanleterrible ().

    • This is a copy of my steps:
      The are executed in an OMV Shell .

      Source Code

      1. ### create workspace for hassio
      2. # mkdir /sharedfolders
      3. # mkdir /sharedfolders/hassio
      4. #apt-get install apt-transport-https ca-certificates curl gnupg-agent software-properties-common
      5. #apt-get install apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq socat software-properties-common network-manager
      6. # curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s -- -d "/sharedfolders/hassio"
      7. ### Instalation take some time as most of packages(container) are installed after....
      OMV 4.x. OMV-Extras ZFS iSCSI Infiniband. Testing OMV 5.1. Testing OMV arm64
    • OK trying to wrap my head around some details:

      Step 0 - install curl (as per yvanleterrible's post) before beginning.

      Steps 1-3 Q. - the shared folder you made for hassio is on the OMV system drive where the OMV OS resides, OR on a Samba share on a data drive?
      Step 7 Q. The install script is downloaded and run (I assume as root) from the share created as per steps1-3.

      Q. Is there a point where the OMV's Docker plugin and setup dialog/interface is used?
    • @shazster
      curl is installed on mi line #4
      The shared folder is created , from OMV, as any other shared folder of the system. In my case is a ZFS fileSystem (does not have a limit on its size). Actually, after one month, is using 490MB..

      The install script is downloaded and run from root account (step #7). it makes all the job. Docker UI is not used.

      Dockeu UI is only used to test tthat all containers are installed and running....
      OMV 4.x. OMV-Extras ZFS iSCSI Infiniband. Testing OMV 5.1. Testing OMV arm64
    • New

      Hello,
      Don't want to start new thread for the same question becouse of OMV version

      I have tried installing home assistant on OMV5 docker several times (following steps from vcp_ai), but am facing same problem every time.
      hassio_dns container is not starting.
      HomeAssistant_supervisor is constantly trying to start hassio_dns.

      # docker logs hassio_dns
      returns:
      Listen: listen tcp :53: socket: permission denied

      from home assistant side I see:
      19-11-27 12:40:41 WARNING (MainThread) [hassio.tasks] Watchdog found a problem with CoreDNS plugin!
      19-11-27 12:40:41 WARNING (MainThread) [hassio.tasks] CoreDNS plugin is in fails state / Reset config

      I have tried:
      . adding DNSStubListener=no to /etc/systemd/resolved.conf
      . dissable systemd-resolved.service
      . add google dns(8.8.8.8) to /etc/docker/daemon.json

      I am not very experienced with linux so I've been searching for solution for two days, and have no ideas what to try next.

      Would appreciate any suggestions

      Thank you

      The post was edited 2 times, last by aSa ().