Plex doesn't see files on an ext HDD

    • OMV 5.x (beta)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex doesn't see files on an ext HDD

      New

      I have OMV 5 installed on a Raspberry Pi 4 and Plex was installed through Portainer according to this video: youtube.com/watch?v=CzMSuRyfMS0.Everything went well apart from the fact that Plex doesn’t see the files that are in the Movie and Music folders that were set up on an external drive. I can see the files when connected through Putty, but Plex shows that the libraries are empty. Reading around, I'm pretty sure I need to change permissions, but because I'm still a noob, I don't know what to change. Any help will be much appreciated.
    • New

      1. Did you connect the folder on the host to a folder in docker (volume mapping)?
      2. In Plex you first need to create a library and then add a folder to that library.
      3. The user that is running the docker should have read access to these folder. If you used the linuxserver image the user is specified by PUID/PGID.
      Odroid HC2 - armbian - OMV4.x | Asrock Q1900DC-ITX - Intenso SSD 120GB - OMV5.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV5 Documentation - user guide :!:
    • New

      Hi macom, thanks for the quick response. To answer your questions:

      1. Volume mapping has been set up as per the attached VolumeMapping screenshot.
      2. Movie and Music libraries were added in Plex then folders were found and added to the libraries.
      3. My PUID and PGID are 1000 and 100 respectively, these are shown on the attached EnvSettings screenshot.

      I noticed the PLEX_MEDIA_SERVER_USER is set to abc, is that normal?

      Thanks
      Images
      • EnvSettings.png

        43.45 kB, 910×573, viewed 13 times
      • VolumeMapping.png

        18.74 kB, 910×255, viewed 9 times
    • New

      Running ls-al /srv/dev-disk-by-label-3TBHDD/Media/ I get:

      pi@raspberrypi:~ $ ls -al /srv/dev-disk-by-label-3TBHDD/Media/
      total 16
      drwxrwsr-x 4 root users 4096 Jan2 13:38 .
      drwxr-xr-x 9 root root4096 Jan2 13:53 ..
      drwxrwsr-x 2 root users 4096 Jan2 16:53 Movies
      drwxrwsr-x 2 root users 4096 Jan2 14:13 Music
    • New

      Thanks gderf, the plexmediaserver.service file shows User=plex and Group=plex but when I run:

      sudochown -R plex:plex /srv/dev-disk-by-label-3TBHDD/Media/

      I get an error saying: chown:invalid user: ‘plex:plex’


      When I run: grep plex /etc/passwd I get nothing

      Would the solution be to add a plex user and group? If so, what commands should I run to do this properly?
    • New

      You could add plex:plex, but it would be better practice to have Plex run as another ordinary user that has control of the files Plex will be looking at.

      Why not create a new user on the system andrew:users and have the Plex container run as that user:group.
      --
      Google is your friend and Bob's your uncle!

      RAID - Its ability to disappoint is inversely proportional to the user's understanding of it.

      ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380