I killed Docker by moving location of docker base, removed it, cant reinstall

    • OMV 4.x
    • Resolved
    • I killed Docker, now I can't reinstall

      Linux noob here, I moved the location of the docker base path, which immediately resulted in an onslaught of errors and killed my containers. I googled around a bit and poked at it some but nothing seemed to make a difference, all I've really done is remove docker and attempt to reinstall. I've done apt-get purge for everything that had docker in the name when I ran dpkg -l, then a reboot (because i'm a network engineer?) then apt-get update and tried again.
      I was hoping someone that is more versed with linux might have an idea of where to go. This is just a side project I'm doing for fun, so a couple of shares, plex, and some docker instances to play with like pihole are all that live on this machine. I'm not afraid of starting back from scratch if I need to, but I've been poking around this forum for a few days and its been a wealth of knowledge and thought I'd try to learn something new.

      I've pasted the results of apt-get install -f (after re-enabling the docker repository). As a side note, if i do start from scratch, what are suggestions for running version 4 vs 5 beta for a Linux amateur? My background is networking, so I really only know enough to have false confidence and break things. Any help or pointers are appreciated, but I'll also accept unique or clever insults.

      TLDR: Broke docker, did some things, no fix, uninstalled, get errors when I try to re install
      Display Spoiler
      root@vault:~# sudo apt-get install -f
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      2 not fully installed or removed.
      After this operation, 0 B of additional disk space will be used.
      Setting up docker-ce (5:19.03.5~3-0~debian-stretch) ...
      Job for docker.service failed because the control process exited with error code.
      See "systemctl status docker.service" and "journalctl -xe" for details.
      invoke-rc.d: initscript docker, action "start" failed.
      ● docker.service - Docker Application Container Engine
      Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
      Active: activating (auto-restart) (Result: exit-code) since Thu 2020-01-16 17:07:08 EST; 13ms ago
      Docs: docs.docker.com
      Process: 16836 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
      Main PID: 16836 (code=exited, status=1/FAILURE)
      CPU: 199ms

      Jan 16 17:07:08 vault systemd[1]: docker.service: Unit entered failed state.
      Jan 16 17:07:08 vault systemd[1]: docker.service: Failed with result 'exit-code'.
      dpkg: error processing package docker-ce (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault-docker-gui:
      openmediavault-docker-gui depends on docker-ce (>= 5:19.03); however:
      Package docker-ce is not configured yet.
      openmediavault-docker-gui depends on docker-ce (<< 5:19.04); however:
      Package docker-ce is not configured yet.

      dpkg: error processing package openmediavault-docker-gui (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      docker-ce
      openmediavault-docker-gui
      Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fcde7ab37b8>
      Traceback (most recent call last):
      File "/usr/lib/python3.5/weakref.py", line 117, in remove
      TypeError: 'NoneType' object is not callable
      Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fcde7ab37b8>
      Traceback (most recent call last):
      File "/usr/lib/python3.5/weakref.py", line 117, in remove
      TypeError: 'NoneType' object is not callable
      E: Sub-process /usr/bin/dpkg returned an error code (1)

    • Fixed, I think I knew what I should have been asking for but I didn't have the confidence to say. I found the config file for docker was still pointing to the shared drive where I moved it to before.
      Writing up what I did here hoping it helps someone else
      I uninstalled docker from OMV
      Ran dpkg -l and used apt-get purge [i]package[/i] to uninstall everything that said docker. If memory serves, It was docker-ce, docker-ce-cli, and openmediavault-docker-gui.
      used rm -r to delete the docker folder in etc that contained the config file.

      I have no idea how much of that is actually necessary but I know the part that was broken was the config file that is at etc/dockerdaemon.json
      I opened it up using nano and saw that it referenced the shared file so I just deleted the whole folder and reinstalled.