Unwanted open ports

    • OMV 5.x (beta)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Unwanted open ports

      I have several open ports on OpenMediavault, that I don't want to be open, like the FTP port (21).

      That's insecure and specially weird, since, for example, I have FTP disabled on OMV GUI. After searching the forum, I have even tried to enable FTP and then disable it, but this trick does not work: the port continues open, no matter what.

      Is this happening only to me? Is there any fix for this?

      Thanks.
    • Two things... It doesn't have any config, so it shouldn't cause any harm. And you should have your omv system behind a firewall/router meaning the port doesn't matter unless you open that port on the firewall/router.

      But I maybe the following would fix it.

      sudo systemctl disable proftpd
      sudo systemctl stop proftpd
      omv 5.3.4 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Two things... It doesn't have any config, so it shouldn't cause any harm. And you should have your omv system behind a firewall/router meaning the port doesn't matter unless you open that port on the firewall/router.

      But I maybe the following would fix it.

      sudo systemctl disable proftpd
      sudo systemctl stop proftpd
      Hey man, thanks for the reply! My ISP gives me an ipv6 address with two options: firewall enabled or disabled. That's it, the ONT has no firewall customization at all for ipv6 (on ipv4, I could manage port forwarding, but it's not the case with ipv6). That's why I'm a little concerned about these open ports.

      I appreciate the suggestion about how to close the port 21, it worked! Could you also give me a hint about how to close the remaining ports? - 111, 139, 445 and 2049.
    • heinsenberg82 wrote:

      My ISP gives me an ipv6 address with two options: firewall enabled or disabled. That's it, the ONT has no firewall customization at all for ipv6 (on ipv4, I could manage port forwarding, but it's not the case with ipv6). That's why I'm a little concerned about these open ports.
      You could still use a router between your ISP and your network.

      heinsenberg82 wrote:

      Could you also give me a hint about how to close the remaining ports? - 111, 139, 445 and 2049.
      111 is nfs
      139 is samba/cifs
      445 is samba/cifs
      2049 is nfs

      So, you need to disable nfs and samba or add entries to the firewall tab in OMV.
      omv 5.3.4 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!