Rpi4 + OMV5 + PiHole via Portainer

    • OMV 5.x (beta)
    • limac wrote:

      ozboss wrote:

      So I don't know whether the underlying linux system (omv) or portainer handles the macvlan driver.
      Macvlan driver is from docker as far as I know.I couldn't say anything since this is too bizarre for my limited knowledge..

      But glad it helped. Although I also noticed that you would need to re-ping your desktop after sometime to keep the GUI working :)
      Nice security feature huh? lol
      You are right, the only reason it would be portainer is if it didn't create the macvlan settings correctly.
      But as you also tried it in docker directly with the same result it won't be portainers fault.
      Anyway I'm happy you found a temporary solution as this was driving me nuts.
      I recreated my macvlan network in every possible way, also tried to ping the container just not the other way around :D
      So I was just ready to reinstall omv, as I thought maybe first have a look in the forums.... :thumbsup:
    • limac wrote:

      (...)Although I also noticed that you would need to re-ping your desktop after sometime to keep the GUI working :) Nice security feature huh? lol
      Having same kind of issue.
      Even if I just jump my laptop between 2.4Ghz and 5Ghz networks, Pihole GUI will imediatly stop working. Then, if I ping from inside it, first 2 pings are always higher (~2sec and 1sec) and then it stabilizes and I have GUI again... strange... it wasn't like this some time ago...
    • OK I have some sort of update, I have installed OMV5 on my Pi 3B+ configured and fully updated before I started anything, installed docker then portainer.

      I pulled the pihole image using pihole/pihole:latest and pihole/pihole:4.3.2-1_armhf it appears to be the same image but with different tags ?(
      I also added a password for the root user on the Pi, this is not the norm as Raspbian prefer you to login as the pi user.

      Followed the original Pi-Hole How-To and created the dockerparms directory using the rootfs plugin.

      1) Using :latest this failed to load the Pi-Hole admin, ping from pi-hole's container console it works
      2) Stopped the container deleted it and deleted the share and contents, recreated the share and deployed pi-hole using :4.3.2-1_armhf same as option 1) ?(

      By this time it was getting late so left it alone until this morning;

      Stopped and deleted the container
      Deleted the share and contents on OMV

      Start again;

      Create the share /dockerparms as per the How-To under the rootfs added subfolders /pihole and /pihole/dnsmasq.d via SMB
      Deployed the container using :4.3.2-1_armhf and followed the How-To only difference being I added DNS1 and DNS2 to env as per the pihole set up on docker hub, double checked each setting before hitting deploy container. Cleared browser cache so there was no residual cache files.

      :thumbsup: :thumbsup: no ping necessary, however there is one caveat my router shows the pi-hole ip address as disconnected ?( but it works as I've changed the dns entry on my W10 workstation.

      WTF is going on, I have no idea, but one thing I do know this is a lot less hassle using a Pi as a dedicated Pi-Hole DNS without the need of docker!!
      Raid is not a backup! Would you go skydiving without a parachute?
    • limac wrote:

      ozboss wrote:

      Anyway I'm happy you found a temporary solution as this was driving me nuts.
      I feel you deeply 8)

      gperpetuo wrote:

      it wasn't like this some time ago...
      So yours was working before till recently?Did you notice anything changed or updated right before you have the issue?
      Like docker was updated or something like that.
      I removed and reinstaled docker and all containers last week or so... so I have no clue when exactly it stopped working... also, because I always had a second dns ip "in case" pihole would stop working...
      And since it was one of the easiest and straight forward containers to install... I really never cared or thought much about it...
    • geaves wrote:

      I pulled the pihole image using pihole/pihole:latest and pihole/pihole:4.3.2-1_armhf it appears to be the same image but with different tags
      Yeah, I can confirm that. It's the same image.

      geaves wrote:

      I added DNS1 and DNS2 to env
      I tried using DNS1=127.0.0.1 and DNS2=1.1.1.1 or 192.168.1.1 but still need to ping.

      gperpetuo wrote:

      I removed and reinstaled docker and all containers last week or so...
      Thanks. Tried a couple of old docker version and recreate macvlan, didn't seem helping.

      Anyways, I agree the easiest way is dedicate a Pi for this purpose.
      But I would assume anyone who uses macvlan might encounter the same issue with similar setup.
      I won't bother anymore as long as it takes some more steps to get to the GUI.


      Btw, Andriod also works, but need to wait longer for the ping :/