Receive Error: Could not fetch a matching mount point from the provided fsname: when attempting to create shared drives on NFS mount point file system

    • OMV 5.x (beta)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Receive Error: Could not fetch a matching mount point from the provided fsname: when attempting to create shared drives on NFS mount point file system

      Hello All,

      Wanting to see if anyone else is seeing this issue: I have installed OMV 5.3.0-1 in a VM on top of Proxmox VE 6.1-3, I created a large ZFS Pool in Proxmox VE as opposed to passing drives through to the ZFS plugin within OMV 5.3.0-1, I created a ZFS NFS share which I can connect to without issue from other NFS clients. Then I installed the remotemount 5.0.2 plugin and mounted a nfs file system mount via the remotemount plugin, the mount completed and mounted as a file system in OMV without error. I then attempted to create a fileshare and I received the error below:

      Error #0:
      OMV\Exception: Could not fetch a matching mount point from the provided fsname: '192.168.0.188:/Pool-A/Movies'. in /usr/share/php/openmediavault/system/filesystem/backend/remoteabstract.inc:209
      Stack trace:
      #0 /usr/share/php/openmediavault/system/filesystem/backend/remoteabstract.inc(139): OMV\System\Filesystem\Backend\RemoteAbstract::fetchMountPointFromFstabByFsnameAndType('192.168.0.188:/...', 'nfs4')
      #1 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(902): OMV\System\Filesystem\Backend\RemoteAbstract->getImpl('192.168.0.188:/...')
      #2 /usr/share/openmediavault/engined/rpc/sharemgmt.inc(88): OMV\System\Filesystem\Filesystem::getImplByMountPoint('/srv/4ca56533-7...')
      #3 [internal function]: Engined\Rpc\ShareMgmt->getCandidates(Array, Array)
      #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      #5 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getCandidates', Array, Array)
      #6 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('ShareMgmt', 'getCandidates', Array, Array, 1)

      #7 {main}

      I have seen reported issues with a similar error on earlier version of OMV and the remotemount plug-in and a suggestion to use NFS 3 as opposed to NFS 4, I tried that with the same result. Any and all assistance or suggestion are appreciated.

      Thanks in advance. :D
    • Update - I installed OMV 4.1.33-1 in Proxmox VE with the remotemount plug-in version 4.0.7 and I was able to create an NFS version 4 connection to my zfs pool NFS mount point and could also create a shared folder from within OMV with no issue.

      Based on what I discovered above the issue I am having with NFS remotemounts on OMV 5 appears to be specific to OMV 5.3.0-1 using the remotemount plugin 5.0.2.

      Any updates on when this will be resolved would be greatly appreciated.
    • Griff1962 wrote:

      Any updates on when this will be resolved would be greatly appreciated.
      I am so tired of this plugin... I will have to try to recreate it.
      omv 5.3.4 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Version 5.0.3 of the plugin in the repo now fixed the problem on my dev system.
      omv 5.3.4 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.5
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!