NEWBIE question anyone patient...

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • NEWBIE question anyone patient...

      Hi

      Managed to install OMV and have access to folders and so far working.
      Now tried to install OpenVPN following a tutorial on youtube, I get stuck on the beginning, when I tried to log in as root, says access denied.

      ssh is enabled & root access

      So I use the same password for all the accounts
      ssh root@192.168.99.189
      password: fail

      ssh admin@192.168.99.189
      password: ok

      ssh francisco@192.168.99.189
      password: ok

      I try to run the command but because I am not under root gives an error
      nano /etc/openmediavault/config.xml

      Any help would be appreciated.

      The post was edited 1 time, last by 007xico ().

    • geaves wrote:

      007xico wrote:

      So I use the same password for all the accounts
      Not a good idea :)

      007xico wrote:

      ssh root@192.168.99.189
      password: fail
      That would suggest that you typed the password in wrong or the password is different to the user admin.
      Anyhow this should help you resolve it
      I must be crap, never succeed at getting anything set up on the pi. Only thing that ever achieved was using it as a media center.

      I follow the instructions suggested above and still nothing.
      On my users there is two pi and Francisco.
      To my understanding I need to ssh to root, so I can follow the tutorial. Problem is when I ssh root@192.168.99.189 I get access denied but when I am on web ui I have ssh enabled and root access.
      I tried creating a new user called “user1” and on groups tick ssh, sido,root.
      then
      ssh user1@192.168.99.189
      password: xxxxx
      sudo root password: add a new one

      then
      ssh root@192.168.99.189
      Password: denied


      Confusing
    • 007xico wrote:

      Sorted, noob here.

      New user1 > groups ssh,sudo,users
      permit root login

      ssh user1@192.168.99.189
      password: xxxxxxxxx

      $ su -
      Password: xxxxxxxx
      root@openmediavault:~#
      OK, so your root password is fine. Are you sure you have root ssh enabled? When you enabled it, did you save and apply the settings? I'm not a fan of SSH as root anyway, and always SSH as a user, then change to root.. but now you know where the issue is.
      Air Conditioners are a lot like PC's... They work great until you open Windows.