Nextcloudpi won't initialise

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Nextcloudpi won't initialise

      Hi, I've run a docker container for Nextcloudpi. I've got it running and can get to the activation page.

      However once I click activate, it's stuck on "NextCloudPi not yet initialized, trying again in a few seconds ..."

      I decided to have a look at the container logs, it won't progress past starting mariaDB:
      Initializing empty volume..
      Making /usr/local/etc/ncp-config.d persistent ...
      Making /etc/services-enabled.d persistent ...
      Making /etc/letsencrypt persistent ...
      Making /etc/shadow persistent ...
      Making /etc/cron.d persistent ...
      Making /etc/cron.daily persistent ...
      Making /etc/cron.hourly persistent ...
      Making /etc/cron.weekly persistent ...
      Making /usr/local/bin persistent ...
      Making /etc/apache2 persistent ...
      Starting PHP-fpm
      Starting Apache
      Starting mariaDB
      2020-02-12 9:22:34 0 [Note] mysqld (mysqld 10.3.18-MariaDB-0+deb10u1) starting as process 102 ...

      It stops there and won't move onto:
      Starting Redis
      Starting Cron
      Starting Postfix
      etc. etc.

      I've got the container running in privileged mode, and the /data and /config shared folders i'm using are read/write/exec for everyone in OMV.
      The container ports are mapped 8080-> 80, 4433 -> 443, 4444 -> 443.

      Any ideas?

      I'm basing my install off Technodad's guide (with timestamp)
      and also Justin's guide in the comments from here: ownyourbits.com/2017/11/15/nex…-dockers-for-x86-and-arm/