Wake on LAN does not work

    • Wake on LAN does not work

      I want to use OMV as my NAS, but do not want to keep it running 24/7 as this is not necessary. I have downloaded the autoshutdown plugin and getting the machine to shutdown is working fine. I have set autoshutdown to monitor the IP of the iMac that I am using and to issue the "Suspend" shutdown command after a number of cycles.

      The next challenge is to get it to wake up again when I want to use the pc. I have checked the "Wake-on-LAN" for my eth0 network interface with which it is connected to the internet. The settings in the BIOS are also enabled and working properly; I have checked this by successfully doing WOL on the same computer in Windows.

      When autoshutdown has suspended the computer, the lights on the ethernet port are off, which is probably not a good sign. Have I missed something in the settings? Do I need to install something in addition to the autoshutdown plugin? How do I debug this WOL not working?

      Edit by Solo0815:
      changed Topic - This is no "autoshutdown-plugin" problem!
    • Re: Autoshutdown / Wake on LAN does not work

      Did you enable the checkbox in OMV -> Network Settings for your NIC?
      "Glowing days. Don't cry because they are over. Smile because they happened." - Confucius

      Server: 1x 32GB SSD (system) - 5x 2TB Data - 1x 2TB Snapraid-Parity - latest OMV 1.x
      No Support through PM
      Tutorials --- Howto install OMV-Extras --- Upgrade/Update-Problems --- If autoshutdown doesn' -work
    • Re: Autoshutdown / Wake on LAN does not work

      You mean the "Wake-on-LAN" checkbox under System -> Network -> Interfaces -> eth0? Yes, this checkbox is enabled.

      I also went through the process of installing all available updates. I am now running 0.5.43 of OMV with version 0.5.19 of the Autoshutdown plugin. This still leads to the same situation. The pc is successfully suspended by the plugin, but cannot be waked up (I use WakeOnLan on my iMac to send the magic packet; this worked fine for Windows).

      After pressing the power button the pc wakes up almost immediately and OMV works as expected again.
    • Re: Autoshutdown / Wake on LAN does not work

      You can also try to install the backport-kernel (3.2) from the omv-extras Plugin and see, if that works
      "Glowing days. Don't cry because they are over. Smile because they happened." - Confucius

      Server: 1x 32GB SSD (system) - 5x 2TB Data - 1x 2TB Snapraid-Parity - latest OMV 1.x
      No Support through PM
      Tutorials --- Howto install OMV-Extras --- Upgrade/Update-Problems --- If autoshutdown doesn' -work
    • Re: Autoshutdown / Wake on LAN does not work

      This is everything you need to activate. Really looks like a compatibility issue. I would try that again with OMV 0.6 and the backports 3.12 kernel
      OMV 4.x| HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV 4.x| Odroid XU4 | 5TB Data drive | 500GB Backup drive
      OMV 5.x| Raspberry Pi 4 | 6TB Data drive | 500GB SSD drive
    • Re: Wake on LAN does not work - Autoshutdown

      Hi,
      Just thought I'd chirp in here as I've been looking at this too.

      I was looking at trying to wake up the OMV NAS at a certain time of day using ACPI wakeups, which was also failing.

      So, in my case, all my problems stemmed from having "RTC Wakeup" enabled in the BIOS. This appears to disable all the other wakeups (Wake On LAN, wake by setting RTC, etc).

      And now, everything works fine - Wake On LAN and via timed wake ups.

      Hope that helps.