OMV on Zyxel NSA320 ?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • @Akeem
      The NSA-325 ist different to the NSA-320. I think you can use dfarnings method described on your linked pages. You'll also find a lot of helpful information and a rootfs on,12096 .

      I wanted the box booting from HD, because a USB-Pen drive will be defective after a week or shorter. The scripted setting of the uboot environment variables for hd-booting was my main challenge.

      A solution for the USB-problem could be the use of a SLC-PenDrive (e.g Mach Xtreme Technology ES SLC USB 3.0 Pen Drive - 8 GB) or an external USB-HD. The latter didn't work for the 320, because the USB-Ports don't deliver enough power for a disk - perhaps it's enough for a 2,5" SSD...

      For the rsync-config we made a HowTo a few weeks ago: Rsync two OMV machines

    • Meanwhile kernel 3.18 is running on my NSA-320, LED are blinking and the powerbutton switches the machine off. Everything seems to run fine thanks to the great work and help from bodhi in the

      As i wrote, i installed Debian and OMV on the first internal HDD, because a USB-flashdrive would be worn out too fast.

      Now i'm thinking about creating a datapartition on the same HDD where the rootfs-partition resides, from that the box boots (with parted while i mount the drive in another Linux system).
      Is it possible to mount a data-partition in OMV, that resides on the system-drive?
      If yes: will that significantly degrade the performance?

      What do you experts think about that?

    • No thoughts?
      Ok, i tried it, and it works: system and data on sda - sda1 (ext3) and sda2 (xfs).
      Testing from Win 8.1 with Helios LanTest over Gigabit LAN: 30 MB/s write, 17 MB/s read.
      h2testw: 34,8 MB/s write, 21,1 MB/s read.
      Test with separate HDDs follows...

      Test with separate Drives: Helios LanTest 20,4 MB/s write, 17,5 MB/s read
      h2testw: 30,1 MB/s write, 16 MB/s read.
      MTU in all tests was default 1500.
      Strange: write ist faster than read and single disk ist faster than separate disks.

      Any ideas where to optimize what settings?


      The post was edited 1 time, last by JanN ().

    • I quite like your monologue.
      I can't be of any assistance, but would be interested in a step-by-step to be able to use OMV ánd use both internal HDDs.
      I wouldn't mind to buy a USB-SSD device.

      I'd would love to use btsync on the main OMV box ánd on the NSA325. Btsync does exactly what I wanted to achieve with rsync.
    • Follow the tutorial here,14351
      Use the rootfs linux-3.16.0-kirkwood-tld-2-rootfs-bodhi.tar.bz2 from 02 Sept 2014 in the thread,12096 and not the latest as said in the tutorial. Going beyond that rootfs requires you to flash a more advanced bootloader, which is not something for the faint of heart (also because it makes the device unable to boot its own original firmware).

      I have a zyxel nsa325v2 and it works.

      Although I have already flashed a better bootloader and I'm not anymore at the rootfs 3.16.

      The post was edited 1 time, last by bobafetthotmail ().

    • JanN wrote:

      Just got it: my NSA320 runs Kralizec 1.12 on Kernel 3.17.0 booted from the first internal HD. :D

      Now i have to test the performance of the box under OMV - if it's sufficient, it'll become my backup machine...

      If someone (or two ;) ) is(are) interested, i could write a HowTo...


      I have a NSA320 and would be very interested in getting it running on my device. Have seen some instructions, also from the NS325. But just only few information on nsa 320. Or can i follow instructions which are given for NSA325?
      Could give me step by step HowTo (if you may do do not have it already)?? or do we have to wait for one more on NSA 320 device ;)
    • Pioneers did it with serial cable to the board or with hacks from the web interface, and that's what is more commonly found in tutorials. Nowadays there are easy installers using a script.

      Here for example there is a nice installer with simple instructions, but works for Arch linux, not for Debian.
      Will modify it a bit to make a version that allows you to boot Debian.
      Just like the tutorial I posted above for the NSA325V2, that is actually using a modified version of the Arch installer for the NSA 325.
      These things are always done AT YOUR OWN RISK. If you don't feel safe enough, DON'T DO IT.

      AFAIK, the u-boot (bootloader, the BIOS of this thing) is too old to be able to boot from USB, can only boot the NAS's original firmware from the flash on its motherboard (too small to install debian in it) or from Sata drives. More updated u-boots with plenty of advanced features are available in the forums of the links above, but it's dangerous to update as if you do it wrong the device can only be restored through the serial cable (IF it can be restored at all), just like updating a BIOS anyway.

      After you followed instructions below and it did its thing, the NAS will be
      set to boot from the left Sata drive, and won't boot again its own
      firmare. (this can be changed easily from inside the Debian system, and
      from a serial connection to the motherboard, but if you don't have
      either working, it's not possible to do anything and you are in trouble)

      So, download the installer zip I modified from here…INUX/
      Extract the contents of that zip inside an EMPTY USB flash drive.

      Then download the rootfs (the Debian system for these devices, same as link above)
      The file is Debian-3.16.0-kirkwood-tld-2-rootfs-bodhi.tar.bzip2, so it is compressed with bzip2 and I have no idea if the firmware of the device is able to handle it, so we need to convert the archive to tar.gzip first.
      Download Peazip (it is portable version, will run without installing itself)
      Then extract the archive you downloaded, you should get another archive called Debian-3.16.0-kirkwood-tld-2-rootfs-bodhi.tar
      Now use Peazip to compress it again, but this time select Gzip (it is set to 7z by default, you don't want that, change it to Gzip).
      Now you should get a file called Debian-3.16.0-kirkwood-tld-2-rootfs-bodhi.tar.gzip
      Rename the file into rootfs.tgz
      Very important as the install script will look for this name to install Debian.
      Then place this file in the same USB flash drive you placed the files of the installer zip above.
      Shut down the NAS.
      Place a EMPTY HDD in left slot (the installer WILL ERASE ANYTHING ON THAT DRIVE, so IT MUST BE EMPTY), remove the drive from the other slot, place the USB flash drive into the front USB port, power on the device.
      Wait a bit. It has to unzip the contents of that file (among other things), and that's a weak processor, so it will take some time.
      After it has finished it will reboot on its own, and if all went well it will be running Debian ARM this time.

      If it was connected to ethernet, it will get an IP address automatically when rebooting.
      At this point it's just a headless (no graphical interface) Debian Wheezy system like any other.
      You need to connect to it with SSH (remote terminal), if you don't know how, see this tutorial…om-windows-by-using-putty
      User: root
      Password: root

      (when you have finished the setup it would be a good idea to change the default password of root user)

      Then you follow the instructions here to install OpenMediaVault, (ignore pre-requirements because you have already a running Debian Wheezy in that NAS)
      Howto install OpenMediaVault on Debian 7.x (Wheezy)

      It will take a while because it has to download quite a few things, and its weak processor will slow down the installation process.

      When I did it, something of OMV failed to install and required a manual tweak, if it happens to you too (I think it was fixed but you never know), post the error and I'll see what I can do.

      The installation will take around 10 GB of the drive inside the NAS for system partitions, the rest of the space will become another partition you can use for data (look in Storage ----> Filesystems to set Openmediavault to mount it and use it).

      NEVER EVER install any Kernel or Grub, the Debian running inside these devices has a custom Kernel, if you install another (not from the forums above) it will not boot anymore. Grub is a bootloader, you have already u-boot for that.

      ======Will give you a run down of what happens while you wait and it installs Debian. ===========
      ======Mainly informative purposes, you can skip reading this if you want========
      The installer is a script that exploits the fact that this NAS is set to look inside USB drives when booting.
      If it finds the stuff that you placed into it (some keys plus a script with a peculiar name) it reacts by loading and executing the script.

      The script changes the boot options in the u-boot.

      The script then ERASES EVERYTHING that is currently on the left sata drive, so USE AN EMPTY DISK OR YOU WILL LOSE DATA, also REMOVE ANY OTHER DISK FROM THE NAS while you are doing this.
      Then it makes a couple partitions it needs, using around 10 GB of disk space. The rest of the space becomes a third partition you can use for data.
      Then it unzips the rootfs.tgz (this is the archive with Debian inside) and moves the files where they need to go.
      Since the processor is weak the unzipping will take some time, be patient.

      Then it will reboot, and if everything went well the NAS will boot Debian Wheezy for ARM.

      The post was edited 1 time, last by bobafetthotmail ().

    • Nice guide, tried it already and did everything in same way you describe aboved. BUT seems I chrashed my system, also can not install again via USB Stick.
      Connected with serial cable and got folloing output. any idea what i could do nex?

      | \/ | __ _ _ ____ _____| | |
      | |\/| |/ _` | '__\ \ / / _ \ | |
      | | | | (_| | | \ V / __/ | |
      |_| |_|\__,_|_| \_/ \___|_|_|
      _ _ ____ _
      | | | | | __ ) ___ ___ | |_
      | | | |___| _ \ / _ \ / _ \| __|
      | |_| |___| |_) | (_) | (_) | |_
      \___/ |____/ \___/ \___/ \__|
      ** MARVELL BOARD: RD-88F6281A LE

      U-Boot 1.1.4 (Mar 23 2011 - 16:09:39) Marvell version: 3.4.19

      U-Boot code: 00600000 -> 0067FFF0 BSS: -> 006CFEE0

      Soc: 88F6281 A1 (DDR2)
      CPU running @ 1200Mhz L2 running @ 400Mhz
      SysClock = 400Mhz , TClock = 200Mhz

      DRAM CAS Latency = 5 tRP = 5 tRAS = 18 tRCD=6
      DRAM CS[0] base 0x00000000 size 256MB
      DRAM CS[1] base 0x10000000 size 256MB
      DRAM Total size 512MB 16bit width
      Addresses 10M - 0M are saved for the U-Boot usage.
      Mem malloc Initialization (10M - 7M): Done
      NAND:128 MB
      Flash: 0 kB

      CPU : Marvell Feroceon (Rev 1)
      //--- stateButtonBit = 3, recovery ---//
      Kernel address is 0x4640000.

      Streaming disabled
      Write allocate disabled

      Module 0 is RGMII
      Module 1 is TDM

      USB 0: host mode
      PEX 0: interface detected no Link.
      Net: egiga0, egiga1 [PRIME]
      Hit any key to stop autoboot: 0

      Reset IDE:
      Marvell Serial ATA Adapter
      Integrated Sata device found
      [0 0 0]: Enable DMA mode (6)
      Device 0 @ 0 0:
      Model: ST2000DM001-9YN164 Firm: CC4B Ser#: Z2F0CCD1
      Type: Hard Disk
      Supports 48-bit addressing
      Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)

      ** Unable to read "/uImage" from ide 0:1 **

      ** Unable to read "/uInitrd" from ide 0:1 **
      ## Booting image at 02000000 ...
      Bad Magic Number

      best wishes
    • Ops, sorry for that. :(
      Since you have the serial connection we can find out where I screwed up and make an installer that actually works next time. :)
      I'm also uploading a rootfs.tgz that I'm sure it works, whenever ready I'm posting the link.
      Also you can fix the issue right away, see below after the ===============

      It seems it does not find the boot partitions.
      this line (and the other similar one)

      Source Code

      1. Unable to read "/uImage" from ide 0:1

      says it is trying to load Debian from a disk located at address 0, from the partition 1.
      The disk you have is being seen as Disk 0, but what about partitions?

      Power on the device, press a key to stop autobooting

      Then you will see
      Marvell >>
      and a blinking cursor,

      ide partition 0

      then can you post the output here?

      also, can you write


      and post the output here?

      In the forum reply box there is a <> button, select all the text you pasted from the console and press that button. It will add tags so the forum displayes correctly the text and will not look messy.

      If you are in a hurry, you can return to boot its own firmware, see below.

      Power on the device, press a key to stop autobooting

      Then you will see
      Marvell >>
      and a blinking cursor,
      you will need to write

      setenv to_stock

      and then press enter
      then write


      and press enter
      then write


      And press enter again.

      The first command tells the u-boot to go back to booting the NAS's own firmware, the second tells the uboot to save the setting, the last asks it to reboot.

      The post was edited 8 times, last by bobafetthotmail ().

    • I did all these manipulations by hand, not with a script.

      Maybe uboot ist looking for uInitrd and uImage in the root directory, but they are in the boot directory in bodhis rootfs. I made symbolic links in root to the files in /boot to solve this.

      I used another linux machines (my OMV-Microserver) cli for that: just connected the NSA-hdd with an USB-SATA-Adapter and mounted the disk. Mind that the symbolic links must be relative, not absolute.

    • JanN wrote:

      I did all these manipulations by hand, not with a script.
      A script is more user-friendly and saves time when doing mainteneance. Once it is written correctly and it does not fail, anyway.

      I did it by hand in my 325V2 (also because I have Linux Mint Debian on my netbook, so working with Linux paritions and archives is pretty easy as I just need to use Gparted and other standard tools) and also hot-booted the nas with another uboot through the serial (to be sure that in case i screwed up when flashing the newer uboot I could still unbrick the device), so it's not like I'm unable to do everything by hand.

      Maybe uboot ist looking for uInitrd and uImage in the root directory
      if the script ran correctly the contents of boot directory are in first partition (ext2), and the rootfs (parameters passed to kernel) is the partition labeled "rootfs" (the second partition, an ext4 that the uboot itself cannot read, but that's irrelevant as it's stuff that will be done by the kernel).

      I made symbolic links in root to the files in /boot to solve this.
      if your u-boot can read the boot partition (and if it is an ext3 it can) you just need to change any instance of /uInitrd to /boot/uInitrd and the same for the
      /uImage to /boot/uImage in its envs.

      After he posts the results printenv I can make a script that sets the u-boot for multibooting (like I did in my NSA325v2 before I decided to flash the new u-boot), so if booting from Sata fails it will proceed and boot its own firmware again.
      Doing so without looking at his uboot envs would have been too dangerous.

      it is just a line like this (taken from another uboot)

      Source Code

      1. bootcmd=run bootcmd_uenv; run bootcmd_usb; run bootcmd_sata; reset
      if "bootcmd_uenv" fails it will go on and run "bootcmd_usb", if that fails it will run "bootcmd_sata", if that fails too it will reboot and try again. If any of these commands run, the NAS will boot a kernel, and the uboot sequence stops because the kernel takes over.
      Even if the uboot is dumb and old this trick works.
      The same can be done to make the u-boot able to boot from either Sata drive (theoretically).

      With newer uboots it's a piece of cake (also pre-set in standard envs) as they have decent scripting support like can understand "if-then" loops and so on.

      Strange: write ist faster than read and single disk ist faster than separate disks.
      Any ideas where to optimize what settings?
      You tried using ext4 instead of xfs filesystem? I'm getting higher speeds than yours and I'm using ext4. Even the original firmware uses ext4 for hard drives, but that's faster for unknown reasons (probably better tuned for hardware).
      also someone else that reports the same, for the sake of giving some proofs of what I say.,14351,17328#msg-17328

      Yes, I know that many people say xfs is lighter on CPU.

      Another thing you can try is adding noatime and big_writes in the mount options of the data partitions in /etc/fstab and maybe optimize samba config as explained here.

      The post was edited 4 times, last by bobafetthotmail ().

    • I already got my device back to stock firmware in easy way with serial connection.
      I would like to have an script for it as i´m not too familar with Linux, programming, etc. Glad to see you will go on with it and help me.

      Late afternoon when I´m at hope i will do steps of installing debian again and post my outputs with above points as well.
    • Ty for your patience. Not having the exact device does make this harder than it should.

      I made a rootfs.tgz with linux compression tools for you (just in case Peazip was screwing up, and also because premade is better), if you reinstall can you can use this?
      it is ready to be placed in the USB drive

      Can you post the results of printenv before and after you tried to install with the script?

      Since you are going to reinstall the script anyway to test, now with serial connection attached when installing you can see what is happening when the script runs and any error message that happens will be useful for me.
      You will get a wall of text and random things as the firmware is very chatty, I don't need all that.
      The parts that matter are the text that you get after you see

      Automatic Installation of Arch Linux ARM

      as that means that the NAS is executing the modified install script.

      Did not change the original name and the debug text (there are some typos), but it does not really matter.

      If we get this working, next step is doing something similar for NSA325V2 that can boot from USB too without installing a new uboot, so any brave tester for that is also welcome, a working serial connection is warmly recommended for troubleshooting. (as I'm not going to flash stock uboot into my own NAS just to test this, flashing uboot is dangerous, as long as you have serial connection you can easily fix any issue caused by the script).

      Theoretically also NSA310 (the one-bay nas from zyxel) should be exactly the same as NSA320 (just one less sata), so after this gets fixed this installer can take over a NSA310 too.

      There is also the NSA320S (same as NSA320 but in the same box as the NSA325V2) and NSA310S (box that looks like NSA325v2 but slimmer).
      This is NSA320…wer-media-server-reviewed
      This is NSA320S

      The post was edited 5 times, last by bobafetthotmail ().

    • Ok, i did some new tests and run and also wrote down the infos you asked for. Hope this helps you - for me it´s like chinese - to find where the problem is.

      1. printenv before using script from USB:

      Source Code

      1. NSA320>> printenv
      2. bootargs=console=ttyS0,115200 mtdparts=nand_mtd:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2) root=/dev/nfs rw init=/init
      3. bootcmd=nand read.e 0x2000000 $(kernel_addr) 0xA00000; bootm 0x2000000
      4. bootdelay=2
      5. baudrate=115200
      6. loads_echo=0
      7. ethaddr=00:19:CB:00:51:81
      8. eth1addr=00:19:CB:00:51:82
      9. ipaddr=
      10. serverip=
      11. rootpath=/mnt/ARM_FS/
      12. netmask=
      13. nandEcc=1bit
      14. MODEL_ID=DD01
      15. PRODUCT_NAME=NSA-320
      16. FEATURE_BIT=00
      17. CONTRY_TYPE=FF
      18. VENDOR_NAME=ZyXEL Communications Corp.
      19. run_diag=yes
      20. stdin=serial
      21. stdout=serial
      22. stderr=serial
      23. console=console=ttyS0,115200 mtdparts=nand_mtd:0xc0000@0(uboot)ro,0x7f00000@0x100000(root)
      24. mainlineLinux=no
      25. CASset=min
      26. enaMonExt=no
      27. enaCpuStream=no
      28. enaWrAllo=no
      29. pexMode=RC
      30. disL2Cache=no
      31. setL2CacheWT=yes
      32. disL2Prefetch=yes
      33. enaICPref=yes
      34. enaDCPref=yes
      35. sata_dma_mode=yes
      36. ethprime=egiga1
      37. netbsd_en=no
      38. vxworks_en=no
      39. bootargs_root=root=/dev/nfs rw
      40. bootargs_end=:::DB88FXX81:eth0:none
      41. image_name=uImage
      42. standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
      43. disaMvPnp=no
      44. ethmtu=1500
      45. eth1mtu=1500
      46. mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
      47. mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
      48. usb0Mode=host
      49. yuk_ethaddr=00:00:00:EE:51:81
      50. hddPowerCtrl=no
      51. netretry=no
      52. rcvrip=
      53. loadaddr=0x02000000
      54. autoload=no
      55. enaAutoRecovery=yes
      56. kernel_addr=0x4640000
      57. pcieTune=no
      58. ethact=egBAa1
      59. Environment size: 1558/131068 bytes
      Display All

      2. printenv after using script from USB:

      Source Code

      1. NSA320>> printenv
      2. bootdelay=2
      3. baudrate=115200
      4. loads_echo=0
      5. ethaddr=00:19:CB:00:51:81
      6. eth1addr=00:19:CB:00:51:82
      7. ipaddr=
      8. serverip=
      9. rootpath=/mnt/ARM_FS/
      10. netmask=
      11. nandEcc=1bit
      12. MODEL_ID=DD01
      13. PRODUCT_NAME=NSA-320
      14. FEATURE_BIT=00
      15. CONTRY_TYPE=FF
      16. VENDOR_NAME=ZyXEL Communications Corp.
      17. run_diag=yes
      18. arcNumber=3956
      19. bootargs_stock=console=ttyS0,115200 mtdparts=nand_mtd:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2) root=/dev/nfs rw init=/init
      20. bootargs_linux=console=ttyS0,115200 mtdparts=nand_mtd:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2) root=LABEL=rootfs loglevel=8
      21. bootcmd_linux=setenv bootargs $(bootargs_linux); ide reset; ext2load ide 0:1 $(loadaddr) /uImage; ext2load ide 0:1 0x01100000 /uInitrd; bootm $(loadaddr) 0x01100000
      22. bootcmd_stock=setenv bootargs $(bootargs_stock); nand read.e $(loadaddr) $(kernel_addr) 0xA00000; bootm $(loadadr)
      23. to_stock=setenv mainlineLinux no; setenv bootcmd \'run bootcmd_stock\'; saveenv; reset
      24. to_linux=setenv mainlineLinux yes; setenv bootcmd \'run bootcmd_linux\'; saveenv; reset
      25. console=100000
      26. =ttyS0,115200 mtdparts=nand_mtd:0xc0000@0(uboot)ro,0x7f00000@0x100000(root)
      27. CASset=min
      28. ethprime=egiga1
      29. bootargs_root=root=/dev/nfs rw
      30. bootargs_end=:::orion:eth0:none
      31. image_name=uImage
      32. standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end) $(mvPhoneConfig); bootm 0x2000000;
      33. ethmtu=1500
      34. eth1mtu=1500
      35. mvPhoneConfig=mv_phone_config=dev0:fxs,dev1:fxs
      36. mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
      37. usb0Mode=host
      38. yuk_ethaddr=00:00:00:EE:51:81
      39. netretry=no
      40. rcvrip=
      41. loadaddr=0x02000000
      42. autoload=no
      43. bootcmd='run bootcmd_linux'
      44. stdin=serial
      45. stdout=serial
      46. stderr=serial
      47. nandEnvBase=100000
      48. mainlineLinux=yes
      49. enaMonExt=no
      50. enaCpuStream=no
      51. enaWrAllo=no
      52. pexMode=RC
      53. disL2Cache=no
      54. setL2CacheWT=yes
      55. disL2Prefetch=yes
      56. enaICPref=yes
      57. enaDCPref=yes
      58. sata_dma_mode=yes
      59. MALLOC_len=3
      60. netbsd_en=no
      61. vxworks_en=no
      62. disaMvPnp=no
      63. hddPowerCtrl=no
      64. enaAutoRecovery=yes
      65. kernel_addr=0x4640000
      66. pcieTune=no
      67. ethact=egiga1
      68. bootargs=console=ttyS0,115200 mtdparts=nand_mtd:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2) root=LABEL=rootfs loglevel=8
      69. Environment size: 2496/131068 bytes
      Display All
    • 3. output of printenv after "Automatic Installation of Arch Linux ARM"

      Source Code

      1. Automatic Installation of Arch Linux ARM
      2. - set bootloader
      3. - parition sda
      4. The number of cylinders for this disk is set to 243201.
      5. There is nothing wrong with that, but this is larger than 1024,
      6. and could in certain setups cause problems with:
      7. 1) software that runs at boot time (e.g., old versions of LILO)
      8. 2) booting and partitioning software from other OSs
      9. (e.g., DOS FDISK, OS/2 FDISK)
      10. Command (m for help): Building a new DOS disklabel with disk identifier 0x2d8e4759.
      11. Changes will remain in memory only, until you decide to write them.
      12. After that, of course, the previous content won't be recoverable.
      13. The number of cylinders for this disk is set to 243201.
      14. There is nothing wrong with that, but this is larger than 1024,
      15. and could in certain setups cause problems with:
      16. 1) software that runs at boot time (e.g., old versions of LILO)
      17. 2) booting and partitioning software from other OSs
      18. (e.g., DOS FDISK, OS/2 FDISK)
      19. Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)
      20. Command (m for help): Command action
      21. e extended
      22. p primary partition (1-4)
      23. Partition number (1-4): First cylinder (1-243201, default 1): Using default value 1
      24. Last cylinder, +cylinders or +size{K,M,G} (1-243201, default 243201):
      25. Command (m for help): Command (m for help): Command action
      26. e extended
      27. p primary partition (1-4)
      28. Partition number (1-4): First cylinder (15-243201, default 15): Using default value 15
      29. Last cylinder, +cylinders or +size{K,M,G} (15-243201, default 243201):
      30. Command (m for help): Command (m for help): Command action
      31. e extended
      32. p primary partition (1-4)
      33. Partition number (1-4): First cylinder (1291-243201, default 1291): Using default value 1291
      34. Last
      35. cylinder, +cylinders or +size{K,M,G} (1291-243201, default 243201):
      36. Last cylinder, +cylinders or +size{K,M,G} (1291-243201, default 243201):
      37. Last cylinder, +cylinders or +size{K,M,G} (1291-243201, default
      38. 243201): Using default value 243201
      39. Command (m for help): Command (m for help): Command (m for help):
      40. got EOF thrice - exiting..
      41. * pause for ioctl to re-sync partitions
      42. - make filesystems
      43. mkfs.ext2: can't format mounted filesystem
      44. mke2fs 1.41.14 (22-Dec-2010)
      45. Filesystem label=rootfs
      46. OS type: Linux
      47. Block size=4096 (log=2)
      48. Fragment size=4096 (log=2)
      49. Stride=0 blocks, Stripe width=0 blocks
      50. 122068992 inodes, 488249488 blocks
      51. 24412474 blocks (5.00%) reserved for the super user
      52. First data block=0
      53. Maximum filesystem blocks=0
      54. 14901 block groups
      55. 32768 blocks per group, 32768 fragments per group
      56. 8192 inodes per group
      57. Superblock backups stored on blocks:
      58. 32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
      59. 4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,
      60. 102400000, 214990848
      61. Writing inode tables: done
      62. Creating journal (32768 blocks): done
      63. Writing superblocks and filesystem accounting information: done
      64. This filesystem will be automatically checked every 21 mounts or
      65. 180 days, whichever comes first. Use tune2fs -c or -i to override.
      66. mke2fs 1.41.14 (22-Dec-2010)
      67. mkfs.ext4: No such device or address while trying to determine filesystem size
      68. - mount destination
      69. mount: /dev/sda1 already mounted or /tmp/boot busy
      70. mount: according to mtab, /dev/sda1 is mounted on /zyxel/mnt/sysdisk
      71. EXT4-fs (sda2): barriers enabled
      72. kjournald2 starting: pid 1371, dev sda2:8, commit interval 5 seconds
      73. EXT4-fs (sda2): internal journal on sda2:8
      74. EXT4-fs (sda2): delayed allocation enabled
      75. EXT4-fs: file extents enabled
      76. EXT4-fs: mballoc enabled
      77. EXT4-fs (sda2): mounted filesystem with ordered data mode
      78. - extract rootfs
      79. - prepare boot partition
      80. cp: can't stat '/tmp/rootfs/boot/*': No such file or directory
      81. - REBOOTING!
      82. led_state_map_addr = 4e
      83. Starting "/etc/init.d/".
      84. Stopping all zypkgs via "/etc/init.d/" ...
      85. - shutdowning package "NFS" ...
      86. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/NFS" is not existed or not excutable
      87. - shutdowning package "BackupPlanner" ...
      88. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/BackupPlanner" is not existed or not excutable
      89. - shutdowning package "SMART" ...
      90. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/SMART" is not existed or not excutable
      91. - shutdowning package "DyDNS" ...
      92. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/DyDNS" is not existed or not excutable
      93. - shutdowning package "SqueezeCenter" ...
      94. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/SqueezeCenter" is not existed or not excutable
      95. - shutdowning package "eMule" ...
      96. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/eMule" is not existed or not excutable
      97. - shutdowning package "gallery" ...
      98. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/gallery" is not existed or not excutable
      99. - shutdowning package "WordPress" ...
      100. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/WordPress" is not existed or not excutable
      101. - shutdowning package "PHP-MySQL-phpMyAdmin" ...
      102. ---> Error: shutdown program "/usr/local/zy-pkgs/etc/init.d/PHP-MySQL-phpMyAdmin" is not existed or not excutable
      103. /etc/init.d/ line 491: can't open /i-data/md0/admin/zy-pkgs/USRPKG_DEPS_SHUTDOWN: no such file
      104. Finish "/etc/init.d/".
      105. Starting "/etc/init.d/".
      106. Starting to release zy-pkgs environment ...
      107. umount: /usr/local/apache/htdocs/adv,/pkg: not mounted
      108. umount: /etc/zyxel/zy-pkgs: not mounted
      109. umount: /usr/local/zy-pkgs: not mounted
      110. Finish "/etc/init.d/".
      111. start kill.
      112. sh: you need to specify whom to kill
      113. BusyBox v1.17.2 (2014-02-13 13:59:56 CST) multi-call binary.
      114. Usage: swapoff [-a] [DEVICE]
      115. rootfs / rootfs rw 0 0
      116. /proc /proc proc rw,relatime 0 0
      117. /sys /sys sysfs rw,relatime 0 0
      118. none /proc/bus/usb usbfs rw,relatime 0 0
      119. devpts /dev/pts devpts rw,relatime,mode=600 0 0
      120. /dev/mtdblock8 /zyxel/mnt/nand yaffs2 ro,relatime 0 0
      121. /dev/sda1 /zyxel/mnt/sysdisk ext2 ro,relatime,errors=continue 0 0
      122. /dev/loop0 /ram_bin ext2 ro,relatime,errors=continue 0 0
      123. /dev/loop0 /usr ext2 ro,relatime,errors=continue 0 0
      124. /dev/loop0 /lib/security ext2 ro,relatime,errors=continue 0 0
      125. /dev/loop0 /lib/modules ext2 ro,relatime,errors=continue 0 0
      126. /dev/ram0 /tmp/tmpfs tmpfs rw,relatime,size=5120k 0 0
      127. /dev/ram0 /usr/local/etc tmpfs rw,relatime,size=5120k 0 0
      128. /dev/ram0 /usr/local/var tmpfs rw,relatime,size=5120k 0 0
      129. /dev/sdb1
      130. /mnt/parnerkey vfat
      131. rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=utf8,shortname=mixed,errors=remount-ro
      132. 0 0
      133. /dev/sda2 /tmp/rootfs ext4 rw,relatime,barrier=1,data=ordered 0 0
      134. The system is going down NOW!
      135. Sent SIGTERM to all processes
      136. Sent SIGKILL to all processes
      137. Requesting system reboot
      138. md: stopping all md devices.
      139. sd 0:0:0:0: [sda] Synchronizing SCSI cache
      140. Restarting system.
      141. Reseting !!
      142. __ __ _ _
      143. | \/ | __ _ _ ____ _____| | |
      144. | |\/| |/ _` | '__\ \ / / _ \ | |
      145. | | | | (_| | | \ V / __/ | |
      146. |_| |_|\__,_|_| \_/ \___|_|_|
      147. _ _ ____ _
      148. | | | | | __ ) ___ ___ | |_
      149. | | | |___| _ \ / _ \ / _ \| __|
      150. | |_| |___| |_) | (_) | (_) | |_
      151. \___/ |____/ \___/ \___/ \__|
      152. ** MARVELL BOARD: RD-88F6281A LE
      153. U-Boot 1.1.4 (Mar 23 2011 - 16:09:39) Marvell version: 3.4.19
      154. U-Boot code: 00600000 -> 0067FFF0 BSS: -> 006CFEE0
      155. Soc: 88F6281 A1 (DDR2)
      156. CPU running @ 1200Mhz L2 running @ 400Mhz
      157. SysClock = 400Mhz , TClock = 200Mhz
      158. DRAM CAS Latency = 5 tRP = 5 tRAS = 18 tRCD=6
      159. DRAM CS[0] base 0x00000000 size 256MB
      160. DRAM CS[1] base 0x10000000 size 256MB
      161. DRAM Total size 512MB 16bit width
      162. Addresses 10M - 0M are saved for the U-Boot usage.
      163. Mem malloc Initialization (10M - 7M): Done
      164. NAND:128 MB
      165. Flash: 0 kB
      166. CPU : Marvell Feroceon (Rev 1)
      167. //--- stateButtonBit = 3, recovery ---//
      168. Kernel address is 0x4640000.
      169. Streaming disabled
      170. Write allocate disabled
      171. Module 0 is RGMII
      172. Module 1 is TDM
      173. USB 0: host mode
      174. PEX 0: interface detected no Link.
      175. Net: egiga0, egiga1 [PRIME]
      176. Hit any key to stop autoboot: 0
      177. Saving Environment to NAND...
      178. Erasing Nand...Writing to Nand... done
      179. __ __ _ _
      180. | \/ | __ _ _ ____ _____| | |
      181. | |\/| |/ _` | '__\ \ / / _ \ | |
      182. | | | | (_| | | \ V / __/ | |
      183. |_| |_|\__,_|_| \_/ \___|_|_|
      184. _ _ ____ _
      185. | | | | | __ ) ___ ___ | |_
      186. | | | |___| _ \ / _ \ / _ \| __|
      187. | |_| |___| |_) | (_) | (_) | |_
      188. \___/ |____/ \___/ \___/ \__|
      189. ** MARVELL BOARD: RD-88F6281A LE
      190. U-Boot 1.1.4 (Mar 23 2011 - 16:09:39) Marvell version: 3.4.19
      191. U-Boot code: 00600000 -> 0067FFF0 BSS: -> 006CFEE0
      192. Soc: 88F6281 A1 (DDR2)
      193. CPU running @ 1200Mhz L2 running @ 400Mhz
      194. SysClock = 400Mhz , TClock = 200Mhz
      195. DRAM CAS Latency = 5 tRP = 5 tRAS = 18 tRCD=6
      196. DRAM CS[0] base 0x00000000 size 256MB
      197. DRAM CS[1] base 0x10000000 size 256MB
      198. DRAM Total size 512MB 16bit width
      199. Addresses 10M - 0M are saved for the U-Boot usage.
      200. Mem malloc Initialization (10M - 7M): Done
      201. NAND:128 MB
      202. Flash: 0 kB
      203. CPU : Marvell Feroceon (Rev 1)
      204. //--- stateButtonBit = 3, recovery ---//
      205. Kernel address is 0x4640000.
      206. Streaming disabled
      207. Write allocate disabled
      208. Module 0 is RGMII
      209. Module 1 is TDM
      210. USB 0: host mode
      211. PEX 0: interface detected no Link.
      212. Net: egiga0, egiga1 [PRIME]
      213. Hit any key to stop autoboot: 0
      214. Reset IDE:
      215. Marvell Serial ATA Adapter
      216. Integrated Sata device found
      217. [0 0 0]: Enable DMA mode (6)
      218. Device 0 @ 0 0:
      219. Model: ST2000DM001-9YN164 Firm: CC4B Ser#: Z2F0CCD1
      220. Type: Hard Disk
      221. Supports 48-bit addressing
      222. Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)
      223. ** Unable to read "/uImage" from ide 0:1 **
      224. ** Unable to read "/uInitrd" from ide 0:1 **
      225. ## Booting image at 02000000 ...
      226. Bad Magic Number
      Display All
    • 4. Info after "ide partition 0"

      Source Code

      1. NSA320>> ide partition 0
      2. Partition Map for IDE device 0 -- Partition Type: DOS
      3. Partition Start Sector Num Sectors Type
      4. 1 63 1028097 8
      5. 2 1028160 -388971391 20

      A lot of codes and words . . . not sure if this really helps you. if i
      have to send more info or should test something else i would do.
    • Yeah, it did help me. Ty. :)
      Old links above are broken now, unnecessary and dangerous.

      All-in-one-installer is here
      Download and extract in the zip in the USB, read the README.txt file included in the package for further instructions.

      Tell me if the lights and buttons work well (or at all) in Debian ARM, if they don't I will ask you to post some more things so I can fix manually the rootfs (and give you some quick instructions for your NAS so you don't have to reinstall everything) to get them running properly.

      The NSA325V2's button and lights required manual setup when I installed (a bunch of text copy-pasted into some configuration files, nothing major), this was no more needed in later rootfs releases by bodhi in those forums (that can't be installed without a newer bootloader).
      The NSA320 should work already, being older and all.

      Will now say what it is supposed to do. (anyone tech-savyy enough can go and open up the usb_key_func files with a text editor to see for himself)

      It is now set to multiboot, if it does not find Debian in the Sata disk in left slot it will boot its own firmware again.
      It also checks that partitioning went well and that the extraction went well, before changing the bootloader.
      If the checks detect issues the script aborts and bootloader is not modified, and writes down the error in a log file in the USB drive.

      The checks are also necessary because the bootloader of this device cannot boot from disks bigger than 2TB or so (it can boot only from disks with MBR partition table, MBR partition table has a max size of 2TB for drive capacity, so all disks with more than 2TB capacity have GPT partition table that is newer and does not have this limitation)
      Newer bootloaders for this device can boot from anything, usb, large drives, even from network.

      Bootloader update procedure is much easier if done from inside the Debian ARM system, so getting it to boot Debian this way is the first step anyway.

      The post was edited 2 times, last by bobafetthotmail ().