Virtualbox on OMV Kralizey

    • Virtualbox on OMV Kralizey

      Hi to all,

      i am new and have a few questions. Since 2 Weeks i had OMV 0.5 with VBox running. Now i made a new installation (netinstall debian wheezy) and on Top Kralizec 1.x with addons. But I cant install virtualbox any more. Does anybody know what i am doing wrong? Thanks for help (must get my VDR Working cause tha Family cant´t TV :oops: ).

      Source Code

      1. Die folgenden Pakete haben unerfüllte Abhängigkeiten:
      2. openmediavault-virtualbox : Hängt ab von: openmediavault (>= 1.0.7) aber 1.0.6 soll installiert werden
      3. E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
      omv 1.14 kralizec | 64 bit | 3.16 backport kernel | omvextrasorg 1.13
      Plugins: Virtualbox, VDR (e-toby 2.2, jessie, manual), OwnCloud, Backup, MiniDLNA, Openvpnas, MySQL, USB Datasave, USV
      HW:Asrock q1900-ITX / 8GB RAM / 60 GB SSD / 2 TB Seagate Green + 2 TB WD Red = RAID 1 / APC Back-UPS CS 350 / Digibit R1 SAT>IP
    • Re: Virtualbox on OMV Kralizey

      ohoh... there are more errors:

      Source Code

      1. {"response":null,"error":{"code":4000,"message":"Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-anacron 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed\nE: Unable to correct problems, you have held broken packages.","trace":"exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get --simulate --reinstall install openmediavault-anacron 2>&1': Reading package lists...\n\nBuilding dependency tree...\n\nReading state information...\n\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed\nE: Unable to correct problems, you have held broken packages.' in \/usr\/share\/openmediavault\/engined\/rpc\/pluginmgmt.inc:382\nStack trace:\n#0 [internal function]: OMVRpcServicePluginMgmt->createIndex(Array, Array)\n#1 \/usr\/share\/php\/openmediavault\/rpcservice.inc(125): call_user_func_array(Array, Array)\n#2 \/usr\/share\/php\/openmediavault\/rpc.inc(79): OMVRpcServiceAbstract->callMethod('createIndex', Array, Array)\n#3 \/usr\/sbin\/omv-engined(495): OMVRpc::exec('Plugin', 'createIndex', Array, Array, 1)\n#4 {main}"}}


      Source Code

      1. openmediavault-anacron : Depends: openmediavault (>= 1.0.7) but 1.0.6 is to be installed


      Can anybody tell me what i do wrong?
      Is it possible to downgrade to omv 1.0.6?

      Many thanks, Jochen
      omv 1.14 kralizec | 64 bit | 3.16 backport kernel | omvextrasorg 1.13
      Plugins: Virtualbox, VDR (e-toby 2.2, jessie, manual), OwnCloud, Backup, MiniDLNA, Openvpnas, MySQL, USB Datasave, USV
      HW:Asrock q1900-ITX / 8GB RAM / 60 GB SSD / 2 TB Seagate Green + 2 TB WD Red = RAID 1 / APC Back-UPS CS 350 / Digibit R1 SAT>IP
    • Re: Virtualbox on OMV Kralizey

      Ignore the error. It's just a temporay bug. If you want to get rid of it, enable OpenMediaVaults pre-release upgrades once, update to 1.0.7 and deactivate the pre-release upgrades again. This will resolve the error.

      If you just want to install virtualbox, do it via cli.

      Source Code

      1. apt-get install openmediavault-virtualbox


      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Re: Virtualbox on OMV Kralizey

      Hi David,

      many thanks for the fast answer.
      That was exactly what i did. On the CLI i have the descibed errors.

      Jochen
      omv 1.14 kralizec | 64 bit | 3.16 backport kernel | omvextrasorg 1.13
      Plugins: Virtualbox, VDR (e-toby 2.2, jessie, manual), OwnCloud, Backup, MiniDLNA, Openvpnas, MySQL, USB Datasave, USV
      HW:Asrock q1900-ITX / 8GB RAM / 60 GB SSD / 2 TB Seagate Green + 2 TB WD Red = RAID 1 / APC Back-UPS CS 350 / Digibit R1 SAT>IP
    • Re: Virtualbox on OMV Kralizey

      This is only needed once! Don't use the pre-release repos after 1.0.7 UNLESS its a testing system!!!!


      In update manager enable the pre-released repo. Then:

      apt-get update
      apt-get upgrade

      You need to get openmediavault version 1.0.7 installed and then openmediavault-virtualbox should install.
    • Re: Virtualbox on OMV Kralizey

      Hi,

      thanks. My fault: Must unsinstall omv-extras. Then the hints from David an you. Then again install omv-extras.
      Looks good now.

      Jochen
      omv 1.14 kralizec | 64 bit | 3.16 backport kernel | omvextrasorg 1.13
      Plugins: Virtualbox, VDR (e-toby 2.2, jessie, manual), OwnCloud, Backup, MiniDLNA, Openvpnas, MySQL, USB Datasave, USV
      HW:Asrock q1900-ITX / 8GB RAM / 60 GB SSD / 2 TB Seagate Green + 2 TB WD Red = RAID 1 / APC Back-UPS CS 350 / Digibit R1 SAT>IP
    • Re: Virtualbox on OMV Kralizey

      sorry again. Machines are running and they are can started and stoped in OMV.
      But phpVirtualbox doesent loads.
      I found the installation in /usr/share/phpvirtualbox. But there are no Logs?
      Can you help again? sorry!

      Jochen
      omv 1.14 kralizec | 64 bit | 3.16 backport kernel | omvextrasorg 1.13
      Plugins: Virtualbox, VDR (e-toby 2.2, jessie, manual), OwnCloud, Backup, MiniDLNA, Openvpnas, MySQL, USB Datasave, USV
      HW:Asrock q1900-ITX / 8GB RAM / 60 GB SSD / 2 TB Seagate Green + 2 TB WD Red = RAID 1 / APC Back-UPS CS 350 / Digibit R1 SAT>IP
    • Re: Virtualbox on OMV Kralizey

      Hi,

      sadly this does not help. Also a reboot. Any hint?

      Jochen
      omv 1.14 kralizec | 64 bit | 3.16 backport kernel | omvextrasorg 1.13
      Plugins: Virtualbox, VDR (e-toby 2.2, jessie, manual), OwnCloud, Backup, MiniDLNA, Openvpnas, MySQL, USB Datasave, USV
      HW:Asrock q1900-ITX / 8GB RAM / 60 GB SSD / 2 TB Seagate Green + 2 TB WD Red = RAID 1 / APC Back-UPS CS 350 / Digibit R1 SAT>IP
    • Re: Virtualbox on OMV Kralizey

      o.k. Must do this tomorrow. But then my running machines will be killed?
      Tanks for the help!

      Jochen
      omv 1.14 kralizec | 64 bit | 3.16 backport kernel | omvextrasorg 1.13
      Plugins: Virtualbox, VDR (e-toby 2.2, jessie, manual), OwnCloud, Backup, MiniDLNA, Openvpnas, MySQL, USB Datasave, USV
      HW:Asrock q1900-ITX / 8GB RAM / 60 GB SSD / 2 TB Seagate Green + 2 TB WD Red = RAID 1 / APC Back-UPS CS 350 / Digibit R1 SAT>IP
    • Re: Virtualbox on OMV Kralizey

      What kind of error?

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • Re: Virtualbox on OMV Kralizey

      Hi,

      same here like alexion´s screenshot. With Firefox and Chrome.

      Greetings, Jochen
      omv 1.14 kralizec | 64 bit | 3.16 backport kernel | omvextrasorg 1.13
      Plugins: Virtualbox, VDR (e-toby 2.2, jessie, manual), OwnCloud, Backup, MiniDLNA, Openvpnas, MySQL, USB Datasave, USV
      HW:Asrock q1900-ITX / 8GB RAM / 60 GB SSD / 2 TB Seagate Green + 2 TB WD Red = RAID 1 / APC Back-UPS CS 350 / Digibit R1 SAT>IP
    • Re: Virtualbox on OMV Kralizey

      That's correct. Let's see if there's something to be found in the logs..

      Source Code

      1. cat /home/vbox/.config/VirtualBox/VBoxSVC.log
      2. cat /home/vbox/.config/VirtualBox/vboxwebsrv.log
      3. cat /var/log/nginx/openmediavault-webgui_access.log
      4. cat /var/log/nginx/openmediavault-webgui_error.log

      Also, since the vbox user password is stored in the file you checked before, try and see if you find out if it's the correct password. The user is vbox.
    • Re: Virtualbox on OMV Kralizey

      Source Code

      1. root@hypervnas:~# cat /home/vbox/.config/VirtualBox/VBoxSVC.log
      2. VirtualBox XPCOM Server 4.3.14 r95030 linux.amd64 (Jul 15 2014 18:51:39) release log
      3. 00:00:00.000206 main Log opened 2014-07-29T09:37:39.729586000Z
      4. 00:00:00.000208 main Build Type: release
      5. 00:00:00.000211 main OS Product: Linux
      6. 00:00:00.000212 main OS Release: 3.14-0.bpo.1-amd64
      7. 00:00:00.000213 main OS Version: #1 SMP Debian 3.14.12-1~bpo70+1 (2014-07-13)
      8. 00:00:00.000234 main DMI Product Name: Virtual Machine
      9. 00:00:00.000241 main DMI Product Version: 7.0
      10. 00:00:00.000318 main Host RAM: 994MB total, 915MB available
      11. 00:00:00.000324 main Executable: /usr/lib/virtualbox/VBoxSVC
      12. 00:00:00.000325 main Process ID: 3032
      13. 00:00:00.000326 main Package type: LINUX_64BITS_DEBIAN_7_0
      14. 00:00:00.106782 nspr-2 Loading settings file "/home/vbox/.config/VirtualBox/VirtualBox.xml" with version "1.12-linux"
      15. 00:00:00.109233 nspr-2 NetIfAdpCtlOut: VBoxNetAdpCtl: Error while retrieving link status for eth0: VBoxNetAdpCtl: ioctl failed: Operation not supported
      16. 00:00:00.109727 nspr-2 HostDnsMonitorProxy: Host's DNS information updated:
      17. 00:00:00.109755 nspr-2 DNS server 1: 8.8.8.8
      18. 00:00:00.109760 nspr-2 DNS server 2: 8.8.4.4
      19. 00:00:00.109990 nspr-2 VDInit finished
      Display All

      Source Code

      1. root@hypervnas:~# cat /home/vbox/.config/VirtualBox/vboxwebsrv.log
      2. VirtualBox web service 4.3.14 r95030 linux.amd64 (Jul 15 2014 18:51:39) release log
      3. 00:00:00.000959 main Log opened 2014-07-29T09:37:40.991716000Z
      4. 00:00:00.000962 main Build Type: release
      5. 00:00:00.000963 main OS Product: Linux
      6. 00:00:00.000964 main OS Release: 3.14-0.bpo.1-amd64
      7. 00:00:00.000965 main OS Version: #1 SMP Debian 3.14.12-1~bpo70+1 (2014-07-13)
      8. 00:00:00.000979 main DMI Product Name: Virtual Machine
      9. 00:00:00.000985 main DMI Product Version: 7.0
      10. 00:00:00.001028 main Host RAM: 994MB total, 915MB available
      11. 00:00:00.001031 main Executable: /usr/lib/virtualbox/vboxwebsrv
      12. 00:00:00.001032 main Process ID: 3142
      13. 00:00:00.001033 main Package type: LINUX_64BITS_DEBIAN_7_0
      14. 00:00:00.005808 SQPmp Socket connection successful: host = 127.0.0.1, port = 18083, master socket = 9
      15. 00:00:05.895126 SQPmp Request 1 on socket 10 queued for processing (1 items on Q)
      16. 00:00:05.895163 SQW01 New SOAP thread started
      17. 00:00:05.895195 SQW01 Processing connection from IP=127.0.0.1 socket=10 (0 out of 1 threads idle)
      18. 00:00:15.784720 SQPmp Request 2 on socket 11 queued for processing (1 items on Q)
      19. 00:00:15.784777 SQW01 Processing connection from IP=127.0.0.1 socket=11 (0 out of 1 threads idle)
      20. 00:00:26.635239 SQPmp Request 3 on socket 10 queued for processing (1 items on Q)
      21. 00:00:26.635277 SQW01 Processing connection from IP=127.0.0.1 socket=10 (0 out of 1 threads idle)
      22. 00:00:36.628127 SQPmp Request 4 on socket 11 queued for processing (1 items on Q)
      23. 00:00:36.628166 SQW01 Processing connection from IP=127.0.0.1 socket=11 (0 out of 1 threads idle)
      24. 00:00:46.635360 SQPmp Request 5 on socket 10 queued for processing (1 items on Q)
      Display All

      and repeated many times to

      Source Code

      1. 00:25:49.338053 SQPmp Request 153 on socket 10 queued for processing (1 items on Q)
      2. 00:25:49.338089 SQW01 Processing connection from IP=127.0.0.1 socket=10 (0 out of 1 threads idle)


      only the last activity

      Source Code

      1. root@hypervnas:~# cat /var/log/nginx/openmediavault-webgui_access.log
      2. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:02 +0400] "POST /rpc.php HTTP/1.1" 200 42 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      3. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:05 +0400] "POST /rpc.php HTTP/1.1" 200 58 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      4. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:08 +0400] "POST /rpc.php HTTP/1.1" 200 42 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      5. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:13 +0400] "POST /rpc.php HTTP/1.1" 200 42 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      6. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:15 +0400] "POST /rpc.php HTTP/1.1" 200 58 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      7. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:18 +0400] "POST /rpc.php HTTP/1.1" 200 42 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      8. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:23 +0400] "POST /rpc.php HTTP/1.1" 200 42 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      9. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:25 +0400] "POST /rpc.php HTTP/1.1" 200 58 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      10. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:26 +0400] "GET /virtualbox/js/language.php HTTP/1.1" 502 166 "http://10.0.0.9/virtualbox/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      11. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:26 +0400] "GET /virtualbox/js/phptest.php HTTP/1.1" 502 166 "http://10.0.0.9/virtualbox/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      12. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:26 +0400] "GET /virtualbox/js/phptest.php HTTP/1.1" 502 166 "http://10.0.0.9/virtualbox/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      13. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:28 +0400] "POST /rpc.php HTTP/1.1" 200 42 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      14. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:33 +0400] "POST /rpc.php HTTP/1.1" 200 42 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      15. ::ffff:10.0.0.4 - - [29/Jul/2014:14:10:35 +0400] "POST /rpc.php HTTP/1.1" 200 58 "http://10.0.0.9/" "Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0"
      Display All


      only the last activity

      Source Code

      1. root@hypervnas:~# cat /var/log/nginx/openmediavault-webgui_error.log
      2. 2014/07/29 14:10:26 [crit] 3263#0: *517 connect() to unix:/var/run/php5-fpm-openmediavault-virtualbox.sock failed (2: No such file or directory) while connecting to upstream, client: ::ffff:10.0.0.4, server: openmediavault-webgui, request: "GET /virtualbox/js/language.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-virtualbox.sock:", host: "10.0.0.9", referrer: "http://10.0.0.9/virtualbox/"
      3. 2014/07/29 14:10:26 [crit] 3263#0: *552 connect() to unix:/var/run/php5-fpm-openmediavault-virtualbox.sock failed (2: No such file or directory) while connecting to upstream, client: ::ffff:10.0.0.4, server: openmediavault-webgui, request: "GET /virtualbox/js/phptest.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-virtualbox.sock:", host: "10.0.0.9", referrer: "http://10.0.0.9/virtualbox/"
      4. 2014/07/29 14:10:26 [crit] 3263#0: *517 connect() to unix:/var/run/php5-fpm-openmediavault-virtualbox.sock failed (2: No such file or directory) while connecting to upstream, client: ::ffff:10.0.0.4, server: openmediavault-webgui, request: "GET /virtualbox/js/phptest.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-virtualbox.sock:", host: "10.0.0.9", referrer: "http://10.0.0.9/virtualbox/"


      What is the password must be correct? VBox user is automatically created when you install the plug-in. VBox password stored in /etc/default/openmediavault-virtualbox?