New OpenMediaVault 1.0.21

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • New OpenMediaVault 1.0.21

      I make a clean installation of the new OMV, and I have big problems with comunication with DDNS
      1 - FTP not work
      2 - owncloud is required a certificate which will conflict with a DDNS server (No-IP in this case).
      3 - Does my problem is between the "keyboard and the chair" (eheheh)?
      The settings I made are the same as i was doing in the tutorial which recently put on the forum.
      Best Regards
      José Crispim
      The problem in today's world is that the intelligent are full of doubt and some idiots are full of certainties. The intelligent are called undecided the idiots are called experts
    • jjrcrispim wrote:

      I make a clean installation of the new OMV, and I have big problems with comunication with DDNS
      1 - FTP not work
      2 - owncloud is required a certificate which will conflict with a DDNS server (No-IP in this case).
      3 - Does my problem is between the "keyboard and the chair" (eheheh)?
      The settings I made are the same as i was doing in the tutorial which recently put on the forum.
      Best Regards
      José Crispim


      Sorry, I thought I replied earlier.. guess I didn't.
      I don't use owncloud.. but can you be more specific as to what problem you're having with FTP? I just checked, and it's working fine for me.
      Air Conditioners are a lot like PC's... They work great until you open Windows.

    • Thanks for your response.
      1 - Regarding the FTP, the problem was among the "keyboard and the chair." My firewall blocked the FTP (FileZilla) client. Here is resolved and absolutely functional. Access by "normal" FTP or over explicit SSL works fine. Sorry for my lapse .

      2 - Regarding OwnCloud, I see that now appears a required field to put the SSL certificate, which did not happen before. And this field is required if not do not let the save
      3 - When I open OwnCloud the following message appears:
      ""You are accessing the server from an untrusted domain. Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domain" setting in config/config.php. An example configuration is provided in config/config.sample.php."
      4 - The Access to the server is done by a NO-IP address, because the ip of my internet is dynamic. I do not understand why the message says that the domain is not reliable.
      5 - Note that the settings I use now are exactly those used in the previous version of OMV (with the exception of the field that I mentioned and that the previous version did not exist.)

      Best Regards
      José Crispim
      The problem in today's world is that the intelligent are full of doubt and some idiots are full of certainties. The intelligent are called undecided the idiots are called experts
    • 2 & 3) why is their conflict with the Certs??? You can use many certs on one machine. For the owncloud certificate you create in OMV for ownCloud make sure you use the ip of your omv for the Common Name. When you enable owncloud in OMV 1 volker has used ip of you omv for the config.php file and this needs to match Common Name in your certificate. You can add domains to the config.php file. If you are using a dynamic dns service you need to add that domain to your config.php for remote access.

      1) There were some issues with FTP but they are corrected. Your problem was not one of the issues.

      4) It is because your certificate cannot be verified by a certificate authority. This is common thing with self signed certs. It is nothing to worry about if you trust the server you are connecting to, which you should because it is yours. You can read more here:
      digicert.com/


      PS- All the supermods accounts got deleted. So we had to recreate today.

      The post was edited 4 times, last by tekkb ().

    • Thanks for your response
      I created the certifed as you said, and gave him the IP OwnCloud. Error (internal access):
      "Your web server is not yet setup to allow enquiry.c files synchronization because the WebDAV interface seems to be broken. Please double check the installation guides."
      Note that I performed a clean installation again.
      If this worked well with the previous version of OMV, why not work now?
      OK, And if I Access from Internet with NO-IP? The IP is different and...
      The problem in today's world is that the intelligent are full of doubt and some idiots are full of certainties. The intelligent are called undecided the idiots are called experts
    • How are you connecting to your OMV on your LAN??? You need to do:

      Source Code

      1. https://ipofyouromv:8443


      if you use hostname to connect you need to add that domain to the config.php file. Wait and I give you an example file.

      /var/www/owncloud/config/config.php

      Source Code

      1. 'trusted_domains' =>
      2. array (
      3. 0 => '192.168.1.54:8443',
      4. 1=> 'myomv:8443',
      5. 2=> 'myhomeomv.dynddns.org:8443',
      6. ),


      myomv = whatever hostname you use
      myhomeomv.dyndns.org = whatever address you are using for your dns service

      The post was edited 8 times, last by tekkb ().

    • Excuse the statement, but because it is necessary to be now putting code when the previous version was not necessary?
      When I gain access to the internal IP gives the error I mentioned you!
      If I try to access externally, does not exist.
      What is the reason that you have added a port (8443) and a Certificate in the new setup of OwnCloud?
      In the previous version access was safe and worked well!
      By the way, does not seem quite right the user has to be insert code to address a situation that, for me, was poorly made (no offense to your work which is fantastic).
      The problem in today's world is that the intelligent are full of doubt and some idiots are full of certainties. The intelligent are called undecided the idiots are called experts
    • You are using SSL now. You need to add domains that you want to connect with or owncloud will give you error message at sign in screen. This may not seem simple but you are way more secure using owncloud with the new setup. Also, we cannot put this information in the plugin as we do not know what you are using as hostname or address you use with your dns service.
    • okay
      First things first.
      1 - I had version 0.5.59 installed;
      2 - Everything functioned properly, FTP, OwnCloud, sharing in LAN, etc.
      3 - I installed the new version of OMV;
      4 - Of course all settings in which made in the Router (assigning fixed IP to the NAS, opening doors, DDNS - No-IP) were maintained;
      5 - And of course that would be valid for the new facility;
      6 - I configured a new version exactly the same as the previous;
      Thanks for your patience, but I give up!
      I will revert to the previous version of OMV, in which everything was fully functional.
      The problem in today's world is that the intelligent are full of doubt and some idiots are full of certainties. The intelligent are called undecided the idiots are called experts
    • my friend
      I understood perfectly. And I've done what you said and gave the message I said. I created the certificate, put the ip I gave to the (192.168.157.9) and i decided to 192.168.157.9:8443
      If I access from the outside ( xyz.noip.me/owncloud or xyz-nas.noip.me:8443) does not access, gives error "server not found"
      There is a clear conflict between doors and certificates.
      I say again: if the previous version worked, why not work now?.
      I remenber you en.jose-crispim.pt/artigos/arm…rt/06_openmediavault.html see in Cloud Server Index
      The problem in today's world is that the intelligent are full of doubt and some idiots are full of certainties. The intelligent are called undecided the idiots are called experts
    • I can not access it because:
      1 - I do not have monitor and keyboard connected to the NAS;
      2 - I know nothing of the command line;
      Thanks for your patience. You are spectacular!
      The time now is 11:56 pm in Portugal and I'm going to sleep.
      Anyway I'll give this version of OMV and will revert to the previous.
      I could make a document with all the prints of the settings I have (and had) and send you but I do not know how I can send you a pdf privately.
      It is unusual, but I give up. I was disappointed with the new version of OMV.
      Thank you for your attention
      greetings
      The problem in today's world is that the intelligent are full of doubt and some idiots are full of certainties. The intelligent are called undecided the idiots are called experts