smartctl/hdparm & Samsung F4 EcoGreen = data loss?

    • OMV 1.0
    • smartctl/hdparm & Samsung F4 EcoGreen = data loss?

      Hi there!
      I've been a -fairly- long time user of OMV (since 0.4 I think), but this is my very first post on a forum I otherwise tend to read a lot. So first things first: thanks a lot to the whole community around OMV, and major thanks to the ones actually behind OMV. I just love it.

      That being said, I've seen the amount of errors on one of my Samsung F4 EcoGreen drives increase lately. Not much: from 0 to 1 and now 2 pending sectors. No big deal you would say. But while digging around this issue, I ended up running smartctl on the said drive, which spits me the following message:

      ==> WARNING: Using smartmontools or hdparm with this
      drive may result in data loss due to a firmware bug.
      ****** THIS DRIVE MAY OR MAY NOT BE AFFECTED! ******
      Buggy and fixed firmware report same version number!
      See the following web pages for details:
      samsung.com/global/business/hd…iew.do?b2b_bbs_msg_id=386
      sourceforge.net/apps/trac/smar…wiki/SamsungF4EGBadBlocks


      Smartmontools website goes a step further:
      WARNING: Do not use smartmontools with Samsung HD155UI and HD204UI drives unless the firmware patch is already installed.
      This warning also applies to other tools which use IDENTIFY DEVICE to obtain drive information. The problem is not SMART related.
      The problem could (at least) also be reproduced with hdparm (on Linux and Windows) and with SeaTools for Windows.
      Update: According to Samsung Support, HD204UI drives manufactured December 2010 or later include the firmware patch.


      Problem: If the system writes to this disk and smartctl -a is used at the same time, write errors are reported and bad blocks appear on the disk.

      I personnally don't have bad blocks, so I'm not sure to be really affected by this, despite owning the targeted drives. I will apply the firmware update anyhow.

      I've seen on another thread that ryecoaaron has a lot of Samsung F4 2TB drives (don't know if those are EcoGreen or not), so I felt like relaying this rather old information. This may be of interest to someone around here (couldn't find any mention of this issue on the forum).

      Best regards,
      calemarie

      PS: Am I plain stupid, or is there no way to post a thread without the "resolved" tag?
      Note that part of this question is rhetorical: please be kind in your replies :rolleyes:
    • OK, the answer to my question is now officially a big fat yes...

      I had an error saying "invalid label" in preview mode, and thought this would hold my post submission. I tried anyway and it worked perfectly. So I end up with a post with no "resolved" label, and a silly question.

      What a great entrance... Sorry about that.

      BR
      calemarie
    • I do have a lot of these drives (8 in my home server) :) On the two drives that had the firmware bug, I patched the firmware. So, no issues here.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!