Internet connection dies when OMV box is attached

    • OMV 1.0
    • Resolved
    • Internet connection dies when OMV box is attached

      I've been struggling with my Internet connection for the past month. It is very unstable at the moment -- I will receive, on average, less than 40% of the packets sent to me. I've had my ISP's network technicians out here and we have checked the lines, the hardware, software, etc. We've replaced my cable modem, my router (three times), and even my gigabit switch.

      The current setup is:

      1. My home PC
      2. My wife's home PC
      3. Our living room PC

      All wired into a gigabit switch (made by Netgear). The switch then feeds cables through the walls to the room containing our cable modem and router. The modem (Motorola SB4161) is plugged directly into the router (Netgear R7000). The router is plugged into the switch and an additional PC. It serves, on the 2.4 ghz band, our Roku in the bedroom and whatever miscellaneous b/g/n devices we have. Our 5 Ghz band serves my wife's laptop, our iphones, our ipads, and my nVidia Shield.

      As long as our NAS (homebuilt, running OMV 1.1) is unplugged, the system works flawlessly. We get full speed, no dropped connections, no DNS resolving errors, etc.

      As soon as the NAS is plugged in, however, it all goes to scheisse. I don't think I ever set up a static IP address in Linux, but I did have an IP address reserved via MAC address on my router. I have cleared that, rebooted the router, etc., but somehow, the NAS still picks up the old IP address ( What setting did I mistakenly bork in OMV that is causing all of these issues?

      Or is it something more nefarious, like my ISP can see the fact that I stream what I assume is quite a bit of media from my NAS to my various devices, including iPhones/iPads when we're out and about but still want to have access to our movie/TV collection, and they're getting upset about the bandwidth usage?
    • If your modem is in bridge mode, which is the most common, I doubt that your Isp can "see" you lan to lan streaming.

      I would try another router (if the router was mine I would already flash it with tomato, the r7000 is supported).

      Other thing to try is change the nic server card.

      If the server is idle does the lan hangs also or is just when you initiate the streaming?
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • I've tried three different routers (Linksys WRT1900AC, Asus RT-AC68U, and now on a Netgear R7000). It's in bridge mode, but I wasn't talking lan-to-lan, but rather remote streaming via Plex Connect (for example, my wife and I were just on a road trip this weekend and she likes to stream to her iPad in the hotel room/car/plane/etc.).

      My R7000 is running DD-WRT (my preferred custom firmware).

      I'll have to see about getting a NIC. No real place to buy them locally but luckily Prime will have it here by Wednesday.

      The lan and wan hang IMMEDIATELY upon plugging the NAS into the router. As in, if you are currently loading a page and you plug in the NAS, the remainder of the data for the page will time out. Nothing, not even the NAS, can connect to anything remote.

      At this point, I'm of half a mind to just start with a fresh OMV install. That won't be a nightmare to recreate everything. :/
    • Maybe it has malware, even it is Linux, is still possible. We've seen that in exposed WAN plex servers. Don't flush yet the server. Keep it offline and create a clean virtual machine bridged to the network see how it behaves with plex server. Don't expose it directly to WAN either use openvpn or a ssh Web socks proxy to stream.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • I've seen bad network adapters cause a lot of problems for switches. Are all of the lights on the switch blinking at the same time when the NAS is plugged in?
      omv 5.3.2 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.2.4 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I seem to remember weird issue like this. I think it had something to do with ipv4 and ipv6. Like ipv6 maybe having to be disabled on omv.

      Things to check:
      bad cable (make sure cable from omv to switch is a cat6, or cat5e, and test with different one in case cable is bad)
      ipv4 ipv6 issue
      firmware on nic not communnicating correctly with switch (firmware issue, bad driver or bad nic)
      firmware on nic not communicating correctly with switch in router (firmware issue, bad driver or bad nic)

      The post was edited 1 time, last by tekkb ().

    • subzero79 wrote:

      Is hard to debug and narrow this problem. This is very unusual.

      Does the stock firmware in R7000 had the same behaviour?

      Also you mentioned a second switch, do you plug OMV directly there or to the rear of R7000?

      I know! I've tried looking at the logs on both the router and OMV, and nothing. The stock firmware did have the same problem, as did stock firmware and DD-WRT on the Asus and stock firmware on the Linksys. It is apparently hardware/platform transparent. The internet connection simply starts timing out as soon as the NAS is plugged in.

      I plug the OMV machine (thevault) directly into the router. The switch is only there to serve three hard-wired PCs in other rooms. Basically, cable goes through my walls to the switch, which then feeds into the router.

      tekkb wrote:

      Things to check:bad cable (make sure cable from omv to switch is a cat6, or cat5e, and test with different one in case cable is bad)
      ipv4 ipv6 issuefirmware on nic not communnicating correctly with switch (firmware issue, bad driver or bad nic)
      firmware on nic not communicating correctly with switch in router (firmware issue, bad driver or bad nic)

      Cable has been checked and is known working.

      Have there been any changes in the ipv4/v6 in OMV? This was working until just a few weeks ago, quite flawlessly, I might add. Not that it's related, but also my Sonarr installation has become super buggy and the app crashes constantly. Something to do with database corruption. I'm currently trying to run down that issue on their forums.

      A bad NIC/firmware on the NIC seems to be the more likely candidate at this juncture. I'm using the onboard NIC for my motherboard, so it could simply be malfunctioning and clogging my router with junk packets. I'll have to order a new NIC from Amazon. Does anyone have any recommendations as to good, compatible PCIE NIC cards?
    • Using DD-WRT your router should most likely say Autmatic Configuration - DHCP at the Setup/Basic Setup in the WAN connection type.

      I have found that some NICs, like Realtek, will not work in the ports on the Router but will work in a decent switch. If you have anything ever that does not work correctly in the router's built in switch try plugging it in a good switch instead of in the router's switch. The Realtek NICs I have had problems with worked when I put them in a good HP swtich.

      Intel is the best in my experience for a NIC.
    • Tried it through a netgear gigabit switch. Same problem.

      Intel NIC is on the way. In the meantime I may try a fresh install tomorrow, but last time I had such a terrible time because the NIC driver I need is only in the backports kernel. I had to put the SSD I use for my OMV system into an enclosure and install from my PC, but that was before I upgraded my motherboard to an X99, so who knows if that will even work?

      I may try just to do a plain Debian install and then install OMV on top of Debian. Or just wait for the Intel NIC. Who knows? I just can't imagine what would cause this so suddenly. But it's like night and day. Plug in the NAS, no internet. Unplug it, all of a sudden -- Internet. I would think my ISP was throttling but there's no way they can react that fast... can they?
    • OK, here's how I fixed it:

      1. Got an Intel Gigabit NIC, installed. OMV not recognizing the new NIC. Can't get online with the box to try to run an update. Figure I should just update the whole thing.

      2. Fresh install of Debian 7.x (whatever the latest version is). New NIC recognized immediately. Installed OMV on top, set up all my programs again. Works great so far. Even my issue with sonarr dying randomly seems to have fixed itself.
    • This beast has once again reared its ugly head. Went through my same troubleshooting steps as last time (fresh NIC installed, no dice).

      As soon as the NAS is on the network, DNS totally drops out. Connections time out, names do not get resolved, etc.

      Simply unplug the NAS from the network and BAM! Back online in an instant.

      I've tried moving my NAS to different rooms, on different circuits in the house, with different ethernet cables and ports... it just does not want to work.

      But here's the dumb thing -- it is the only thing that works if you hook it up (except of course it can't connect to the Internet). But functions very well as a LAN-only media server in the meantime.

      I am at my wits end here.
    • 1. I shouldn't, but maybe I do.

      2. Fairly strong, I think. Probably unguessable, but not strong enough to survive brute force. Time to change that.

      Edited: no, 22 wasn't open on the WAN, although SSH login was turned on. I'm not discounting the ability to get around that, because UPNP was on. I updated my root password to be stronger.