Update to 1.19

    • OMV 1.0
    • Resolved
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Update to 1.19

      ================ Error =================
      Failed to execute command 'export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install openmediavault 2>&1': Reading package lists...

      Building dependency tree...

      Reading state information...

      openmediavault is already the newest version.
      You might want to run 'apt-get -f install' to correct these:
      The following packages have unmet dependencies:
      libc-dev-bin : Depends: libc6 (< 2.14) but 2.19-18 is to be installed
      libc6 : Breaks: libtirpc1 (< 0.2.3) but 0.2.2-5 is to be installed
      Breaks: locales (< 2.19)
      Breaks: libc6:i386 (!= 2.19-18) but 2.13-38+deb7u8 is to be installed
      libc6:i386 : Breaks: libc6 (!= 2.13-38+deb7u8) but 2.19-18 is to be installed
      libc6-dev : Depends: libc6 (= 2.13-38+deb7u8) but 2.19-18 is to be installed
      libc6-i386 : Depends: libc6 (= 2.13-38+deb7u8) but 2.19-18 is to be installed
      locales : Depends: glibc-2.13-1
      E
      :
      Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
      =========================================



      Trying to do the updates in updatemanager..

      -f install gives:

      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Correcting dependencies... Done
      The following packages were automatically installed and are no longer required:
      apache2 apache2-mpm-worker apache2-suexec apache2-utils apache2.2-bin apache2.2-common avahi-daemon beep bind9-host
      collectd collectd-core cpufrequtils cron-apt dbconfig-common gdisk groff-base hdparm ifenslave-2.6 iptables libaio1
      libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libavahi-core7 libbind9-80 libcap-ng0 libcpufreq0
      libdaemon0 libdbd-mysql-perl libdbi-perl libdbi1 libdevmapper-event1.02.1 libdns88 libgd2-noxpm libgeoip1 libisc84
      libisccc80 libisccfg82 libjavascript-minifier-xs-perl libjs-extjs4 libjson-perl liblocale-po-perl libltdl7 liblwres80
      libmysqlclient18 libnfnetlink0 libnss-mdns libossp-uuid16 librrd4 libsensors4 libsnmp-base libsnmp15
      linux-libc-dev:i386 lsb-release lvm2 monit mysql-client-5.5 mysql-common mysql-server mysql-server-5.5
      mysql-server-core-5.5 nginx nginx-common nginx-full ntfs-3g php-json-schema php5-pam php5-proctitle pm-utils
      proftpd-basic proftpd-mod-vroot python-apt-common python3 python3-apt python3-minimal python3.2 python3.2-minimal
      quotatool rrdcached rrdtool sdparm smartmontools snmpd socat tftpd-hpa uuid
      Use 'apt-get autoremove' to remove them.
      The following packages will be REMOVED:
      lib32gcc1 libc-dev-bin libc6:i386 libc6-amd64:i386 libc6-dev libc6-dev:i386 libc6-i386 libgcc1:i386 libtirpc1 locales
      nfs-common nfs-kernel-server openmediavault openmediavault-extplorer openmediavault-mysql openmediavault-omvextrasorg
      rpcbind
      0 upgraded, 0 newly installed, 17 to remove and 2 not upgraded.
      4 not fully installed or removed.
      After this operation, 81.3 MB disk space will be freed.



      Now what? :/ Cause i dont wanna remove OMW, right...?

      I think the problem came when installing ARK server, and it wanted libc6 installed aswell...

      Installed with
      You need to download libc6_2.19-18_amd64.deb from packages.debian.org/sid/amd64/libc6/download and to install it dpkg -i --auto-deconfigure libc6_2.19-18_amd64.deb

      The post was edited 3 times, last by silvrblue ().

    • Wierd.. Cause i got a error message when starting the ark server:
      Output from server:
      ./ShooterGameServer:
      /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found
      (required by /home/steam/arkd
      edicated/ShooterGame/Binaries/Linux/../../../Engine/Binaries/Linux/libsteam_api.so)
      Sitert tekst


      Then someone told me to
      You need to download libc6_2.19-18_amd64.deb from packages.debian.org/sid/amd64/libc6/download and to install it dpkg -i --auto-deconfigure libc6_2.19-18_amd64.deb



      Am i screwed? Was thinking doing a dpkg -r libc6 .. But if it is a major part of debian, i should not... Maybe?

      Ow, and ARK: Survival Evolved is a survival game. With dinosaurs. And awesome grapics. :)

      And i have no idea what a docker container is... I use google, and read forums...

      The post was edited 1 time, last by silvrblue ().

    • Im reading this as a fail..

      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Selected version '2.13-38+deb7u8' (Debian-Security:7.0/oldstable [amd64]) for 'l ibc6'
      The following packages were automatically installed and are no longer required:
      libc6-amd64:i386 libc6-dev:i386 linux-libc-dev:i386
      Use 'apt-get autoremove' to remove them.
      Suggested packages:
      glibc-doc
      The following packages will be DOWNGRADED:
      libc6
      0 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 2 not upgraded.
      4 not fully installed or removed.
      Need to get 4,335 kB of archives.
      After this operation, 784 kB disk space will be freed.
      Do you want to continue [Y/n]? y
      Get:1 security.debian.org/ wheezy/updates/main libc6 amd64 2.13-38+deb7u8 [4,335 kB]
      Fetched 4,335 kB in 0s (4,711 kB/s)
      Preconfiguring packages ...
      dpkg: warning: downgrading libc6:amd64 from 2.19-18 to 2.13-38+deb7u8
      (Reading database ... 60699 files and directories currently installed.)
      Preparing to replace libc6:amd64 2.19-18 (using .../libc6_2.13-38+deb7u8_amd64.d eb) ...
      Unpacking replacement libc6:amd64 ...
      dpkg: error processing /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb (- -unpack):
      trying to overwrite shared '/usr/share/doc/libc6/NEWS.gz', which is different f rom other instances of package libc6:amd64
      dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
      Errors were encountered while processing:
      /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb
      Creating index of upgradeable packages ...
      Creating index of OpenMediaVault plugins ...
      E: Sub-process /usr/bin/dpkg returned an error code (1)

    • Downgrading libc is always a nightmare... Try:

      rm -f /usr/share/doc/libc6/NEWS.gz
      dpkg -i /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Firstone worked ok. Then..

      ~$ sudo dpkg -i /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb
      dpkg: warning: downgrading libc6:amd64 from 2.19-18 to 2.13-38+deb7u8
      (Reading database ... 60699 files and directories currently installed.)
      Preparing to replace libc6:amd64 2.19-18 (using .../libc6_2.13-38+deb7u8_amd64.deb) ...
      Unpacking replacement libc6:amd64 ...
      dpkg: error processing /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb (--install):
      trying to overwrite shared '/usr/share/doc/libc6/changelog.Debian.gz', which is different from other instances of package libc6:amd64
      dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
      Errors were encountered while processing:
      /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb

    • rm -rfv /usr/share/doc/libc6
      dpkg -i /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • sudo dpkg -i /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb
      dpkg: warning: downgrading libc6:amd64 from 2.19-18 to 2.13-38+deb7u8
      (Reading database ... 60699 files and directories currently installed.)
      Preparing to replace libc6:amd64 2.19-18 (using .../libc6_2.13-38+deb7u8_amd64.deb) ...
      Unpacking replacement libc6:amd64 ...
      dpkg: error processing /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb (--install):
      trying to overwrite shared '/usr/share/lintian/overrides/libc6', which is different from other instances of package libc6:amd64
      dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
      Errors were encountered while processing:
      /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb

    • This might be dangerous but I don't think you have a choice.

      dpkg -i --force-overwrite /var/cache/apt/archives/libc6_2.13-38+deb7u8_amd64.deb
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • dpkg: warning: downgrading libc6:amd64 from 2.19-18 to 2.13-38+deb7u8
      (Reading database ... 60699 files and directories currently installed.)
      Preparing to replace libc6:amd64 2.19-18 (using .../libc6_2.13-38+deb7u8_amd64.d eb) ...
      Unpacking replacement libc6:amd64 ...
      dpkg: warning: overriding problem because --force enabled:
      trying to overwrite shared '/usr/share/lintian/overrides/libc6', which is diffe rent from other instances of package libc6:amd64
      Setting up libc6:amd64 (2.13-38+deb7u8) ...
      USER@SERVER:~$


      This is a good thing, right?

      Edit: Sure was! Thanks alot for help. :)

      Reading package lists...
      Building dependency tree...
      Reading state information...
      Suggested packages:
      linux-doc-3.2 debian-kernel-handbook
      The following packages will be REMOVED:
      libc6-amd64:i386 libc6-dev:i386 linux-libc-dev:i386
      The following packages will be upgraded:
      linux-image-3.2.0-4-amd64
      1 upgraded, 0 newly installed, 3 to remove and 1 not upgraded.
      3 not fully installed or removed.
      Need to get 23.4 MB of archives.
      After this operation, 33.8 MB disk space will be freed.
      WARNING: The following packages cannot be authenticated!
      linux-image-3.2.0-4-amd64
      Authentication warning overridden.
      Get:1 security.debian.org/ wheezy/updates/main linux-image-3.2.0-4-amd64 amd64 3.2.68-1+deb7u2 [23.4 MB]
      Preconfiguring packages ...
      Fetched 23.4 MB in 6s (3471 kB/s)
      (Reading database ... 60694 files and directories currently installed.)
      Removing libc6-amd64 ...
      Removing libc6-dev:i386 ...
      Removing linux-libc-dev:i386 ...
      (Reading database ... 60060 files and directories currently installed.)
      Preparing to replace linux-image-3.2.0-4-amd64 3.2.68-1+deb7u1 (using .../linux-image-3.2.0-4-amd64_3.2.68-1+deb7u2_amd64.deb) ...
      Unpacking replacement linux-image-3.2.0-4-amd64 ...
      Examining /etc/kernel/postrm.d .
      run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
      run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
      Setting up libtirpc1:amd64 (0.2.2-5) ...
      Setting up libc6:i386 (2.13-38+deb7u8) ...
      Setting up locales (2.13-38+deb7u8) ...
      Generating locales (this might take a while)...
      en_GB.UTF-8... done
      Generation complete.
      Setting up linux-image-3.2.0-4-amd64 (3.2.68-1+deb7u2) ...
      Running depmod.
      Examining /etc/kernel/postinst.d.
      run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
      update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
      W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
      W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
      run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
      run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.2.0-4-amd64 /boot/vmlinuz-3.2.0-4-amd64
      Generating grub.cfg ...
      Found linux image: /boot/vmlinuz-3.2.0-4-amd64
      Found initrd image: /boot/initrd.img-3.2.0-4-amd64
      done
      Creating index of upgradeable packages ...
      Creating index of OpenMediaVault plugins ...
      Ferdig ...

      The post was edited 2 times, last by silvrblue ().