Mumble-Server-Plugin -> manually start service after every reboot

  • Hello everyone,

    I've got a problem with the mumble-plugin (v1.02). Every time i start my OMV Server(v1.19) the mumble-service doesn't start correctly. I have to deactivate & reaktivate it using the WebGUI (or stop & start the service via ssh) before I can connect.

    Anything I can do about this?

    With best regards

  • One person had an issue where his nic was not coming up fast enough when it was dhcp. When he switched to static ip it worked. Not the case for you. Did you try to remove the init script and re add it? I assume it is mumble.init

    apt-get -f mumble remove
    apt-get mumble defaults

    Sometimes that works...

  • Just tried to purge remove mumble (including the mumble-server.ini) and reinstall it. But still the same behavior as before. =/

    I guess I'll try to run a cronjob that restarts the mumble-server after every boot.

  • Thank you very much! :)

    I guess you could be right with the timing issue. If i run a cronjob @reboot "/etc/init.d/mumble-server restart" without delay mumble still doesn't work. If I run the job with anacron and 1 minute delay mumble works...But now the mumble-server will also restart at 00:01... (Intel PCI-E NIC)

  • If you manually entered the settings for MySQL in the config file it probably is the issue with the init file.

    Try editing /etc/init.d/mumble-server and changing the two lines that look like:

    # Should-Start: $mysql
    # Should-Stop: $mysql

    and remove the $ sign so that it looks like:

    # Should-Start: mysql
    # Should-Stop: mysql

    If that doesn't help, start looking in the logs (/var/log/mumble-server/mumble-server.log), otherwise we're just guessing.

  • Okay... Here we go. :D

    I don't know/think that I ever entered the settings for MySQL in the config file BUT I removed the $ sign. -> Reboot -> Doesn't change anything.

    This is how it looks now:

    The log file (damn I'm such a noob! last time i "nano-checked" the folder instead of the actually log file =/ ^^) :

    After "service mumble-server restart" (when I am able to connect)

    Don't know why ipv6 is mentioned above... It's deaktivated in the network settings... (Only my Router/gateway is using a hybrid INET connection with IPV4 & IPV6 at the same time)

  • So at least it's not that issue. :) Sadly I can't really see which error is causing the server not to start though. By the way, is it started but not listening or just not started at all?

    I've searched around and found this issue which sounds similar(ish) but is with systemd instead.

    I would try these things to see if anything changes. Start by making it only bind to IPv4. Do that by editing /etc/mumble-server.ini. Find the line that contains #host= and change it to host=

    If that doesn't do anything there seems to be some issue with Dbus. I'm not running Mumble on my OMV server anymore but instead on an Jessie server. On that one the /etc/init.d/mumble-server originally looks like (with the exception that I changed $mysql to mysql):

    You could try edit that file to make it look like that. I don't know if you need to disable and enable the server after that to make the changes work though, so do that to be safe.

    And for the last issue (which I don't think should prevent it from starting) is to install lsb-release (apt-get install lsb-release).

  • Thank you.

    I don't really now... it's sleeping ^^. "service mumble-server start" doesn't work. I need to stop it first or restart it.
    I've got the mumble process with PID 2990 marked as "sleeping". After restarting the mumble-server it changes it's PID & "running" before it sleeps again. (The process is only for the murmur & mumble-server.ini)

    Changing the *.ini file to host =, server ip adress, localhost...... doesn't make a difference. Also a couple of different changes in the init.d/mumble-server file & installing lsb-release had no effect at all.

    I just updatet to OMV 2.1... Now mumble seems to work correctly. :D

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!