Setting up openvpn

  • tks, this helps.. also, the automated install scirpt fails, had to execute /usr/local/openvpn_as/bin/ovpn-init tool
    instead and manually set it up, but stuck at the final step since the user openvpn cant be added


    Initializing OpenVPN...
    Adding new user login...
    useradd -s /sbin/nologin "openvpn"
    Error: Could not add user openvpn


    openvpn# useradd -s /sbin/nologin "openvpn"
    useradd: group openvpn exists - if you want to add this user to that group, use -g.



    EDIT: probably a leftover from teh other install - did a delgroup and created teh user as intended.
    executed the install again, all good, AS installed.

  • I just added a profile to my phone. I had to install the dolphin browser from the Google playstore to download the profile from user site :943. The site is no longer working with Chrome because it no longer supports java. I uninstalled the Dolphin browser after I got my profile.


    @DanielP Glad you got it working !!!

  • Need new AS package in repos for OMV 2.x and OMV 3.x.

    Latest package in repo for 3.x but I'm not updating 2.x repos anymore.

    Can you remind me where the openvpn-as package is in the repos for OMV 3.x???

    It is in the plex repo. Since it isn't open source, I can't put it on bintray.

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • @freeman32 Can you give me a screenshot of your plugin settings? I have the plugin based on the community package on a machine with OMV 2 and it connects no problem using chrome to other devices. I've not tested openmediavault-openvpn on OMV 3.x. Let me see your screenshots first.


    Also, are you using OMV''s firewall at all?


    How many users do you need connected to the VPN? Is there a reason you are not using the OpenVPN AS plugin?

  • @freeman32 Can you give me a screenshot of your plugin settings? I have the plugin based on the community package on a machine with OMV 2 and it connects no problem using chrome to other devices. I've not tested openmediavault-openvpn on OMV 3.x. Let me see your screenshots first.


    Also, are you using OMV''s firewall at all?


    How many users do you need connected to the VPN? Is there a reason you are not using the OpenVPN AS plugin?

    I have to connect only une user, me. I have no reason I just install the first on the list and And I had never seen openvpn-as before

  • I forgot the openvpn-as package was in the plex repo when I made the change to omv-extras to use the official plex repo. Just install it manually for now until I figure out what to do about this.


    wget http://swupdate.openvpn.org/as/openvpn-as-2.1.9-Debian8.amd_64.deb
    dpkg -i openvpn-as-2.1.9-Debian8.amd_64.deb

    omv 5.5.22 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.4
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • hum, i'm very sorry but there is 2 weeks that i'm tryin to see my windows share on smb nut never works.
    I can't understand why is there is not a pre configured sample on the plugins or minimal some example.


    i have a server OMV on local 192.168.0.50 (ip fix) OMV on 80 and 443 port SSL, EMBY ssl on 8096 port, subsonic ssl on another port with 3 different ssl cert and that all OK


    BUT the open vpn, don't works.


    router 192.168.0.1 with port 1195 nat to server 1195 port in UDP AND TCP
    but what usage off plugin setting? UDP, TCP?
    wins?
    dns server???
    PAM aut????
    dns search domain???

    Rasbery pi 4 (4go), OMV 5.5.5-1(usul), rasbian mini on 32Go SD 100MO/sec, kernel 5.4.51-V7I+, data on intenso 5TO usb3 32MOcache

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!