Setting up openvpn

  • PS- The OpenVPN mobile app is called OpenVPN Connect (in the Google Play Store). You have to get the zipped cert file on your phone, unzip it and then import it. The is a drop down to import in that app. You can guide it to where you have those files.

    When I download the zipped file, it unzips to be a .crt file. But the OpenVPN clients all want .ovpn files. What am I doing wrong?

    EDIT: I realized the zip contains ALL the needed files after all.

  • Hello I have setup openvpn this morning, I Can acces form my Android app, but my network is on 192.168.0.xx and I can't acces to my other network machine, juste the NAS when I'm connected to the vpn. How can I do for acces others machine, before with my Qnap its work very well with pptp vpn.

    Thanks for answer. Have good day.

  • This is OpenVPN AS yes? You should be able to access any of your machines that are on the same subnet as the NAS, using HTTP/HTTPS or SSH. Tell us how you are trying to access the other machines.

  • I have setup openvpn plugin not the AS, when I'm connected to the vpn form my Android I type in chrome for acces to my gateaway and its not working.

  • using 0mv 3.0.82 here, tried installing Openvpn AS, said a dependency is missing and is cannot be installed openvpn-as
    i installed the otther plugin instead - configured everything, added my user, clicked on download certificate, nothing happens... how do i get it??

  • You need to enable the repo that has openvpn-as. Not sure what one it is in right now. I've been away from forums for a while. Aaron can answer this:


    It might be in the plex repo.

    they are all already enabled... :( still does not install. and now removing the other plugin gives me a dashboard error RPC stuff i mentioned.

  • I only installed one of them - I tried the -as first, gave me an error that it could not find dependency, did not isntall at all.
    SO i tested to other one, installed - could not get the certificates thru the webUI - began reading this thread,
    attempted removing the only installed plugin for VPN - RPC error on dashboard.

    here is the stuff you asked for.

    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    ii openmediavault 3.0.82 all Open network attached storage sol
    ii openmediavault 3.6 all backup plugin for OpenMediaVault.
    ii openmediavault 3.2.2 all OpenMediaVault CouchPotatoServer
    ii openmediavault 1.0 all GnuPG archive keys of the OpenMed
    ii openmediavault 3.2 all command-line based binary newsgra
    ii openmediavault 3.4.25 all Package Repositori
    ii openmediavault 3.0.6 all OpenVPN plugin for OpenMediaVault
    ii openmediavault 3.8.1 all OpenMediaVault Plex Media Server
    ii openmediavault 3.0 all OpenMediaVault Radarr plugin
    ii openmediavault 3.3 all Reset Permissions
    ii openmediavault 3.7.1 all snapraid plugin for OpenMediaVaul
    ii openmediavault 3.2 all OpenMediaVault Sonarr plugin
    ii openmediavault 3.0.18 amd64 OpenMediaVault plugin for ZFS

    uninstalling openVPN gave me this erorr on dashboard:

    Error #0:exception 'OMV\Rpc\Exception' with message 'RPC service 'OpenVpn' not found.' in /usr/share/php/openmediavault/rpc/ trace:#0 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('OpenVpn', 'getList', Array, Array, 1)#1 {main}

  • Yeah, try it in command line.

    reinstalled plugin...
    error is gone.
    attempted from cli
    same error is back on dashboard.

    openvpn plugin is still listed on the plugin section on the left-hand side menu, and not gone from teh services dashboard widget.

    but dpkg -l openm* doesn`t list it anymore

    i would not mind using this plugin instead os AS, but after installing it I could not downlaod teh certificate, clicking on the UI - download cert. does nothing, this is I'm trying to unisntall it.

  • Did you refresh your browser??? javascript can be leftover in the browser cache so you need to refresh your browser.

    now I feel like an idiot, because i did close it before and relaunch it, and the error was still there, now testing on incognito wondow (clear cache) the error is gone.

    now i can get back to installing openvpn-as :)

    this is the message i talked about not being able to isntall openvpn-as

    Reading package lists...
    Building dependency tree...
    >>> *************** Error ***************
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-openvpnas 2>&1' with exit code '100': Reading package lists...

    Building dependency tree...

    Reading state information...

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    openmediavault-openvpnas : Depends: openvpn-as (>= 2.0.24) but it is not installable
    E: Unable to correct problems, you have held broken packages.
    <<< *************************************

    can I just do a apt-get openvpn-as and try to force it in @tekkb

  • Yes, AS is way to go unless you are using an ARM device. I hope that package is in the plex repo. You can check if it is available before installing the plugin by:

    apt-cache policy openvpn-as

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!