Secure FTP access

  • Hi,

    I configured my FTP service so now I access my NAS from Internet using Filezilla client successfully, the only issue is that Filezilla shows a message that "the server is not secured".

    How to secure it?

    SSL/TLS Tab:

    Enable SSL/TLS connections: Unchecked
    Certificate: None (when check "Enable SSL/TLS connections" the drop-down list shows "None" only)
    Required: Unchecked: This option requires clients to use FTP over TLS when talking to this server.
    No certificate request: Unchecked: This option causes the server to not send a certificate request during a SSL handshake.
    No session reuse required: Unchecked: The requirement that the SSL session from the control connection is reused for data connections is not required.
    Implicit SSL: Unchecked: This option will handle all connections as if they are SSL connections implicitly.
    Extra options: (blank)

    Many thanks,

  • I've just created a certificate and used it with FTP, unfortunately now I cannot access ftp folders!
    I'm using Active mode so I only NAT my PUBLIC_IP:21 to my NAS:21, do I need to NAT any other port?
    What about other above-mentioned options?

  • I fixed it. full steps:

    1. System > Certificates:

    • Create a certificate (to be used with FTP SSL/TLS)

    2. Services > FTP > Settings:

    • Passive FTP: Check "Use the following port range": 14100-14110
    • Masquerade Address: <Public IP> : To fix FileZilla message "Server sent passive reply with unroutable address"

    3. Services > FTP > SSL/TLS:

    • Check "Enable SSL/TLS connections": To fix FileZilla message "Server not secured"
    • Choose the certificate created in step 1

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!