Emby - Can't play anything: Error starting ffmpeg / Access denied

  • Hello,


    I have recently installed the Emby plugin however I'm not able to play a show I wish to watch. This is the error I can locate on the logs when I try:



    It repeats this same error multiple times for some reason.


    I have tried to give emby permission to the file. I added emby to the users group and given both emby user and users group permissions through ACL to the video.


    Code
    root@nuc:~# id emby
    uid=114(emby) gid=65534(nogroup) groups=65534(nogroup),100(users)
    root@nuc:~#


    Does anyone have any suggestions?

  • 1. make shared folder media, use default drop down which give read only to others.
    2. add privileges (read/write for main user) to the shared folder
    3. share it with samba
    4. Connect to the share via the network from another machine
    5. Create subfolders in the media share (e.g. Music, TV, Movies, etc...)

  • You should not be using ACL for a media folder. There is no reason for this. Also, the data drive you are using should be ext4 or xfs.


    Hey, my filesystem is XFS.


    I don't understand why I should not use ACL? Initially when I installed Sonarr, it wasn't able to move or arrange my files. I used ACL to give it read/write permission to my media and now it can. What is a better way of doing this if ACL isn't ideal, and why should we avoid ACL? Is it dangerous?


    I don't want to lose my media, I have about 3 terabytes of it and my download speed is 300kb/s so it's not easy to replace.


    1. make shared folder media, use default drop down which give read only to others.
    2. add privileges (read/write for main user) to the shared folder
    3. share it with samba
    4. Connect to the share via the network from another machine
    5. Create subfolders in the media share (e.g. Music, TV, Movies, etc...)


    I don't understand why this is required when Plex is able to play these files with no problems. Is there something I've done to let Plex work but not Emby? I can't help but feel I've broken something.

  • ACL is not dangerous. It just does not work very well and the way you are using it is not it's intended purpose. You can create a new media share and then the subfolders. Then move you files over to the new subfolders. I can't talk more now. Busy with my kid.

  • ACL is not dangerous. It just does not work very well and the way you are using it is not it's intended purpose. You can create a new media share and then the subfolders. Then move you files over to the new subfolders. I can't talk more now. Busy with my kid.


    I hope your kid is okay :)


    I really dislike Samba, but have tried this method to see if I could get it working. Every time I try move files from the old share to the new share through my notebook it moves at around 500kb/s and times out after moving 50mb.


    Tried to do it through nano on my notebook because I think if I do it via SSH as a mv command it will keep/copy the current permissions which are invalid?


    One other thing that you may find interesting is I went in to /etc/init.d/emby.conf and changed the user and group to plex and plex. As I said before, Plex works just fine with playing the media. When emby is using the plex account, I assume it should have the same access, however it does not. Is it possible that the problem does not lie with the permissions on the video file?


    This feels like a problem more related to Emby than OMV or the plugin, so I'm going to cross post this problem to their forums and will certainly let you know if I find a solution. :)

  • You could use nfs. Why don't you change directory into a folder where a file you are trying to play and run the state command on that file.


    stat filename


    Give results so we can see what mess is going on.


    What you are doing in the emby.conf is nuts.



    Your media shares need chmod 755. That is it. The last 5 is read for all other users. You are messing with way to much. The plex and emby users are used to run the working directories for each service. You should not be changing the user of one service to the user of the other.


    OMG

  • If you have a media share that is all fragged because of bad perms or acl you can:


    1) Go to Access Rights Management / Shared folders
    2) Then select the Reset Permissions TAB
    3) The default selection for Permissions is all you need for media shares.
    4) Select the shared folder in question. Put a check in clear ACLs. Then click on Save.


    Adding emby to the users group is fine if you want to be able to store meta data alongside the files in your media's data folders. In emby there is a check mark you need to select to allow this as well.


  • Hehe I'm just learning :)


    State doesn't work, but stat does, is it the same?



    If you have a media share that is all fragged because of bad perms or acl you can:


    1) Go to Access Rights Management / Shared folders
    2) Then select the Reset Permissions TAB
    3) The default selection for Permissions is all you need for media shares.
    4) Select the shared folder in question. Put a check in clear ACLs. Then click on Save.


    Adding emby to the users group is fine if you want to be able to store meta data alongside the files in your media's data folders. In emby there is a check mark you need to select to allow this as well.


    So instead of using ACLs, I should find which user a service is running and add that to the users group to give it access to files?

  • I CHMOD'ed it to 0755 and went back to Emby and the file still won't play;


    Code
    root@nuc:/media/c1a0b79e-e049-4412-8668-c1963a2b91db/TV/Halt and Catch Fire/Season 2# stat Halt\ and\ Catch\ Fire\ -\ S02E06\ -\ 10Broad36\ HDTV-720p.mkv
    File: `Halt and Catch Fire - S02E06 - 10Broad36 HDTV-720p.mkv'
    Size: 1045301888 Blocks: 2041616 IO Block: 4096 regular file
    Device: 811h/2065d Inode: 871300839 Links: 1
    Access: (0755/-rwxr-xr-x) Uid: ( 1000/ sabnzbd) Gid: ( 100/ users)
    Access: 2015-08-08 21:59:14.793971037 +0800
    Modify: 2015-07-06 03:02:28.000000000 +0800
    Change: 2015-08-10 10:02:21.912460377 +0800
    Birth: -
  • Try this:
    cd /media/c1a0b79e-e049-4412-8668-c1963a2b91db
    chown -R root:users TV


    Give results of this:
    id sabnzbd


    Also, are any other files playing OK?


    Still no luck :(


    root@nuc:/media/c1a0b79e-e049-4412-8668-c1963a2b91db# sudo chown -R root:users TV
    root@nuc:/media/c1a0b79e-e049-4412-8668-c1963a2b91db# id sabnzbd
    uid=1000(sabnzbd) gid=100(users) groups=100(users)
    root@nuc:/media/c1a0b79e-e049-4412-8668-c1963a2b91db#

  • Is your ffmpeg in this location?


    /media/c1a0b79e-e049-4412-8668-c1963a2b91db/emby/ffmpeg/20150331/ffmpeg


    This folder should have been moved:


    /media/c1a0b79e-e049-4412-8668-c1963a2b91db/emby/ffmpeg


    It does not run because the data disks are mounted noexec
    The plugin normally moves this folder to the system drive and leaves symlink in the old location.

  • Hi, i have the same problem :



    Thats the File from the error Msg:

    Code
    ll "/media/3a55f751-488d-4fb9-8374-33e99b0e8331/Musik/Elektronisches/Komplettes/Alben/DaxRiders/Backintiown/dax riders - Backintown.mp3"
    -rw-rw-r-- 1 root users 480940 Mai 3 2002 /media/3a55f751-488d-4fb9-8374-33e99b0e8331/Musik/Elektronisches/Komplettes/Alben/DaxRiders/Backintiown/dax riders - Backintown.mp3


    I'm very new to omv, justed installed yesterday. I put emby DB dir on my Snappool, because i have omv on an usb stick an didnt know if the Flash Plugin also
    protects the typical emby folders. Permissions look good. (emby:nobody) . I added emby to "users" group, because i wanted to save Metadata in the Media Folders.

    Code
    ll ffmpeg/
    insgesamt 4
    drwxr-sr-x 4 emby nogroup 4096 Aug 9 09:35 20150331
    ll ffmpeg/20150331/
    insgesamt 56032
    -rwxrwxrwx 1 emby nogroup 28714176 Aug 9 09:35 ffmpeg
    -rwxrwxrwx 1 emby nogroup 28652992 Aug 9 09:35 ffprobe
    drwxr-sr-x 2 emby nogroup 4096 Aug 9 09:35 fonts


  • What do you mean?
    I have made a Folder emby under the aufs pool, and created a share because somewhere i read that you shouldnt use diect access to the drives if using aufs....


    as i said, i'm really new to omv and still try to figure out the best concept for file access ... also have different problems with aufs, cant rename Folders in a smb share,
    can't access some Folders in the same directory even the have the same permissons :(

  • Malefunk, your ffmpeg looks good. So you do not have all the problems of the previous poster. There seems to be some problem with permissions and the pool. This is something I would have to take some time to investigate. Maybe another user using aufs can bring some clarity to this. If not I'll try to look at it when I have time. My personal life is taking up most of my spare time currently.

  • Malefunk, what filesystem did you use for you data drives???


    Also, how did these become chmod 777 ???
    -rwxrwxrwx 1 emby nogroup 28714176 Aug 9 09:35 ffmpeg
    -rwxrwxrwx 1 emby nogroup 28652992 Aug 9 09:35 ffprobe

  • Hi, thanks for your time :)


    I used ext4


    For the emby share it's propably because i created the share with everyone read/write because i could not choose the emby User directly.


    Or is it unnecessary to create a share for emby db folder?


    It's really strange.. Emby sees all files, can modify metadata, download jpegs and save it.. Only play brings Access denied..

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!