openmediavault-calibre installation error

  • Hi,


    I'm trying to install the plugin and I'm getting this:


    Reading package lists...
    Building dependency tree...
    Reading state information...


    >>> *************** Error ***************
    Failed to execute command 'export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-calibre 2>&1': Reading package lists...


    Building dependency tree...


    Reading state information...


    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:


    The following packages have unmet dependencies:
    openmediavault-calibre : Depends: python-poppler but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    <<< *************************************


    System is running OMV 2.18. Any help?

  • python-poppler:
    Installed: (none)
    Candidate: 0.12.1-8+b1
    Version table:
    0.12.1-8+b1 0
    400 http://ftp.cvut.cz/debian/ wheezy/main amd64 Packages


    and if I'm trying to install it


    The following packages have unmet dependencies:
    python-poppler : Depends: python-gtk2 (>= 2.10.0) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.


    I made a apt-cache clean, nothing.


    If I try to install calibre directly, it seems to work (I didn't proceed but I didn't get error message)

  • apt-get install calibre uses a much older version of calibre from the debian repo. The plugin downloads it from the author's website.


    Try installing python-gtk2.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The following packages have unmet dependencies:
    python-gtk2 : Depends: python-numpy (>= 1:1.6.1) but it is not going to be installed
    Depends: python-numpy-abi9
    E: Unable to correct problems, you have held broken packages.


    python-numpy:
    Installed: (none)
    Candidate: 1:1.6.2-1.2
    Version table:
    1:1.6.2-1.2 0
    400 http://ftp.cvut.cz/debian/ wheezy/main amd64 Packages



    The following packages have unmet dependencies:
    python-numpy : Depends: libblas3 but it is not going to be installed or
    libblas.so.3 or
    libatlas3-base but it is not going to be installed
    Depends: libgfortran3 (>= 4.3) but it is not going to be installed
    Depends: liblapack3 but it is not going to be installed or
    liblapack.so.3 or
    libatlas3-base but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

  • There is something very strange going on with your system. Post the output of the following:


    cat /etc/apt/sources.list
    cat /etc/apt/sources.list.d/*
    omv-mkconf omvextrasorg aptclean

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!


  • I'm guessing that you probably had the unstable repo uncommented at some point and a new library from unstable is causing this problem. This is one of the problems with using unstable/experimental repo.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Calibre uses a lot of python packages. One of the older python packages that Calibre needs must not like one of the newer ones.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!