Harddrive Failure OMV won't load

  • Hi there. I might have misunderstood how OMV works, however one of the raid harddrives has failed and OMV won't start. OMV is on a separate drive. If I remove the RAID then OMV loads, but with them in it won't

    This kind of confuses me as I would expect to be able to load OMV regardless.

    One the boot up screen I get hundreds of errors saying Failed Command: Read FPDMA Queued. and error { UNC } and lots of other issues, it goes through this cycle many times

    Finally it says, unexpected consistency, run fsck manually, fsck died with exit status 4. File system check failed.

    As I say, I understand that one of the disks has gone down, but I would have expected OMV to load, being as its not on that disk.



  • Also if anyone could tell me how to run the disk check that would be cool. I tried to boot into recovery mode but when it gets to asking for root password it says it is incorrect (It is absolutely the one I entered when I set it up)

  • Hi Yes. I set this up for my mate many moons ago and forgot what I had did, unfortunately his IP network at home is different to mine so I could not get to the OMV gui. I have simply reinstalled OMV. I now have access and remembered that it was not raid I set up just two disks one backing up to the other.

    The problem I now have is the one good disk is inserted and shows a mounted. However when I try and add a shared folder where it says 'volume' when I click this it does not show up. This has me confused as it is mounted. Any ideas?

  • OK ignore all that I am in and worked out my error I must have set the drivers up as a raid. 1 disk cannot be read because of the Superblock Error. Certain threads suggest that it is possible to retrieve.

    I ssh into OMV and ran FSCK confirming the superblock invalid.

    It suggested I ran: e2fsck -b 8193 <device>

    I did that for the drive in question and then it said:

    -bash: syntax error near unexpected token `newline'

    If I could save any of the data that would be super cool.

  • Sorry for the stream of posts, it was my bad on the newline thing.

    So basically I am trying to fix the superblock, but I am far from expert at this. I have established with the superblock backups are saved but attempts to replace using e2fsck -b always returns an error stating its looking for an EXT2 filesystem, I don't know why this would be, presumably I am using the wrong command?

  • try (if it is ext4)

    fsck.ext4 /dev/sdX


    fsck.ext4 /dev/sdX1

    replace the "X" with the correct Character (a-z) for your drive

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!