openmediavault-docker-gui Testing

  • I think we should add rtorrent by diameter to the repo.
    I don't use rtorrent, but i spent once a whole day trying to run it. This one comes ready to start, no php, apache, libtorrent fiddling around.


    edit: Also roaming today in the hub found this one


    https://hub.docker.com/r/jwilder/nginx-proxy/ This will act as a reverse proxy for all containers exposing ports, passing the domain name as env var.


    For this you will have to move the port 80 in omv to another one.

  • Is there a specific reason why you'd need to run a reverse proxy inside of a docker plugin?


    I was able to use reverse proxy for apps running inside and outside of docker by dropping a config file into the following directory:


    Code
    /etc/nginx/openmediavault-webgui.d/


    Though it would be good to have a GUI in either each of the plugins or a separate "plugin".


    Here's what I currently have (emby is the plugin running inside Docker), with OMV running on port 80 still:


  • @der-brumm-baer could you test and replace the plugin code in /etc/rc.local with the following code:



    Then reboot and see if the permission denied problem is gone. This works on my test system, but so did the old code too...

  • Hello,


    I put your code into the /etc/rc.local + two additional Logging Lines so it looks like this


    Therefore the messages "DOCKER-INIT Start /etc/rc.local" appears in /var/log/syslog
    But i don't get the end Message


    df -h gives the following



    So it looks like the /etc/rc.local doesn't finish to the end and i end up with permission denied

  • Hello


    I simply tried this in /etc/rc.local


    Code
    logger -t DOCKER STOP PID `pidof docker`
    service docker stop
    logger -t DOCKER STOPPED `pidof docker`
    mount -o remount,bind,defaults /var/lib/docker/openmediavault
    logger -t DOCKER MOUNT
    service docker start
    logger -t DOCKER STARTED `pidof docker`


    I did x reboots and everytime my containers started

  • I did have it like that from the beginning but had quite some issues with it. Could you test to change the code:

    Code
    if [ $DOCKERSERVICE -eq 1 ]; then
    i=5
    fi


    to:

    Code
    if [ $DOCKERSERVICE -eq 1 ]; then
    break
    fi


    But with proper indentation :-)

  • If I remove the for loop completely and only keep the service docker start line in itself and put the logging line AFTER that command, nothing shows in syslog. However if I move the logging BEFORE the start of docker service it shows up in the log. I just love the Docker service... :-)

  • Hello,


    after I've found this about runtime of docker init script
    https://github.com/docker/docker/issues/11181
    and this about failures in /etc/rc.local
    http://askubuntu.com/questions…nd-what-can-i-do-about-it


    I moved the stopping / mounting / starting part to an extra script in /usr/local/bin and started this through /etc/rc.local
    Maybe this could be an solution


    /usr/loca/bin/dockerremount


    and in /etc/rc.local I only put

    Code
    /usr/local/bin/dockerremount


    Maybe the parts about /var/run/docker-ssd.pid are not needed

  • Wow! Really good info! However I have an issue on my system with the service not stopping with your script (even though the line in syslog is there saying it's been stopped). This results in two mount lines pointing to /var/lib/docker/openmediavault (one with noexec and one without).

  • @der-brumm-baer Could you try with this code in dockerremount script:



    This works for me and should let the Docker service exit properly.


    EDIT: I had two entries in fstab which caused the previous issue... This code should however work fine when fstab is correct... :-)

  • Hello,


    I tried your script and my script in a virtualbox vm and on real hardware
    both failed on each system, but not everytime. :cursing:
    Yesterday my script worked on both but today no success ?(:cursing:
    At the moment i have no idea what to try next, maybe a combination of both, or changing the init script of docker to remount
    during startup :huh:

  • Hello,


    I did a short test with


    crontab -e


    adding this line

    Code
    @reboot /usr/local/bin/dockerremount.sh


    My script work in 3 out of 3 reboots on my real hardware setup
    Your Script hangs while trying to stop the service


    I received your Mail now, the checks above i did with the old version

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!