Updates Can't Install

  • I've just started receiving an error when I try to install any updates in OMV.


    Code
    Error #4000:
    exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get update 2>&1': E: Malformed line 30 in source list /etc/apt/sources.list.d/omv-extras-org-stoneburner.list (dist parse)
    E: The list of sources could not be read.' in /usr/share/openmediavault/engined/rpc/apt.inc:277
    Stack trace:
    #0 [internal function]: OMVRpcServiceApt->update(NULL, Array)
    #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('update', NULL, Array)
    #3 /usr/sbin/omv-engined(500): OMVRpc::exec('Apt', 'update', NULL, Array, 1)
    #4 {main}
  • Have some similar message today, anyway the update for openmediavault (2.1.15) and omvextrasorg (2.3) seems to be installed but remain at the update panel. If i try it whit apt-get this is happen.


    Code
    root@omv:~# apt-get update && apt-get upgrade
    E: Missgestaltete Zeile 40 in Quellliste /etc/apt/sources.list.d/omv-extras-org-stoneburner.list (»dist parse«)
    E: Die Liste der Quellen konnte nicht gelesen werden.


    Line 40 shows that


    Code
    deb https://dl.bintray.com/openmediavault-plugin-developers/stoneburner-docker2 main

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!