I can't mount my disks

  • I have 2 hdd's with I was able to mount before separably but not both. Now I can't mount any. Even though I can see them and reformatted them in parted live. I couldn't do it in omv because they were busy? This is the error of the first drive.


    Failed to mount '5964e6c8-3655-4a7f-bdd3-fdb40fc5cb6b': mount: can't find /media/5964e6c8-3655-4a7f-bdd3-fdb40fc5cb6b in /etc/fstab or /etc/mtab


    Fout #6000:
    exception 'OMVException' with message 'Failed to mount '5964e6c8-3655-4a7f-bdd3-fdb40fc5cb6b': mount: can't find /media/5964e6c8-3655-4a7f-bdd3-fdb40fc5cb6b in /etc/fstab or /etc/mtab' in /usr/share/openmediavault/engined/module/fstab.inc:90
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/config.inc(206): OMVModuleFsTab->startService()
    #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
    #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
    #4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(899): OMVRpc::exec('Config', 'applyChanges', Array, Array)
    #5 [internal function]: OMVRpcServiceFileSystemMgmt->mount(Array, Array)
    #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
    #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('mount', Array, Array)
    #8 /usr/sbin/omv-engined(500): OMVRpc::exec('FileSystemMgmt', 'mount', Array, Array, 1)
    #9 {main}

  • Ok doing that I could mount one of my 2 drives the one that still doesn't mount is connected with a e-sata to sata converter is that a problem?
    also my external drive doesn't mount anymore either. Same error for both "Can't find it in fstab"

  • FSTAB


    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    # / was on /dev/sdb1 during installation
    UUID=c73cc0d6-1b49-42ef-98b0-4874a72becfc / ext4 noatime,nodira time,errors=remount-ro 0 1
    # swap was on /dev/sdb5 during installation
    #UUID=c1d4d925-8466-4b7b-8626-999a83400689 none swap sw 0 0
    /dev/sda1 /media/usb0 auto rw,user,noauto 0 0
    /dev/sda2 /media/usb1 auto rw,user,noauto 0 0
    /dev/sda5 /media/usb2 auto rw,user,noauto 0 0
    /dev/sdb1 /media/usb3 auto rw,user,noauto 0 0
    /dev/sdb2 /media/usb4 auto rw,user,noauto 0 0
    /dev/sdb5 /media/usb5 auto rw,user,noauto 0 0
    # >>> [openmediavault]
    UUID=4f622d93-b4e6-4c9e-9023-cd79fce01844 /media/4f622d93-b4e6-4c9e-9023-cd79fce 01844 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aqu ota.group,jqfmt=vfsv0,acl 0 2
    UUID=56a6dd1d-1e33-47ff-a2cc-93fcb95e0660 /media/56a6dd1d-1e33-47ff-a2cc-93fcb95 e0660 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aqu ota.group,jqfmt=vfsv0,acl 0 2
    UUID=8a8dfdf4-160b-4e87-9f8e-22b085c09cd3 /media/8a8dfdf4-160b-4e87-9f8e-22b085c 09cd3 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aqu ota.group,jqfmt=vfsv0,acl 0 2
    UUID=33b47395-ccda-4b6c-bf85-386f3b4f8d96 /media/33b47395-ccda-4b6c-bf85-386f3b4 f8d96 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aqu ota.group,jqfmt=vfsv0,acl 0 2
    /dev/disk/by-uuid/465CD2EA5CD2D431 /media/465CD2EA5CD2D431 ntfs defaults,nofail 0 2
    /dev/disk/by-uuid/5CE80614E805ECD8 /media/5CE80614E805ECD8 ntfs defaults,nofail 0 2
    UUID=c145fbeb-2346-4712-905c-f02e8c25e6e4 /media/c145fbeb-2346-4712-905c-f02e8c2 5e6e4 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aqu ota.group,jqfmt=vfsv0,acl 0 2
    UUID=6e42714b-2f47-4275-b122-ff50c370d38f /media/6e42714b-2f47-4275-b122-ff50c37 0d38f ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aqu ota.group,jqfmt=vfsv0,acl 0 2
    none /media/c3c6caa3-1998-4310-b9f7-256db7c6623e aufs br:/media/4f622d93-b4e6-4c 9e-9023-cd79fce01844=rw:/media/56a6dd1d-1e33-47ff-a2cc-93fcb95e0660=rw:/media/8a 8dfdf4-160b-4e87-9f8e-22b085c09cd3=rw:/media/33b47395-ccda-4b6c-bf85-386f3b4f8d9 6=rw:/media/c145fbeb-2346-4712-905c-f02e8c25e6e4=rw,sum,create=mfs 0 0
    # <<< [openmediavault]


    BLKID


    /dev/sda1: UUID="4f622d93-b4e6-4c9e-9023-cd79fce01844" TYPE="ext4" LABEL="d1"
    /dev/sdb1: UUID="56a6dd1d-1e33-47ff-a2cc-93fcb95e0660" TYPE="ext4" LABEL="d2"
    /dev/sdc1: UUID="8a8dfdf4-160b-4e87-9f8e-22b085c09cd3" TYPE="ext4" LABEL="d3"
    /dev/sde1: UUID="33b47395-ccda-4b6c-bf85-386f3b4f8d96" TYPE="ext4" LABEL="d4"
    /dev/sdd1: LABEL="d5" UUID="19a584bf-5b21-47c3-9d8d-5b1714b3eed3" TYPE="ext4"
    /dev/sdg1: UUID="c73cc0d6-1b49-42ef-98b0-4874a72becfc" TYPE="ext4"
    /dev/sdg5: UUID="c1d4d925-8466-4b7b-8626-999a83400689" TYPE="swap"
    /dev/sdf1: LABEL="parity" UUID="6e42714b-2f47-4275-b122-ff50c370d38f" TYPE="ext4"
    /dev/sdh1: UUID="ddd3f165-0537-4536-aaa8-0509741e17ce" TYPE="ext4"

  • Delete this and reboot. What is the other UUID that is causing a problem? I see the one above.


    Code
    /dev/sda1 /media/usb0 auto rw,user,noauto 0 0
    /dev/sda2 /media/usb1 auto rw,user,noauto 0 0
    /dev/sda5 /media/usb2 auto rw,user,noauto 0 0
    /dev/sdb1 /media/usb3 auto rw,user,noauto 0 0
    /dev/sdb2 /media/usb4 auto rw,user,noauto 0 0
    /dev/sdb5 /media/usb5 auto rw,user,noauto 0 0
  • d2 is the second of my 4 2TB hdd's yes I didn't notice it at first but my external drive also doesn't want to mount like the others I also reformatted it in parted live .
    The drives that are not mounting are "d5" and "parity" both 4TB drives I labeled them that way for my snapraid setup.

  • The external drive is a just a cheap one with a hitachi hdd inside. It worked perfecly before because I used it to transfer my backup.
    The other 2 are WD greens 4TB ones. one of them d4 was used a while as parity drive in my snapraid. But after I got the second one and tried to hook it up using e-sata to sata these problems arose.
    I can see them all in the physical devices tab so it should work right?

  • Ofcourse I'm getting a random new problem that no one else has -_-
    anyway here is the output of df -h


    Bestandssysteem Grootte Gebruikt Besch Ge b% Aangekoppeld op
    rootfs 6,7G 3,2G 3,2G 5 1% /
    udev 10M 0 10M 0% /dev
    tmpfs 801M 832K 800M 1% /run
    /dev/disk/by-uuid/c73cc0d6-1b49-42ef-98b0-4874a72becfc 6,7G 3,2G 3,2G 5 1% /
    tmpfs 5,0M 0 5,0M 0% /run/lock
    tmpfs 1,6G 0 1,6G 0% /run/shm
    /dev/sda1 1,8T 458G 1,4T 2 5% /media/4f622d93-b4e6-4c9e-9023-cd79fce01844
    /dev/sdb1 1,8T 593G 1,3T 3 3% /media/56a6dd1d-1e33-47ff-a2cc-93fcb95e0660
    /dev/sdc1 1,8T 230G 1,6T 1 3% /media/8a8dfdf4-160b-4e87-9f8e-22b085c09cd3
    /dev/sde1 1,8T 433G 1,4T 2 4% /media/33b47395-ccda-4b6c-bf85-386f3b4f8d96
    none 7,2T 1,7T 5,5T 2 4% /media/c3c6caa3-1998-4310-b9f7-256db7c6623e
    /dev/disk/by-uuid/c73cc0d6-1b49-42ef-98b0-4874a72becfc 6,7G 3,2G 3,2G 5 1% /var/folder2ram/var/lib/monit
    folder2ram 4,0G 12K 4,0G 1% /var/lib/monit
    /dev/disk/by-uuid/c73cc0d6-1b49-42ef-98b0-4874a72becfc 6,7G 3,2G 3,2G 5 1% /var/folder2ram/var/tmp
    folder2ram 4,0G 0 4,0G 0% /var/tmp
    /dev/disk/by-uuid/c73cc0d6-1b49-42ef-98b0-4874a72becfc 6,7G 3,2G 3,2G 5 1% /var/folder2ram/var/lib/rrdcached
    /dev/disk/by-uuid/c73cc0d6-1b49-42ef-98b0-4874a72becfc 6,7G 3,2G 3,2G 5 1% /var/folder2ram/var/lib/openmediavault/rrd
    folder2ram 4,0G 22M 3,9G 1% /var/lib/rrdcached
    folder2ram 4,0G 1,1M 4,0G 1% /var/lib/openmediavault/rrd
    /dev/disk/by-uuid/c73cc0d6-1b49-42ef-98b0-4874a72becfc 6,7G 3,2G 3,2G 5 1% /var/folder2ram/var/lib/php5
    folder2ram 4,0G 0 4,0G 0% /var/lib/php5
    /dev/disk/by-uuid/c73cc0d6-1b49-42ef-98b0-4874a72becfc 6,7G 3,2G 3,2G 5 1% /var/folder2ram/var/spool
    /dev/disk/by-uuid/c73cc0d6-1b49-42ef-98b0-4874a72becfc 6,7G 3,2G 3,2G 5 1% /var/folder2ram/var/log
    folder2ram 4,0G 16K 4,0G 1% /var/spool
    folder2ram 4,0G 22M 3,9G 1% /var/log

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!