OMV Web GUI Timeout too Low or S.M.A.R.T. Issue

  • My current server apparently isn't a fan of some of the S.M.A.R.T. commands. It's on in the BIOS, but when OpenMediaVault tries to enumerate SMART devices in the GUI, the Kernel spews the following for each dive:


    Code
    [70311.776099] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
    [70311.781773] ata3.00: failed command: READ LOG EXT
    [70311.787396] ata3.00: cmd 2f/00:06:03:00:00/00:00:00:00:00/00 tag 14 pio 3072 in
    [70311.787397] res 40/00:00:00:4f:c2/00:00:00:00:00/00 Emask 0x4 (timeout)
    [70311.798653] ata3.00: status: { DRDY }
    [70311.804263] ata3: hard resetting link
    [70312.128030] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [70312.141401] ata3.00: configured for UDMA/133
    [70312.146988] ata3: EH complete


    This occurs for every device in turn. If it gets through all of this, everything works fine but it looks like this takes 5-15 seconds for each device. I have 6 disks, so that means can take over a minute. It looks like OMV's GUI communications timeout is 60 seconds. This means I get a communication error before it can finish this process. Is there anywhere I can increase this? I've tried a few settings in the nginx config file and several php5-fpm config files, issuing service nginx restart && service php5-fpm restart each time but it looks like the timeout continues to be 60 seconds.


    Alternatively, does anyone know how to fix this SMART issue? The board is a SuperMicro X7QC3 with an Intel 7300 Chipset. Here's the output of lspci:



    And "for EACH in /dev/sd?; do echo ===== ${EACH} =====; smartctl -i ${EACH}; done":


    Note that sda-sdf are SATA, the rest are USB.


  • Hokay, I think I figured it out. All numbers are in seconds (hence the multiplication lower down).


    The things that need to change (all of these) are:


    /etc/openmediavault/php.ini:
    max_execution_time = #


    /etc/php5/fpm/pool.d/openmediavault-webgui.conf:
    php_value[max_execution_time] = #


    /etc/nginx/sites-enabled/openmediavault-webgui:
    fastcgi_read_timeout #s;


    /etc/default/openmediavault:
    OMV_HTTPREQUEST_TIMEOUT="#*1000"


    After these changes:
    service openmediavault-engined restart && service php5-fpm restart && service nginx restart


    The last one did not exist, but was referenced in rpcproxy.inc and was the one I was missing. Afterwards, I went through and tried to increase one at a time until the time it took before failure went up.It took just over 2 minutes to enumerate my SMART devices. Yay.

  • I've been looking for some way of increasing the timeout. There is a user of the ZFS plugin who has too many datasets defined to enumerate them all within 60 seconds. This should probably help, even if it would be even better to speed up the enumeration itself... :-)

  • Anybody know how to do this in OMV4? I did change the PHP timeout to 600 seconds in the settings (also applied) but it still kicks the timeout after 30 seconds.


    I also set the OMV_HTTPREQUEST_TIMEOUT variable to 600000 (600 sec) but it looks like it doesn't apply these changes... Also the default value of OMV_HTTPREQUEST_TIMEOUT is 60000 (60 sec) but it already timeout at 30 sec...

    OMV 4 - Ryzen 7 1700 (8 Cores / 16 Threads 65W TDP) - 32 GB DDR4 ECC
    128 GB OS SSD - 256 GB Plex SSD - 32 TB RAIDZ2 (6x8TB HGST NAS)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!