Docker GUI plugin now stable

  • Not for Plex and Emby (the two that usually cause this issue)... Read the thread. He had his config folder on a separate drive. Even if they take it into consideration, like you they think it's an issue with their config files, and it's not


    Unfortunately it's not an issue... Until it is. To a new user this could be daunting, that's all I'm saying.

  • I think that this are issues that should be easily avoided improving the wiki.
    I'm fine will help as much as I can with it, since I made so many trial and error :)

    Intel G4400 - Asrock H170M Pro4S - 8GB ram - Be Quiet Pure Power 11 400 CM - Nanoxia Deep Silence 4 - 6TB Seagate Ironwolf - RAIDZ1 3x10TB WD - OMV 5 - Proxmox Kernel

  • From what I have seen of Portainer, existing containers are imported into it. But unless I am missing something, I am unable to edit the Environment Variables or Volumes and Bind Mounts of those imported containers.

    It seems possible to edit those.


    In the container details click "Duplicate/Edit".
    Then make the changes you need to do.
    Then click "Deploy the container".


    The position of the button is confusing. It is on the left side just above the "Advanced container settings".
    When you click, you will get a warning which is telling you, that the old container will be deleted and a new one will be created. Which is what you want.

  • Thanks.


    Portainer SERIOUSLY needs file browser capability so that you can navigate to and select a directory.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Did a quick search but only found a request for a general file explorer integrated in Portainer, which is not exactly what we are looking for.

    I'd settle for a general file explorer integrated in Portainer if the fully qualified path displayed could be copied to the clipboard and then pasted wherever it is needed. Tab completion would be OK too.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Thanks.


    Portainer SERIOUSLY needs file browser capability so that you can navigate to and select a directory.

    problem is portainer runs most commonly inside a container so is pretty much useless to browse inside unless you pass a path, but it would need some sort of remapping

  • Probably easy (read:stupid) question: how to connect portainer to the local docker instance when installing it via the button with OMV-extras on usul? I am offered four different options (local, agent, edge agent & Azure). Normally, for a local docker I would choose 'local' and set /var/run/docker.sock as the URL. But not even unix:///var/run/docker.sock nor as an agent with http://local_ip:8000 achieve a connection. Am I missing something fundamentally?
    The portainer docker is apparently started as docker run --name=Portainer --hostname=xyz--env="PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" --volume="/var/r
    un/docker.sock:/var/run/docker.sock" --volume="portainer_data:/data" --volume="/data" -p 8000:8000 -p 9000:9000 --restart=unless-stopped --det
    ach=true portainer/portainer (according to runlike), so it should be okay to connect locally via the docker.sock option.


    Any ideas?

  • how to connect portainer to the local docker instance when installing it via the button with OMV-extras on usul?

    You shouldn't have to do anything. Just click local and it should take you to portainer.


    Normally, for a local docker I would choose 'local' and set /var/run/docker.sock as the URL. But not even unix:///var/run/docker.sock nor as an agent with http://local_ip:8000 achieve a connection.

    Is the docker-ce package fully installed? dpkg -l | grep docker I have had no problems with this on any systems.


    The portainer docker is apparently started as

    Here is the start command - https://github.com/OpenMediaVa…bin/omv-installdocker#L67

    omv 5.5.13 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • You shouldn't have to do anything. Just click local and it should take you to portainer.

    I re-installed docker & portainer and it worked. Now it did not present me with the mask to input a URL.

    Is the docker-ce package fully installed? dpkg -l | grep docker I have had no problems with this on any systems.

    Apparently it was installed correctly:
    ii docker-ce 5:19.03.1~3-0~debian-buster amd64 Docker: the open-source application container engineii docker-ce-cli 5:19.03.1~3-0~debian-buster amd64 Docker CLI: the open-source application container engine


    Anyway, it works now, thanks for pointing me in the right direction (dpkg, etc.).

  • I re-installed docker & portainer and it worked. Now it did not present me with the mask to input a URL.

    Did you just click the button in omv-extras again or manually from the command line? Just trying to make the button as easy as possible.

    omv 5.5.13 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Again with the button, don't know what went wrong the first time. Was a fresh installation of OMV5 on ESXi 6.5.

    I'm glad hitting the button again worked. I will have to try a few more times on fresh installs. Did you upgrade OMV and the OS (install everything in the Updates tab) before clicking the button?

    omv 5.5.13 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Did you upgrade OMV and the OS (install everything in the Updates tab) before clicking the button?

    Yes, everything was updated prior to installing docker & portainer. As far as I remember, there were no updates available for the freshly installed 5.05 ISO image.


    edit: Switched back to OMV4 as portainer is too confusing for me right now and the formidable GUI for docker in 4 is just the best. Maybe I'll try again when OMV5 is officially released and I have a bit more time but currently, portainer just appears to be lacking compared the the GUI we got right now.

  • Linux newbie here but would it be possible to add the option to set a umask value to the web GUI? As I understand the daemon now runs with default umask 022 and would like to change this.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!