Docker GUI plugin now stable

  • There was an issue with latest backport kernel by zol but that was solved some weeks ago if I am not mistaken. The plugin was ported by the same dev that did docker.
    Anyway upgrade from 2.0 to 3.0 is not recommended as you would encounter issues. Fresh install is better and also bear in mind that some plugins were abandoned. You can always check bintray webpage to check which are available.

  • 3.0 was still in testing stage

    Some of the plugins are but OMV 3.x is stable (even if not official declared).


    Also I read something about ZFS not working in 3.0.
    Could be that I was wrong?

    zfs plugin is working.

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Last night I tried upgrading a system clone in the spare disk. :sleeping: It failed miserably. So I reverted.


    And I had another issue with docker while the plugin was offline. Suddenly my containers where not starting and then they disappeared. Without me doing anything, only rebooting. But in the end I managed to diagnose it.


    I store the data from my containers in a ZFS array. Its mounted in the Z2 directory, and I refer it in my containers, for example: /Z2/docker-data/emby.
    Well, since the docker plugin failed me, the docker service was starting before ZFS during boot. As the pool was not yet imported, there where no content in Z2, so docker decided to create the referenced folders. ZFS then attempted to mount the pool on Z2, but failed because the directory wasn't empty. So I missed the pool and containers because they couldn't boot.


    I'll try to do a clean install on the spare disk, but we'll see how my arrays will be restored. Guys, that's not a nice situation. Now I'm thinking on the several installations I've done to some customers and where left alone at the datacenter. ||

  • I've tested a few upgrades lately and they went fine (other than the dbus error which is unavoidable and not OMV's fault). So, I need to figure out which plugins are causing the problem. So, far I have eliminated omv-extras and minidlna :)

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Everytime I open Docker GUI in OMV2 I receive the following error.



    Code
    Error: "couldn't connect to host" - Code: 7
    Error #0: exception 'OMVModuleDockerException' with message 'Error: "couldn't connect to host" - Code: 7' in /usr/share/omvdocker/Utils.php:63 Stack trace: #0 /usr/share/omvdocker/Utils.php(125): OMVModuleDockerUtil::doApiCall('http://localhos...') #1 /usr/share/openmediavault/engined/rpc/docker.inc(145): OMVModuleDockerUtil::getImages('42005', true) #2 [internal function]: OMVRpcServiceDocker->getImages(Array, Array) #3 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array) #4 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getImages', Array, Array) #5 /usr/sbin/omv-engined(500): OMVRpc::exec('Docker', 'getImages', Array, Array, 1) #6 {main}

    I uninstalled and re-installed as well. Still happening.

  • I just want to update my suggestion list based on what I saw in Docker for OMV3 (I had OMV2 at the time).

    I'll try to scavenge the source code and collaborate... don't know if I know enough web development for this.

  • EDIT: Problem solved by restarting docker in terminal, as was previously discussed in this thread.


    Hi, I installed the plugin on my OMV 2.2.13 and activated it. I am new to docker. What do I have to do to be able to use handbrake or handbrake.cli with docker? I installed docker to be able to install handbrake without messing up the original OMV.


    Do I have to do an Ubuntu installation as docker image/container? If so, how is it done over the GUI?


    Does the '"Error: couldn't connect to host:" - Code 7' have relevance? It occures when I click on "Docker" under "Services" or when I click on the "search" bar inside the docker service GUI.


    Thank you very much.


  • Good that you could make the error go away. Regarding handbrake though the plugin is not well suited for the task. Check the instructions of the handbrake docker image to see what command to run in cli. The plugin is intended to run docker images as services, like Web services and such.

  • I also experienced this "Error: "couldn't connect to host" - Code: 7" issue when I installed the plugin. For me the issue was that the kernel was too old. Looking in /var/log/docker.log there was written:


    Code
    time="2016-12-22T13:46:18.074304788+01:00" level=fatal msg="Your Linux kernel version 3.2.0-4-amd64 is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer."


    So I am using Stone Burner 2.2.13 and the Kernel was 3.2.0-4. I installed the Backports-Kernel through OMV-extras. That one is 3.16.0-0 which seems to suffice. After rebooting with this kernel the plugin does not complain anymore and the docker service is running.

  • I tested docker with 4.8 kernel, seems working well, what crash? any logs?

    I tracked down the issue to the following error:


    root@SRV{/var/log}: systemctl -l status docker.service
    docker.service - Docker Application Container Engine
    Loaded: loaded (/lib/systemd/system/docker.service; enabled)
    Drop-In: /etc/systemd/system/docker.service.d
    +-openmediavault.conf
    Active: failed (Result: exit-code) since Tue 2017-01-03 12:40:03 BRST; 6min ago
    Docs: https://docs.docker.com
    Process: 1183 ExecStart=/usr/bin/docker daemon -H fd:// $DOCKER_OPTS $OMVDOCKER_API $OMVDOCKER_IMAGE_PATH (code=exited, status=1/FAILURE)
    Main PID: 1183 (code=exited, status=1/FAILURE)



    Jan 03 12:40:02 SRV docker[1183]: time="2017-01-03T12:40:02.688499871-02:00" level=warning msg="[!] DON'T BIND ON ANY IP ADDRESS WITHOUT setting -tlsverify IF YOU DON'T KNOW WHAT YOU'RE DOING [!]"
    Jan 03 12:40:02 SRV docker[1183]: time="2017-01-03T12:40:02.692333359-02:00" level=info msg="libcontainerd: new containerd process, pid: 1326"
    Jan 03 12:40:03 SRV docker[1183]: time="2017-01-03T12:40:03.712906769-02:00" level=error msg="[graphdriver] prior storage driver \"aufs\" failed: driver not supported"
    Jan 03 12:40:03 SRV docker[1183]: time="2017-01-03T12:40:03.712961967-02:00" level=fatal msg="Error starting daemon: error initializing graphdriver: driver not supported"
    Jan 03 12:40:03 SRV systemd[1]: docker.service: main process exited, code=exited, status=1/FAILURE
    Jan 03 12:40:03 SRV systemd[1]: Failed to start Docker Application Container Engine.
    Jan 03 12:40:03 SRV systemd[1]: Unit docker.service entered failed state.

  • It seems that Kernels 4+ don't like AUFS

    That is why we removed aufs from the unionfilesystems plugin. It isn't in the backports kernel and won't be in future versions of Debian. You need to switch to use devicemapper - Docker GUI plugin now stable

    omv 5.5.17-3 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.2
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!