Dual network connection problem

  • Hello ! I installed OMV 2.1.17 Stone Burner on a HP microserver gen 8 that have two network interfaces. After this step I cofigured the network connections and there is something I didn't like with them. I assigned a static ip for each network interface: eth0 has the ip 192.167.1.90 and eth1 has the ip 192.167.1.91 and I connected both to a unmanaged switch. My computer is connected too at this switch and the switch is connected further to a router.


    This is what happens with my NAS:
    -When the interface eth0 is connected to the switch and the interface eth1 is not connected, I can connect through eth0 to both ips as the eth1 has a cable connection (but it hasn't). The router sees eth0 with its ip 192.167.1.90 in the ARP list and not with the ip 192.167.1.91 .
    -When the interface eth0 is not connected and the interface eth1 is connected (and has a static IP), I can't acces both network connections.
    -When both network connections are physical connected to the switch, the router can't see none of them in the ARP list.
    -When I let the router to assigne an ip to interface eth1 through DHCP and the eth0 has a static IP, the router sees both connexions in the ARP. If I disconnect eth0 the router can see eth1 in the ARP list (with its dynamic ip) and I have acces to my NAS (through eth1).


    I wonder if this is the real way that OMV uses the dual network connection. I need both network connections to work independently of one another.

  • You can not have two network interfaces in the same machine that define or belong to the same network.


    192.167.1.90 & 192.167.1.91 are in same network on the same machine. This is an ambiguous configuration and not allowed.


    You need to reassign one of the interfaces to define another network. How this does or does not play with the rest of your setup is not known.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I need one group of users to acces the NAS through the first network interface (wich has the ip 192.167.1.90) and the other group of users to have acces through the second network interface (192.167.1.91). With this configuration I'm looking to avoid overriding one network interface.

  • I need one group of users to acces the NAS through the first network interface (wich has the ip 192.167.1.90) and the other group of users to have acces through the second network interface (192.167.1.91). With this configuration I'm looking to avoid overriding one network interface.


    The reason you are overriding one network interface is because they are numbered that way - it's ambiguous and will not work.


    And it makes no difference if the addresses are private or public, it's still ambiguous.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • Linux allows more than 1 IP address on a machine. Even multiple addresses on one nic. You may need to set it up on the command line tho if it is not working with the gui.


    I think ink you should give a description of your network and explain what you are trying to do. Then you can get better answers.

    If you make it idiot proof, somebody will build a better idiot.

  • Linux allows more than 1 IP address on a machine. Even multiple addresses on one nic. You may need to set it up on the command line tho if it is not working with the gui.


    I think ink you should give a description of your network and explain what you…


    Thank you for this replay. I have 6 IP cameras and I want them to send their data on the NAS. To avoid overloading the first network interface I need to use the second nic on the same network as first (192.167.1.x). The second nic will have a static IP (192.167.1.91) without setting its default gateway and DNS. Only the first nic (192.167.1.90) will have set the default gateway and DNS.


    Yesterday, I installed Xpenology (the pirated version of the software created by Synology). It worked well on both network interfaces without the problems I expected with OMV. Every nic responded to its IP, without interfering one another. The bad part with Xpenology is that it has lower speeds then OMV. I'm pretty sure that OMV has a software bug here which must be repaired.

  • Post your /etc/network/interfaces file. There could be a bug I don't know. I think I would try a bond of the 2 nics. If your switch can do link aggregation try that. If not maybe round robin. A bond should be able to handle and balance the load better than 2 individual nics.

    If you make it idiot proof, somebody will build a better idiot.

  • I'm not sure why @gderf is being downvoted. While Linux certainly does allow multiple IP addresses on the same subnet the behavior is *not* the same as having multiple *interfaces* on the same subnet. The issue is that Linux, by default, will identify a given IP address as "itself", and will thus respond to ARP requests for any of it's IPs with the first interface on that network (or a random interface on that network?). This is a solvable problem but is less than intuitive and oftentimes a bit complex. Useful reading:


    http://unix.stackexchange.com/…-for-correct-arp-response
    http://linux-ip.net/html/ether-arp.html (specifically the "ARP Flux" section)
    http://askubuntu.com/questions…ddresses-with-one-gateway
    https://www.centos.org/forums/viewtopic.php?t=8401


    Also, you may actually want to solve your issue via Bonding rather than doing load balancing the way you're trying to do.

  • I'm not sure why @gderf is being downvoted. While Linux certainly does allow multiple IP addresses on the same subnet the behavior is *not* the same as having multiple *interfaces* on the same subnet. The issue is that Linux, by default, will identify a given IP address as "itself", and will thus respond to ARP requests for any of it's IPs with the first interface on that network (or a random interface on that network?). This is a solvable problem but is less than intuitive and oftentimes a bit complex. Useful reading:


    http://unix.stackexchange.com/…-for-correct-arp-response
    http://linux-ip.net/html/ether-arp.html (specifically the "ARP Flux" section)
    http://askubuntu.com/questions…ddresses-with-one-gateway
    https://www.centos.org/forums/viewtopic.php?t=8401


    Also, you may actually want to solve your issue via Bonding rather than doing load balancing the way you're trying to do.


    I never thought linux would behave in this manner with network interfaces. I don't know if my unmanged switch support bounding the two nic, but if there is a way I could give it a try.


  • I never thought linux would behave in this manner with network interfaces. I don't know if my unmanged switch support bounding the two nic, but if there is a way I could give it a try.


    Nope, LACP is a behaviour that requires configuration, thus it would be impossible for an unmanaged switch to have LACP capability (how can you tell which port to be trunked without management?)

  • And I would say that, OP you don't need to worry about saturating the network interface of OMV, 1000M/6 = 166.67Mbps, it would be an unrealistic bitrate for a normal IP camera to produce, even for transcoding over network it would be hard to reach 100Mbps bitrate per client unless you are doing with ultra high quality 4K/8K video source.

  • I'm not sure why @gderf is being downvoted.


    Sometimes when you tell an OP something they don't want to hear, they react that way. I did twice; he did twice.


    But I see that he removed the downvotes. I won't ask why.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • I don't like disklikes. It is just stupid when someone is taking the time to try and help you. I've seen plenty of cases where people used a disklike and they were the one that was wrong. Be nice people.


    +1 just for taking the time to help others.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!