Guide: Installed OpenMediaVault on my old HP EX470 Mediasmart Windows Home Server

  • I recently switched my HP EX470 Mediasmart home server from the end-of-lifed Windows Home Server to OpenMediaVault. At least upon first impression, everything seems to be working other than the internal network adapter, so I've used a USB network adapter in lieu of that. I've pasted in my notes on the process below in case it helps anyone else making the transition.


    To start off with, you need access to a normal computer from which to prepare the install media. You'll also need a USB keyboard.


    On the other computer:
    Download the ISO image of OpenMediaVault.
    My other computer was on Windows, so I then used http://unetbootin.sourceforge.net/ to restore the image onto the flash drive.


    The wiki installation instructions weren't clear on this, but you'll then need a second flash drive on which to install OpenMediaVault. The ISO image is an installer drive, and it'll then install OpenMediaVault onto your second flash drive.


    Once I had OpenMediaVault installed on my second flash drive, I booted it on my regular computer. Using the root password I set during the installation process, I logged in and deleted the existing network configuration with the following command:
    rm /etc/udev/rules.d/70-persistent-net.rules


    On the HP MediaSmart home server:
    I removed all existing hard drives and inserted the flash drive into the bottom most rear USB port.


    I plugged a USB keyboard into the front USB port. Powering on the home server, I repeatedly tapped F12 for 10 seconds. Apparently, this will bring up the boot menu. There is no harm in over pressing F12, so you can keep pressing to be sure. After that, I carefully hit the down arrow on the keyboard exactly 7 times, which apparently selects the USB boot option, and then hit enter. Doing this a single time seems to apply it every time in the future, as my home server always boots from the USB drive now. The process was developed by people who hacked VGA output into their servers.


    From another computer:
    After a minute or two, I connected to the home server's IP address from a web browser, and the OpenMediaVault interface came up!


    However, you'll note that only the bottom and third from the bottom drive bays are functional. This is due to a BIOS setting that will need to be changed.


    Back on the HP Mediasmart home server:
    Using a USB keyboard, after power on as soon as the health LED begins to blink blue and red hit DELETE and it'll become solid (either blue or red depending on what it was when you hit delete) and enter the BIOS. Advice on the Internet suggests to wait 5 seconds after this to ensure it's in the BIOS. Press F10 and then ENTER to save and reboot. Repeat this process until you're fully comfortable with the process of blindly booting into the BIOS and safely saving and exiting.


    Boot into the BIOS again.


    Press the DOWN arrow three (3) times to reach Integrated Peripherals
    Press ENTER to select


    Press the DOWN arrow one (1) time to select SIS OnChip PCI Device
    Press ENTER to select


    Press the DOWN arrow eight (8) times to select SIS Serial ATA Mode
    Press PGDN one (1) time to select 4P(IDE)+4S(IDE).


    Press F10 one (1) time to save and exit.
    Press ENTER to confirm.


    The server should now reboot again, and when you login again to the OpenMediaVault web interface, drives in all four bays should now be recognized.


    Quirks:
    As noted above, the internal Ethernet has serious problems. To read more about those problems, as well as more about how I got the BIOS working to recognize all four drives, see this thread.
    The health light on the front of the server will continuously flash when it's booted - apparently it does that whenever Windows isn't installed.
    The HP Mediasmart server have a built-in small flash partition for Windows recovery. This appears in OpenMediaVault as a 250MB drive connected to /dev/sda.
    My HP Mediasmart is old enough that the CMOS battery is worn out. As a result, if the server is unplugged for an extended period, it will lose the BIOS settings, and I need to set the BIOS ATA mode again to re-enable drive bays 2 and 4.

  • @creamsicle: I doubt if you still follow this thread, but in case you do:
    I had an old EX490 lying around with some extra RAM installed (and I think I replaced the CPU years ago). I followed your instructions and installed OMV on the device. It’s early days, but it seems to run smoothly now.
    I did notice a few things:
    - booting from one USB stick to create another wasn't that easy, since all my PC's use UEFI. OMV doesn’t support UEFI and the install-stick will not boot on UEFI systems. Took me a while and some great help from this forum to realize I could set the BIOS to legacy. That worked ^^
    - I read the stuff about having to get into the bios to het the upper two bays to work. I couldn't get there using the trick you describer. However much I tried, I couldn’t get the health light to stop blinking. To my surprise, I didn't need to; all 4 bays are active and accessible without any changes.


    I could not have gotten this far without your article. Thanks for your excellent descriptions on what to do! :thumbsup:


    One question; long ago, when I used this box for Windows Home Server, a 2TB drive was the maximum supported capacity. Do you know if the box supports larger drives with OMV installed?

  • Hi
    This site has given me a lot of insight into the conversion of the HP Home Media Server; I have a EX470 which I pick up on eBay earlier this year. Mainly because my World Book I had in service from 2009 till early this year when the power unit gave up, so time for something new. In comes a HP Media server which silly me thought I may be able to get it to work with W10. But no, so rethink, then I thought about Openmediavault. I read about the constant update the unit does and that the OS is on a flash Rom. I acquired a header cable from Germany very expensive, connected the SVG screen, keyboard and mouse. Then booted the gem up, I was surprised to find the IDE set up in the Cmos consisted of not only the four drives in the bays but, as follows:


    IDE 0 Master
    “ “ 0 Slave
    “ “ 2 Master
    “ “ 2 Slave
    “ “ 3 Master
    “ “3 Slave
    Plus a 247 MiB USB Disk Serial No AA04012700036216 hiding somewhere in the box.
    Anyway I was lead to understand that the uppermost disk was the primary Sata Disc, so after about 30 times of trying to load openmediavault on to the disc with no luck. When it came to the setup point were the primary disc is partitioned the setup could not find a disc in the top slot. So sitting down with a cup of tea and thinking about it, I decided to boot the box and move the disc about each boot cycle and I found the the bottom slot in the box was the IDE 2 Master next one up was the Slave, then third slot up was IDE 3 then top slot was IDE 3 Slave. I then booted the unit with 1Tb Drive in IDE 2 Master and still when it come to the system disc being formatted and portioned no go.
    Then I decided to try something new, with a reconfiguration to the boot order I set 1 st boot USB external, 2nd boot HDD and all following boot devices disabled. With the Openmediavault setup disc in a CD Rom connected to the bottom USB socket I did a Cmos save and reboot after the post as the CD Rom started to spin I Hot Shoed the bottom Sata HDD into the bottom slot of the unit. And let it go. The part of the setup arrived at the HDD format and partitioning and there was the drive, I clicked continue and away it went to complete the install. When the install was completed I checked the drives in Openmediavault it showed the 1Tb HDD with the system on it and a USB Disk 247.50MiB disc which I did not mount in Openmediavault. I then Shut the system down and hoped it would reboot once I had fitted the other 3 Drives (3Tb HDD’s) into the unit. On reboot I once again checked the Cmos settings to make sure they had not reset, all was good, so on with the reboot. The system rebooted OK I then configured the 3 x 3TB drives as ext4 File system not a Raid 5 which I wanted to do but I would have lost to much room, I have since backed up all my movies and 20% of my TV Recordings a total of 1.5Tb. With Plex plug-in installed I can watch the films and TV recordings on my TV connected to the hard wire network. I have yet to upgrade the Memory chips to 4Gb from 2Gb the CPU seems fast enough no stream to the TV or any of the PC, Laptops or Tablets. To do this on any HP Media Server it is necessary to have a header cable the upload cannot be done without it unless you like a lot of frustration and hassle. The noticeable thing is, it has been running now for a few weeks, a number of times been rebooted and no time has it tried to update its self. On the boot into Linux it does show widows Vista in the background but nothing else. The Linux system has updated a few times but not Vista. It is still in the process of being loaded with data and is performing well with access the the filing system from windows desktop works well.


    Will keep you updated


    steve

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!